8
OP5T Enable VoWiFi and VoLTE after update OnePlus 5T to Android 10

  1. popos1
    Donut Jul 5, 2020

    popos1 , Jul 5, 2020 :
    After update OP5T to Android 10, missing switches to VoWiFi and VoLTE.
    In this tutorial i will show how to fix this.
    It is enabling VoWiFi and VoLTE even in Poland with T-Mobile, Orange and Play carrier.

    This method doesn't required root.

    0. Make sure that you just enabled the VoWiFi and VoLTE in your carrier first !!!
    1. Download and install the old LogKit: https://www.dropbox.com/s/8kk77qzo4bmlmko/com.oem.oemlogkit_1.0-1_minAPI28(nodpi)_apkmirror.com.apk?dl=1 or https://www.apkmirror.com/apk/onepl...lease/onepluslogkit-1-0-android-apk-download/
    3. Type *#800# --> oneplus Logkit --> Function Switch --> enable VoLTE and VoWifi switch
    4. Open Settings --> WiFi & Intenet --> SIM & netwok --> enable VoLTE and VoWifi switch
    5. Connect your phone to PC
    6. Type *#801# in Phone app and enable Serial and Full-port switch
    7. Download and unzip the EfsTools with config files includes: https://www.dropbox.com/s/aslwvbmegy0dbin/EfsTools-0.10-modded-1.2-win32.zip?dl=1
    8. Open CMD as Administrator on the PC, navigate to the folder where you extract the files (eg. cd c:\EfsTools-0.10-modded-1.2-win32)
    9. Now execute the following commands:
    EfsTools.exe efsInfo

    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim

    EfsTools.exe writeFile -i mcfg_autoselect_by_uim -o /nv/item_files/mcfg/mcfg_autoselect_by_uim -s 1

    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -v

    EfsTools.exe uploadDirectory -i mcfg_sw.mbn -o / -s 1

    Thats it. Commands with "1" on at the end are for the second SIM card.

    My example on the T-mobile carrier:
    upload_2020-7-5_20-51-50.png

    Oryginal tutorial:
    https://4pda.ru/forum/index.php?showtopic=875898&st=15900#entry97287430

    Method for Android 9 with PDC app, doesn't work anymore
     
    Last edited: Aug 9, 2020

    #1
  2. twinsen
    Cupcake Jul 6, 2020

    twinsen , Jul 6, 2020 :
    Please mention clearly, if this method needs root or not.
     

    #2
  3. P1518862919541
    Cupcake Jul 6, 2020

    P1518862919541 , Jul 6, 2020 :
    Got to step 9 with unrooted phone, keep telling me "Critical error. The operation has timed out."
     

    #3
  4. G_Lars_Rücker_bIIQ , via OnePlus 5 , Jul 6, 2020 :
    I opened CMD with administrator rights on the computer, after that IT worked in my case.
     

    #4

  5. #5
    twinsen likes this.
  6. wholehog2
    Donut Jul 7, 2020

    wholehog2 , Jul 7, 2020 :
    It's work for me for Volte but not for Vowifi on my 5T with android 10 and Bouygues Telecom french carrier.
     

    #6
  7. P1518862919541
    Cupcake Jul 7, 2020

    P1518862919541 , Jul 7, 2020 :
    I must not be doing it right, do you copy and paste step all in one go or one line at a time? sorry, im a total noob
     

    #7
  8. G_Lars_Rücker_bIIQ , via OnePlus 5 , Jul 7, 2020 :
    One line at a time, it always beginns with EfsTools...
     

    #8
  9. O1594148917522
    Cupcake Jul 7, 2020


    #9
  10. gsser
    Eclair Jul 7, 2020

    gsser , Jul 7, 2020 :
    thanks for the guide. now i have volte and vowifi working perfect.
     

    #10
  11. O1594148917522
    Cupcake Jul 7, 2020


    #11
  12. P1518862919541
    Cupcake Jul 8, 2020

    P1518862919541 , Jul 8, 2020 :
    Done all the commands but still don't see the icon. Any able to get this working for Telstra Australia? Thanks
     

    #12
  13. yasador
    Cupcake Jul 10, 2020

    yasador , Jul 10, 2020 :
    hi, when i paste first line of commands, this message show. plz help me.
    EfsTools.exe : The term 'EfsTools.exe' is not recognized as the
    name of a cmdlet, function, script file, or operable program.
    Check the spelling of the name, or if a path was included,
    verify that the path is correct and try again.
    At line:1 char:1
    + EfsTools.exe efsInfo
    + ~~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (EfsTools.exe:Stri
    ng) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException
     
    Last edited: Jul 10, 2020

    #13
  14. G_Boris_Sweden_lHuW
    Gingerbread Jul 13, 2020


    #14
  15. denis1276
    Cupcake Jul 13, 2020

    denis1276 , Jul 13, 2020 :
    I have oneplus5 unroot with android 10.0.0
    I follow the steps but:
    1. in sim and network settings i see only "wifi calling" and not volte
    2. when i complete all steps volte icon is appear and work in all calls after i close and open again wifi calling.
    volte field its not in network settings.
    3. when i reboot phone, wifi calling its still there but volte icon its not appear, and volte calling its not working even if close and open again wifi calling
     

    #15
  16. twinsen
    Cupcake Jul 14, 2020

    twinsen , Jul 14, 2020 :
    I need to say, that on OnePlus 5 this method does not work. All commands pass, but no VoLTE or VoWiFi appears on the status bar. I use on SIM1 - Plus (Nowy Plus Internet na Kartę) and on SIM2 - nju mobile (Orange branch). Maybe some different MBN file is needed here? On Android 9, I was using profile for EE (Everything Everywhere UK), and it was working.
     

    #16
  17. oblivio
    Jelly Bean Jul 17, 2020

    oblivio , Jul 17, 2020 :
    Thanks for the tutorial it worked perfectly on oneplus 5t without root.
     

    #17
  18. W1595064571530
    Cupcake Jul 18, 2020

    W1595064571530 , Jul 18, 2020 :
    You're a master! It works wonderfully. VoLTE and VoWifi activated after reboot on OnePlus 5T

    Thanks thousand times!
     

    #18
  19. Slurpino
    Cupcake Jul 22, 2020


    #19
  20. Aurelian1
    Donut Jul 22, 2020

    Aurelian1 , Jul 22, 2020 :
    I tested this method on Oneplus 5 and Oneplus 5T.
    Both were patch on android 9 using "Telefonica-UK" PDC but after update to android 10 the settings were reversed and there was no more VoLTE and VoWIFI.
    After some research I found this post and tried out the patch that was mention above.

    I waited for almost 2 weeks before I posted this confirmation.
    VoLTE and VoWifi are working now on both phones perfectly. Even better then on android 9. Before, on android 9, on VoWifi if I was getting out of range of the wifi and back again VoWifi was functional again only after phone restart. Now, on android 10, with this patch is working perfectly no matter how many times I go out of 4G or Wifi range. The functions switch on and off as it supposed to.
    I saw that someone above says that does not work on OP5. For my phone at least, I can confirm it works and is stable.

    After I will patch my sisters phone (Oneplus 6t) I will come with feedback for that one also.

    Thank you!
     
    Last edited: Jul 24, 2020

    #20
    popos1, astracd and pedritopl like this.