Enabling WiFi calling?

  1. Darksurf
    Donut Dec 20, 2018

    Darksurf , Dec 20, 2018 :
    Just got the 6T McLaren, plugged in my Google Fi SIM. Went looking for an option to enable WiFi calling, can't find it. I've spoke with other people who've had better luck than I and found just disabling cellular data allows them to make WiFi calls, but this isn't working on mine. I checked settings, internet & WiFi, SIM & Network, SIM1 and there is no WiFi Calling option to enable. I do get VoLTE though. how can I enable WiFi calling on this phone?


    edit: just inserted my brother's TMO SIM and WiFi calling option appeared like magic, switched back, option disappeared. is there supposed to be data on the SIM that enables WiFi calling or does the phone recognize the carrier and enable it? technically Google Fi is just an MVNO with TMO as the default/primary carrier it uses.
    Last edited: Dec 20, 2018

  2. Darksurf
    Donut Dec 21, 2018

    Darksurf , Dec 21, 2018 :
    learned I could override with *#800# OnePlus Logkit -> function switch -> VoWiFi switch (check box). then going back to the SIM option and enabling WiFi calling.

    unfortunately now it complains that I need to connect to wireless to make a call and I am connected to wireless. any suggestions?

  3. Ohalfie
    Froyo Dec 21, 2018

    Ohalfie , Dec 21, 2018 :
    I thought that just TMO offered wi-fi calling option for the 6T. Works fine on mine (using TMO).

  4. Darksurf
    Donut Dec 22, 2018

    Darksurf , Dec 22, 2018 :
    works fine on TMO. Google Fi's primary carrier is TMO. This should be running on TMO towers, but because it's an MVNO I don't ever see VoWiFi come up on my phone and I can never use WiFi calling. I'm trying to figure out could be causing this. maybe I need to add info to the APN for WiFi calling? I'm not sure what makes it work.

  5. Schwermzilla
    Cupcake Jan 7, 2019

    Schwermzilla , Jan 7, 2019 :
    I too am struggling with this on the OnePlus 6,
    I had Wi-Fi calling on T-mobile, switched to FI and I only have VoLTE option now unless overriding it via settings (with similar results to your's)

    I am guessing its an APN or MVNO issue. I will let you know if I get it to work

  6. bengio
    Cupcake Feb 13, 2019

  7. v0 HaVoK 0v
    Ice Cream Sandwich Feb 14, 2019

  8. roshanravan
    Cupcake Mar 10, 2019

  9. G_Thomas_Connelly
    Cupcake Mar 18, 2019

    G_Thomas_Connelly , Mar 18, 2019 :
    I tried installing a ported google dialer in conjunction with the "*#800# OnePlus Logkit -> function switch" to enable wifo calling. Still nothing :-(

    Has anyone else made any progress?

    BTW, it works on a moto z2 play which is in the same category as the OP6T from a Google Fi perspective. They say that "wifi calls might work".

  10. G_Peter_Haubrich_dyBt
    Cupcake Jun 7, 2019

  11. nikhs247
    Cupcake Aug 14, 2019

    nikhs247 , Aug 14, 2019 :
    It is a bit late to answer, but posting the response that I got From Google Fi Support Team for One Plus 6T.

    Please be informed, features sets like will vary between devices Designed for Fi and those Compatible with Fi (Android, iOS). Devices Designed for Fi include the full roster of features, but devices Compatible with Fi have certain limitations.

    The following features won't work on Compatible with Fi devices:
    • Network Switching: Devices will always be connected to T-Mobile's network and won't switch to Sprint or US Cellular.
    • Wi-Fi calling and messaging: Making calls over Wi-Fi and sending messages over Wi-Fi will not be possible in these devices.
    • Smooth Security & Network transitions: Will not be offered in Compatible with Fi devices.

  12. drl431
    Marshmallow Aug 14, 2019

    drl431 , Aug 14, 2019 :
    For what its worth, my OP6 works well with Simple Mobile, an MVNO that uses the TMO network (in south Florida). Started out a couple of years ago with a Samsung, then last year, got the OP6 and just moved over the sim card. VoLTE and VoWiFi stayed and remains functional.

    ironass likes this.
  13. jonarooni
    Eclair Aug 21, 2019

    jonarooni , Aug 21, 2019 :
    You are on the right track.

    Before you go through the *#800# menu, you'll need to download and install "com.oem.oemlogkit_1.0-1.apk".

    The following site has a guide that will help:


    Good luck!

    sokhangoo likes this.
  14. roshanravan
    Cupcake Dec 10, 2019

  15. roshanravan
    Cupcake Dec 10, 2019

    roshanravan , Dec 10, 2019 :
    I have enabled the Wi-Fi calling from Fi app but I still don't see the option in the phone settings, only i see VoLTE, not sure how to proceed

  16. inareshmatta
    Froyo Jan 15, 2020

  17. roshanravan
    Cupcake Jan 19, 2020

    roshanravan , Jan 19, 2020 :
    Not available in Android 10