0
Third Party Software Error: App Not Installed

  1. raaomoka
    Honeycomb May 10, 2015

    raaomoka , May 10, 2015 :
    ANSWERED

    Hey guys,

    Ran into a problem while managing apps on my OnePlus One (running Rooted, running CyanogenMod Android Lollipop). Was in the process of installing an older version of an app over it's current installation, then I all of a sudden began experiencing this problem:

    Screenshot_2015-05-10-08-13-30.png

    This affects installation of apps from the Amazon AppStore. I'm able to download them, tap the install button, but it always shows that "App Not Installed" error message regardless of where I initiate the installation from, even from my PC (via SnapPea).

    Could anyone advice me on how to fix this? I have tried clearing the app caches and reflashing the system update (without losing all my settings/configurations)...still the same error message.

     
    Last edited: May 10, 2015

    #1
  2. raaomoka
    Honeycomb May 10, 2015


    #2
  3. Da Bozz
    Gingerbread May 10, 2015

  4. raaomoka
    Honeycomb May 10, 2015

    Best Answer
    raaomoka , May 10, 2015 :
    OK, so after hours of patience, it appears I've found the root 'cause of the problem, and it's a stupidly simple problem that took a while to figure out (never saw a solution online). Feel sorry for those who wiped their entire device 'cause of it.

    Eitherway, during the process of managing my apps, it appears some bug (or perhaps misconfiguration on my part) 'caused the preferred install location to change to "Removable SD Card", which the OnePlus One obviously doesn't have. Unfortunately, Android isn't coded to show a proper error message for this problem.

    Here's how to fix it:
    1.) Go to Settings, scroll down and select "Storage"
    Fixing 'App not installed Error' (1).png
    2.) Select "Apps"
    Fixing 'App not installed Error' (2).png

    3.) From the overflow menu, select "Preferred install location"
    Fixing 'App not installed Error' (3).png

    4.) Select "Internal device storage"
    Fixing 'App not installed Error' (4).png

    5.) Vuala, the problem should now be fixed
    Hope that helps ☺
     

    #4
    JVS96 likes this.
  5. aljalil
    Froyo Aug 2, 2015

    aljalil , Aug 2, 2015 :
    Hey,
    Got the same issue, since I upgraded to CM12.
    I am unable to install some of the apps I was using (evernote, dolphin browser).

    Updated the settings as you're suggesting but unfortunately still being stuck :(
    Thanks anyway
     

    #5
  6. JVS96
    Eclair Sep 4, 2015

    JVS96 , Sep 4, 2015 :

    I don't get such an option when I open the overflow menu. There's only the option to reset app preferences. I'm running oxygen OS. Please help....
     

    #6
  7. 3007
    Cupcake Sep 16, 2015

    3007 , Sep 16, 2015 :
    Same problem here?
    Are you solve this?
     

    #7
  8. 3007
    Cupcake Sep 16, 2015

    Attached Files:


    #8
  9. mohsin92
    Cupcake Oct 4, 2015


    #9
  10. Tavjot
    Froyo Nov 29, 2015


    #10
  11. raaomoka
    Honeycomb Dec 4, 2015

    raaomoka , Dec 4, 2015 :
    Have you guys tried changing the install location as I pointed out? Could you take a screenshot of where you're stuck and explain what's missing?
     

    #11
  12. takaoyuudai
    Eclair Jan 9, 2016

    takaoyuudai , Jan 9, 2016 :
    Me also got same prob when to install my apps using release version.

    I think prob because certificate not same as before as me is using debugging and release version.

    So, to solve it just go to apps setting and click tab ALL
    skroll down until found your apps, click on it, press setting on top right menu. Uninstall for all users.

    Try install again..
     

    Attached Files:


    #12
  13. go8soccer
    Ice Cream Sandwich Feb 9, 2016

    go8soccer , Feb 9, 2016 :
    This is why I love the oneplus forum.. Great write up! I suffered this very issue on stock oxygen 2.1.4. Google worked its magic, just like @raaomoka did here on the forums.
     

    #13
  14. Etheonor
    Cupcake Mar 22, 2016


    #14
  15. Affwan Hassan
    Cupcake Apr 17, 2016

    Affwan Hassan , Apr 17, 2016 :
    Dint work on my oneplus 2...
    Did not find the" internal storage" option on install location as suggested earlier...

    Any suggestions guys?
     

    #15
  16. jstepa
    KitKat Apr 17, 2016

    jstepa , Apr 17, 2016 :
    Suggestion, maybe try asking in OPT category?
     

    #16
  17. CertifiedSammy
    Donut Nov 5, 2016


    #17
  18. NickJohns
    Cupcake Jan 30, 2017


    #18