2
Facebook messenger overrides do not disturb mode

  1. JohnStr97 Donut Feb 18, 2017

    JohnStr97, Feb 18, 2017 :
    Hello! My OnePlus 3T is on Android 7.0, Oxygen 4.0.2 and when I'm on do not disturb mode, if I get a message on Facebook messenger I get notified normally.

    However I don't want that to happen and "override do not disturb" is off in the app's settings. Can anyone help?
     

    #1
    lean_paulocmatos and RawRs like this.
  2. DimitrisCSD Froyo Feb 18, 2017

    DimitrisCSD, Feb 18, 2017 :
    In that mode you still get notifications but they just make no sound. If you get no sound then it's working fine.

    There are some things however that indeed do not work as intended in do not disturb like an incoming call on hangouts. That still makes noise...

    The difference between silent mode and do not disturb, is that the latter can be set to not accept calls if you want to, or just accept calls from starred contacts.

    I hope this helps.
     

    #2
    RawRs likes this.
  3. JohnStr97 Donut Feb 18, 2017

    JohnStr97, Feb 18, 2017 :
    yeah man I know and thanks, but messenger notifications make sound while in no disturb mode...
     

    #3
    dsommer likes this.
  4. DimitrisCSD Froyo Feb 19, 2017

    DimitrisCSD, Feb 19, 2017 :
    That's weird. I'm on a 3T OOS 4.0.3 and messenger notifications definitely don't make a sound in DnD. No idea about calls as I haven't tested, but messages are definitely silent for me.

    Hangouts/Viber *calls* thought, do make sound in DnD which is ridiculous!
     

    #4
  5. lawreo Cupcake Feb 19, 2017

    lawreo, Feb 19, 2017 :
    WhatsApp and wechat overrides the mode too. not sure what's the use then?
     

    #5
  6. alego500 Cupcake Mar 2, 2017

    alego500, Mar 2, 2017 :
    Think I found a solotion guys! Don't have a one plus, but if you disable the chat bubble feature messenger seems to respect DND mode ;-)
     

    #6
  7. teddyelliot Cupcake Nov 3, 2017

    teddyelliot, Nov 3, 2017 :
    I've been having this problem and I just worked out how to fix it.

    if you go into Messengers notification settings, change your alert slider to do not disturb, then turn sound off. the app knows what mode you're in and turns sound back on when you're in normal mode.

    this has been bugging me for so long, so relieved I finally fixed it
     

    #7
  8. Sridhar Ananthanarayanan Lollipop Nov 3, 2017

    Sridhar Ananthanarayanan, Nov 3, 2017 :
    have you checked the settings within the app?
     

    #8
  9. Sridhar Ananthanarayanan Lollipop Nov 3, 2017

    Sridhar Ananthanarayanan, Nov 3, 2017 :
    are you supposed to do that every time you enable DND? not practical.
     

    #9
  10. Pavel_Pavlov Froyo Nov 3, 2017

    Pavel_Pavlov, Nov 3, 2017 :
    I use Tasker to control many things when in "Do not disturb" or "Silent" but the most useful is simply changing the ringtone to "none". That assures no apps using the default ring tone are ringing loudly, if I'm in dnd or silent mode.
     

    #10
  11. teddyelliot Cupcake Nov 4, 2017


    #11
  12. G_Jonas_Almkvist_thhE Cupcake Sep 19, 2018

    G_Jonas_Almkvist_thhE, Sep 19, 2018 :
    KINDA SOLLUTION: This thread haven´t been active for a while, but i have some kind of sollution to the problem. Uninstall Facebook Messenger and install Facebook Messanger Lite. Did that yesterday, and it seems like that doesn´t override the do not disturb-mode :)
     

    #12
  13. Lionel_B Cupcake Sep 19, 2018

    Lionel_B, Sep 19, 2018 :
    Go to Alert Slider / Do Not Disturb and set Messages to None. This will solve your issue.
     

    #13
  14. G_Jonas_Almkvist_thhE Cupcake Sep 19, 2018

    G_Jonas_Almkvist_thhE, Sep 19, 2018 :
    I have messenges set to none in ”Do not disturb” and that does not do it for me :(
     

    #14
  15. farridm Eclair Sep 20, 2018

    farridm, Sep 20, 2018 :
    try uninstalling then get Messenger Lite to see if it is the same.

    Or you can reset the phone and try again.
     

    #15
  16. lean_paulocmatos Cupcake Jan 11, 2019


    #16
  17. ghostofcain Lollipop Jan 11, 2019

    ghostofcain, Jan 11, 2019 :
    As do OP6T users posting in an android 8 on OP3(T) thread...
     

    #17
    lean_paulocmatos likes this.