0
Failed nandroid restore unable to decrypt data partition

  1. yelti_be
    Cupcake Oct 20, 2019

    yelti_be , Oct 20, 2019 :
    Hi,
    Yesterday I did something wrong.
    I made a nandroid backup, next reset the phone to test something and then I tried to restore the nandroid backup.
    The restore failed with error: "createTarFork() process ended with ERROR: 255"
    I thought it would be ok to reboot and try again, but I guessed wrong.
    After the reboot the phone doesn't ask for decrypting the data.
    I can see the data partition but all folders and files have random character names.
    The phone always boots to recovery.

    I was rooted, had an unlocked bootloader and latest codeworkx Twrp recovery.
    The steps I tried:
    - I tried to sideload oxygenos 9.0.8 with twrp recovery, the phones reboots after the flash, then reboots again to recovery.
    - I flashed the stock recovery, and tried to sideload the stock image, but the when I'm in adb sideload, the phone is not recognized in Windows 10.

    I'm at a loss on what to do next.
    I want to decrypt my data partition in hope to recovery my backups I made, then I can fully reformat the phone if required.

    If anyone has ideas on what to try or what to check, I would be grateful.
     

    #1
  2. yelti_be
    Cupcake Oct 26, 2019

    yelti_be , Oct 26, 2019 :
    This is the data I see on the data partition.
    [​IMG]
    I dumped the data partition to an usb drive.
    I formatted the data partition and the phone boots normally.
    After this I put on the same pin code and restored the image from the usb drive, but with the same result:
    TWRP does not asks for a password and I cannot decrypt the data partition.
     

    #2