1
Failing to connect my OP2 to pc after latest update of OS. Is this happening to all?

  1. rahuldborse
    Honeycomb Jun 12, 2016

    rahuldborse , Jun 12, 2016 :
    I updated my OP2 to 6.0.1, Oxygen 3.0.2. Since then i fail to connect my phone to windows pc. is this happening to all? please help.
     

    #1
    AkshayMurali1209 likes this.
  2. Bernardoz
    Cupcake Jun 12, 2016

    Bernardoz , Jun 12, 2016 :
    Same here I have been trying all day to connect my OP2 to my laptop but no thing has changed. I tried to change a few things in developer mode and still nothing.
     

    #2
    rahuldborse likes this.
  3. Lancelot_69
    Lollipop Jun 12, 2016

    Lancelot_69 , Jun 12, 2016 :
    When you connect to pc, what do you see? Have you gone to developers options and allowed for usb connect? Have you selected media transfer after pulling icon down on front face?
     

    #3
    rahuldborse and otto2 like this.
  4. faifai
    Froyo Jun 12, 2016

    faifai , Jun 12, 2016 :
    you only see the driver, installed reboot the same, only see driver, then when you change the phone option to act as file transfer it show the same thing, not the folders but only the driver setup.exe
     

    #4
    rahuldborse likes this.
  5. SeanPlus
    Ice Cream Sandwich Jun 12, 2016


    #5
    rahuldborse likes this.
  6. Lancelot_69
    Lollipop Jun 12, 2016


    #6
    rahuldborse and otto2 like this.
  7. otto2
    Photography Expert Jun 13, 2016

    otto2 , Jun 13, 2016 :
    Use Linux instead of buggy windows, after connecting the USB to PC or laptop pull down status bar and choose "mtp". This has been changed by Google in Android "M".
     

    #7
    rahuldborse likes this.
  8. evertking
    Ice Cream Sandwich Jun 13, 2016

    evertking , Jun 13, 2016 :
    Yes.. I have the same problems. Windows and Ubuntu. Just the cable alone gives a malfunction pop up
     

    #8
    rahuldborse likes this.
  9. faifai
    Froyo Jun 13, 2016

    faifai , Jun 13, 2016 :
    which part don't you understand
    when we plugin the usb cable, on windows 7 pc only show empty root with driver setup and autorun
    even after the install and reboot of the driver, it shows the same thing
    changing to file transfer or anything else on the phone side yield the same result
    was on my phone earlier, when replying the message
     
    Last edited: Jun 13, 2016

    #9
    rahuldborse likes this.
  10. faifai
    Froyo Jun 14, 2016

    faifai , Jun 14, 2016 :
    I kind of found a solution
    you have to do the swipe down, then choose file transfer
    a windows will pop up on your pc and ask if you want to open (do not open with that)
    instead close it from your pc and go to file explorer and double click on your oneplus device
    you should now see all your folders
    this is dumb as the option is fooling you to a different drive
     

    #10
    rahuldborse likes this.
  11. anupritaisno1
    KitKat Jun 14, 2016

    anupritaisno1 , Jun 14, 2016 :
    Pull down statusbar, find the USB for charging notification and select MTP. This is not a oneplus problem so stop being idiots
     

    #11
    rahuldborse likes this.
  12. rahuldborse
    Honeycomb Jun 14, 2016

    rahuldborse , Jun 14, 2016 :
    yes......this is what i see on my pc
     

    #12
  13. rahuldborse
    Honeycomb Jun 14, 2016

    rahuldborse , Jun 14, 2016 :
    great.....thanks for help!
     

    #13
  14. rahuldborse
    Honeycomb Jun 14, 2016

    rahuldborse , Jun 14, 2016 :
    oh...ok....i try this and inform you about the result.....thanks a lot for your help!
     

    #14
  15. rahuldborse
    Honeycomb Jun 14, 2016

    rahuldborse , Jun 14, 2016 :
    wow.....you are a geek...thanks for your kind words
     

    #15
  16. NarayanAras
    Froyo Jun 14, 2016

    NarayanAras , Jun 14, 2016 :
    It fails to connect to a Linux PC as well.

    This is a bug: Even if the USB is configured to MTP mode, the phone disregards it.

    The workaround is to switch to any other (e.g. Charge) mode and then switch back to MTP mode. This works only for the current session. Every time you connect the phone to a PC, you have to do it again.

    For those who did not understand the short version above, here is the detailed process:

    I am assuming that you have enabled the developer options on your phone.
    If not, follow this procedure first.
    1. Swipe down from the top of screen with two fingers.
      This exposes the Settings (geared wheel) icon (top right corner of the screen).
    2. Tap on this button. The Settings screen opens.
    3. Scroll down to bottom to see the About phone option. Tap on it.
    4. Scroll down till bottom to see the Build number option.
    5. Tap on this option five times rapidly. (If you delay the tapping, this trick fails! Repeat.)
    You will see the message "You are now a developer!"

    Now you can proceed with the actual trick.
    1. Connect the phone to PC with a USB cable.
    2. Unlock the phone.
    3. Swipe down from top of screen with two fingers. This exposes the Settings (geared wheel) icon.
    4. Tap on the Settings button. The Settings screen opens.
    5. Tap on the magnifier glass icon (top-right corner of screen)
    6. Enter "USB" (without quotes)
    7. Immediately, the search results appear below.
    8. Tap on the Select USB configuration option.
    9. A list of options appears. Ignore its current selection state.
      (This is irrelevant, thanks to the bug).
    10. Select the first option (Charging).
    11. Now repeat step-8, and select the second option (MTP)
    12. Immediately the PC responds and pops up the autoplay dialog
      (It shows the Internal storage directory)
    13. Your change is done. Exit the settings mode.
    You have to repeat this every time you connect your phone to a PC.

    Hope that helps...
     

    Attached Files:

    Last edited: Jun 14, 2016

    #16
    rahuldborse likes this.
  17. rahuldborse
    Honeycomb Jun 14, 2016

    rahuldborse , Jun 14, 2016 :
    thank you so much for your detailed description of problem solving process....this is really good for a layperson like me..have a good day
     

    #17
    Lancelot_69 likes this.
  18. NarayanAras
    Froyo Jun 14, 2016

    NarayanAras , Jun 14, 2016 :
    You are welcome!

    BTW I found some issues with my first draft.
    I have edited some points.

    Please follow them carefully.
    If you find any inaccuracy (however small), please point them out, so that I can edit my post.
    That way the subsequent readers will benefit.

    Thanks!
     

    #18
    rahuldborse likes this.
  19. Cipher0
    Froyo Jun 14, 2016

    Cipher0 , Jun 14, 2016 :
    My PC (running Windows 7) doesn't detect the phone upon connect either. I have to manually go into USB configuration mode and select MTP mode (although already selected), after doing this I can explore the contents of the phone.
     

    #19
    rahuldborse likes this.
  20. teddybelly
    Eclair Jun 14, 2016

    teddybelly , Jun 14, 2016 :
    One of my friend is facing the same problem. He is unable to connect his OP2. It keeps on saying "it seems your screen is locked, please unlock your screen to continue", BUT the screen is unlocked and he has enabled USB connect in developer options. :( Any help would be greatly appreciated.
     

    #20
    rahuldborse likes this.