0
Fiddled with LTE Diversity Ant Switch in Manual Mode (*#808#). Getting only 2G now. Help!!

  1. brob
    Cupcake Jun 5, 2016

    brob , Jun 5, 2016 :
    Hello all. I know that I shouldn't have done it, but i just typed in a number and pressed OK. Now I'm only getting 2G. What is the original number that I must put? Please don't try it out; I don't know how to rectify what I've done. Can a dev or someone familiar with the LTE Ant thing help me out?

    Thanks
     

    #1
  2. viveks_
    Cupcake Jun 5, 2016

    viveks_ , Jun 5, 2016 :
    Try this! Enter *#*#4636#*#* in to the dialer. Then a new screen comes up for testing. From there choose "Phone information", then scroll till you see "Preferred Network type", tap there and from the list choose the appropriate network. (GSM only for 2G, WCDMA for 3G, LTE for LTE, you can also choose options with "auto" prefix in the options, which will automatically switch between these according to network).
     
    Last edited: Jun 6, 2016

    #2
  3. The1337Doctor
    Froyo Jun 5, 2016


    #3
  4. sionyn2
    Eclair Jun 6, 2016

    sionyn2 , Jun 6, 2016 :
    You've changed the lte diversity configuration I think which alters how the baseband decides to use the primary antenna or secondary ie the diversity. You changed the TIS sensitivity number (likely the issue your having).

    I have no idea how that value is calculated whether diffrerent across lte bands or if test equipment is need to calibrate it.

    Asking the support guys is the way go..
    Goodluck and hope you find a fix
     

    #4
  5. T1574562369624
    Cupcake Nov 24, 2019

    T1574562369624 , Nov 24, 2019 :
    I had the same problem on my OP5 and this is where Google sent me, so I'll put the solution here for the next person who makes the same mistake.

    Luke OP, I went to *#808# which gives you many submenus of different tests. I tried the LTE Diversity Ant Switch. It made everything on my screen turn into red shades (the ultimate low blue light mode ;) ), put a white border around the screen, and probably messed with my antenna settings like OP.

    Pressing the switch again didn't change anything, so it's not a toggle switch. Airplane mode didn't fix it. Rebooting seemed to fix it, but after a minute the red screen tones and border returned.

    Resetting my network settings did work (settings - system - reset options). It's been 10 minutes or so since I did that, and everything is still good.

    When I go to, *#*#4636#*#* to check my phone connection status, it seems alright. I've got LTE for voice and data and the phone can choose whatever network it needs.

    UPDATE: This didn't work. After a while (12 hours or so) the red screen and border appears again. Resetting the network settings every day isn't a great solution.

    I've tried going back into *#808# and every time I press LTE Diversity Ant Switch it crashes.

    UPDATE 2: I performed a factory reset over 24h ago, and so far there's been no reoccurrence. I'm going to tentatively suggest that this solution, as severe as it is, does work.
     
    Last edited: Nov 27, 2019

    #5
    G_plusone likes this.