9
Fingerprint Hardware Not Available - Issue Started Out Of Nowhere

Thread Status:
Not open for further replies.
  1. chrism380
    Ice Cream Sandwich Jul 9, 2016

    chrism380 , Jul 9, 2016 :
    This started for with the newest update. Worked perfectly fine and suddenly issue started.

    Just realized this is the op2 forum, this is now happening on a op3.
     

    #41
  2. TLK
    Froyo Jul 9, 2016

  3. afnan03
    Cupcake Jul 10, 2016

    afnan03 , Jul 10, 2016 :
    Same problem. Please help.
     

    #43
  4. Rahman Qassemi
    Cupcake Jul 27, 2016


    #44
  5. CUS
    Froyo Jul 27, 2016

    CUS , Jul 27, 2016 :
    1) Press and hold Power button to get power menu up
    2) Press and *HOLD* Power off option on screen and a new option to boot into safe mode will appear...choose that
    3) Once its booted into safe mode, go into settings and setup new fingerprint
    4) Reboot

    Worked for me after FP reader completely stopped working both as a scanner and home button ;)
     

    #45
  6. kiz84
    Cupcake Jul 28, 2016

    kiz84 , Jul 28, 2016 :
    I've tried everything, force closing, clearing cache etc but nothing and now the battery drain is ridiculous! From 100% it went down to 61% in just 2 hours. WTF!
     

    #46
  7. Sushant19
    Eclair Jul 28, 2016

    Sushant19 , Jul 28, 2016 :
    Hii, I bought a Oneplus 2 few days ago. I wanted to find out whether the phone is rooted or not? Please suggest me some methods by which I can check. Thanks

    As I am getting the notification for system update. But after I download it, the phone goes into recovery mode and there it says installation failed and reboots my phone. Any suggestions on this will also be helpful
     

    #47
  8. racheuk
    Cupcake Sep 27, 2016

    racheuk , Sep 27, 2016 :
    Another OP2 user with same issue, and also had my phone since Nov time.

    Tried rebooting in safe mode, clearing cache and fiddling with navigation buttons.

    Still no fingerprint sensor and the option to add fingerprints has gone from the menu.
     

    #48
  9. Gremlins
    Eclair Sep 29, 2016

    Gremlins , Sep 29, 2016 :
    My fingerprint sensor went dead twice in a year, and the only trick that ever worked was draining the battery to zero while having the on-screen buttons, and then turning them off after a full charge. The exact sequence can be found everywhere in this forum/XDA, since it has worked for so many users already.

    EDIT : it's method #3 from TLK's post.
     

    #49
  10. javi.ayllon
    Cupcake Sep 29, 2016

    javi.ayllon , Sep 29, 2016 :
    Mine had the same issue, just RMA, don't waste your time, it's a hardware fault. I think these tricks just make it work for a while, but I'm sure that it's phisicaly damaged.
     

    #50
  11. joaoaa8
    Donut Sep 30, 2016

    joaoaa8 , Sep 30, 2016 :
    Had the same problem a while back. I wiped the cache partition and the FP started working as usual. There wasn't any need to go through the process of enlisting new fp's

    Edit: wipe cache through reboot mode
     

    #51
  12. syserror
    Cupcake Oct 8, 2016

    syserror , Oct 8, 2016 :
    Just now it started happening to me as well. however it is also vibrating constantly in short bursts and the screen is turning off as if i'm hitting the shortcut on the fingerprint button to disable the screen. - therefore i cannot turn the phone off or clear the cache.

    I do not take my phone with me when i exercise.
    i do not take my phone out when it is raining.
    i have never dropped the phone before.
    i have always kept it clean of smudges whenever i see them.
    i have always kept it in its otterbox case.

    [ninja edit]
    after my fourth reboot by holding down the power button....it stops. but the button is not working.
    i enter *#808# and do the fingerprint self test with error: The application cannot reach t he android service for the sensor."

    same error with the checkerboard test.

    thoughts?
     

    #52
  13. Kartik Kashyap
    Honeycomb Oct 9, 2016

    Kartik Kashyap , Oct 9, 2016 :
    It would not work no matter what you do! I have had the same issue and I did try every solution on earth to make it work, but it didn't. All you can do is wait for OnePlus to push next update which would probably fix the issue. I have decided for sure that i won't buy OnePlus next time. They are just an immature company. Now, some fanboys would critisize me like hell. But you don't know what difficulties I have been facing when I started using this phone. Idk about OnePlus 3, but OnePlus 2 is just a piece of shit.


    A fanboy(was) who had to settle every time.
     

    #53
    archer_7 likes this.
  14. fareed_xtreme
    Eclair Oct 10, 2016

    fareed_xtreme , Oct 10, 2016 :
    I had exactly the same issue as you in August, and mind you I had tried literally everything. When I discussed with the OnePlus Support they said it's a hardware fault even though for me the hardware tests passed.

    Luckily for me the device is under 2 years warranty for my region and so the issue was fixed free of charge. However I was phoneless for 3 weeks.
     

    #54
  15. iam_raks
    Cupcake Nov 5, 2016

    iam_raks , Nov 5, 2016 :
    No need to do all that thing . . I have same issue . . Not only fingerprint but also not even working as home buttons . . All fingerprint options disabled . . . What I did was just leave the phone till battery is dead and keep restarting continuously till whole battery is drained . . Till the stage where phone won't flash even after holding for 15 secs . . . Then charge tour phone and restart . . All set that should work it worked for me and my friend . .I hope This should work for you all also . .
     

    #55
  16. MatisyahuSerious
    Cupcake Nov 6, 2016

    MatisyahuSerious , Nov 6, 2016 :
    same issue as everyone else here - tried all the steps, no luck. then, mysteriously, 2-3 weeks later, its all working again. the most curious part of all this is that when it is not working, all the software options for it are missing in settings...and then, magically, they reappear when its working again.
     

    #56
  17. Sahnig
    Eclair Nov 6, 2016

    Sahnig , Nov 6, 2016 :
    I kinda love solving this problem. Seems a lot of us don't search around before we post.

    Did it occurred to any of you sweet brilliant people that a mere hair dryer pointed to your FPS (charging socket on phone), while being switched off from a safe distance while not burning the chipset with over heat could actually make it work.

    Hmmm....!!
     

    #57
  18. ficker22
    Eclair Nov 6, 2016

  19. suvilsusvirkar
    Cupcake Nov 23, 2016

    suvilsusvirkar , Nov 23, 2016 :
    As funny as it may sound, the problem began after I switched to a new case. I bought a case online which was probably too tight.

    After switching back to the first case that I have been using for past one year, things got back normal.

    It may be a one off situation but it's worth a try.

    Best,
    Suvil
     

    #59
  20. F_Arjun_Sai_LOUb
    Eclair Nov 24, 2016

    F_Arjun_Sai_LOUb , Nov 24, 2016 :
    if the hardware is missing issue arises just go to the nearest op service centre bro , the module is damaged.I had to replace mine , the op2 teams been very helpful though got it replaced in 15min
     

    #60