0
Other Fingerprint issue in custom roms - blame google?

?

Anyone facing such fingerprint issue in any custom rom?

  1. Yes

    2 vote(s)
    100.0%
  2. No

    0 vote(s)
    0.0%
  3. Yes but solved it

    0 vote(s)
    0.0%
  1. sfksuperman
    Honeycomb Apr 29, 2020

    sfksuperman , Apr 29, 2020 :
    I am facing this weird issue ever since I started using custom roms (A10). It never happens to me on stock oos rom ever.
    This post gonna be long maybe but I will try my best to explain it in quite detail.
    For this, I have captured a screen record too. Take a look how it fails and annoys me.

    Some basic info here:
    Model used: OnePlus 6T
    Issue happened on: all custom roms (android 10)
    Base rom: Stock OOS 10.3.1, 10.3.2 & 10.3.3
    Custom roms used so far: Pixel Experience, Evolution X, Pixen
    NOTE: I HAVE ADDED TWO GOOGLE ACCOUNTS, SAY G1 & G2. Remember this, I will explain below.

    My fingerprint doesn't unlock the device and always says "not recognised".
    Then i tried to figure out why and when this happens and I found out that when FP is working fine and I rebooted my device, after then it ran into some issue.
    It never works afterwards. Yeah, one single reboot & poof...it's gone, not working!
    And when I delete the FP and try to register it, after 6th touch, i.e. on 7th touch, it throws error as "Lift finger, then touch sensor again" and it stuck there.
    But after few trials, I somehow able to complete the enrollment. But it never works and unlocks the device saying "not recognised" all the time. So, this enrollment is just a waste.

    THEN i found few temporary solutions which are as follows to get the FP working again (BUT REMEMBER HERE ALSO, ONE REBOOT AND IT'S WASTED AGAIN):
    (1) Delete the fp enrollments and removed the G1 google account only (keep G2 account) and then wait for 5-10 mins and try to enroll again. This time it worked and enrollment finishes either without fail or few fails (at 7th touch). FP now works good and I add G1 account back again.
    OR
    (2) Just delete the fp enrollments and do not remove any google account and wait for 5 mins and then enrollment works fine and it unlocks device normally.
    From point (1), I deduced that there is something fishy about my G1 google account. As long as it remains there, fp enrollment has issues.

    Should I blame google for this that developers are saying so? Is there anyone here who is having any ideas why this issue has something related to my Google account or why even this is happening, please enlighten me and help me out.
    This issue has become pain in the dash ever since. It's very annoying for me to keep deleting and enrolling fp every 2-3 times a week or so.
    You help would be appreciated.
     

    #1
  2. Caomhin
    OnePlus 9 Series Expert Community Expert Apr 29, 2020

    Caomhin , via OnePlus 6T , Apr 29, 2020 :
    Just wondering is the FP security protocol in someway linked to Google framework and or services, and its maybe not functioning on occasion due to some miscommunication between the code within those frameworks, services.

    Personally I have never had this issue. So I am not sure why some get that issue while others don't. Even with the same OOS software and OP hardware.

    Only other issue could be an 3rd party app running in the background, interfering with the process somehow.
     

    #2
  3. flyoffacliff
    Cupcake Dec 26, 2020

    flyoffacliff , Dec 26, 2020 :
    I'm having the EXACT same issue, since I just switched from OOS to Havoc OS. Was googling around and found this, any solutions yet?
    I found that sometimes toggling face unlock off and back on helps for a bit.
     

    #3
  4. Caomhin
    OnePlus 9 Series Expert Community Expert Dec 27, 2020

    Caomhin , via OnePlus 6T , Dec 27, 2020 :
    As you are now using Havoc OS. You will have to take this up with the Havoc OS developers, OnePlus have nothing to do with that Custom OS.
     

    #4