71
Fix Assert Failed Errors when flashing CM 11S 05Q in TWRP

  1. Crackass
    Froyo Feb 10, 2015

    Crackass , Feb 10, 2015 :
    Everytime a new OTA comes around a lot of people get this "assert failed:"... error. This is usually due to the system being modified in some way (eg. having installed xposed). I always get this error too as I am rooted and mess with my phone quite a lot. There are two methods I have. The first one works most of the time (I've only seen it fail on me and someone on XDA). The second one works all of the time (at least I think so) but is more difficult and advanced. It requires knowledge of adb and fastboot. You can look up how to get adb and fastboot but I really don't have time to type up how to get it and everything. I would reccommend trying the first one first and if it doesn't work then do the second one. Both of these methods will not clear any user data or apps.

    FIRST MAKE A NANDROID BACKUP. There is a small small percentage of failure and I'm not liable if you lose important data because of this. You can delete it after if everything went smoothly.

    Also for both methods I recommend wiping Dalvik Cache and Cache in TWRP before proceeding. If you have already got CM 11S 05Q and didn't do this and there is no issues leave it. If for some reason you have "Force close" issues clear your Dalvik Cache and Cache in TWRP.

    BTW don't forget to uncheck "Update CM recovery" in developer options if it isn't already. I saw a few people forget and their TWRP recovery was overwritten with stock and they had to reflash the TWRP recovery.

    Method 1:

    You'll need these files:
    Mirror 1: https://www.androidfilehost.com/?fid=95916177934526852
    Mirror 2: http://goo.gl/v7uBRg

    Since you got this error I'm going to assume you know how to flash things in TWRP. This time instead of flashing the official OTA zip file flash this slightly modified one that I made which removes the system checks (where it checks the files to see if it has been changed). When flashing this there will be no assert failed error and it should complete. Once that finishes you can flash SuperSU now if you want or had root. Now reboot and if you get to your lockscreen you succeeded. In the extremely rare occasion you're stuck on the boot logo then restore from your nandroid backup to get it working again and proceed to try method 2.

    Method 2:

    EDIT:
    Since the official factory image for XNPH05Q was released, this method can be simplified. Instead of fastboot flashing the system and boot images of 44S and then flashing the incremental zip in recovery to update we can now fastboot flash the system and boot images of 05Q and skip the incremental zip part. So for this shortcut all you need to do is to fastboot flash these system and boot images of 05Q using the same commands as outlined below and then flash the SuperSU zip in TWRP if you want root. It's the same process below but the system and boot images that you are flashing are newer so you are able to skip the flashing of the OTA incremental zip file.

    You'll need these files:
    Mirror 1: https://www.androidfilehost.com/?fid=95916177934526853
    Mirror 2: http://goo.gl/ptjcgq
    • ADB/Fastboot files and a USB Driver of some sort to use ADB and Fastboot (this is on your computer) *Sorry can't give links since there are many methods of getting these and you most likely already have it if you got the error because that means you are rooted and to root you need these unless you used an all-in-one tool. If you don't have it google how to get it or ask for help.*

    What you want to do now is put your phone into fastboot mode. You do this by turning your phone off and then simultaneosly holding the power + volume up. You should now be in fastboot mode. Connect your phone to your computer and open up your command prompt and change directory to the adb/fastboot folder (basically go to where you can type adb/fastboot commands). Now type... (each new line is a separate command)

    fastboot flash system system.img
    fastboot reboot-bootloader
    fastboot flash boot boot.img
    fastboot reboot-bootloader

    After this hold your phone's volume down + power until it turns off. Now re-hold volume down + power to enter TWRP. After this you should be able to flash the official OTA successfully and then SuperSU if you want root.

    Once you reboot it should say "Android is upgrading..." and after all the apps are optimized your phone should now be running CM 11S 05Q! Any app that was in your /system (such as the Xposed Framework, BetterBatteryStats etc.) will be removed since you reflashed the system


    If you need help please ask others. I have school and so I'm busy and I don't have much extra time to help others. I'm sure many people will be confused especially with method 2 but I know there will also be many people that get it and are willing to help.
     
    Last edited: Feb 14, 2015

    #1
  2. bestlands
    KitKat Feb 10, 2015


    #2
  3. maicasajusta
    Jelly Bean Feb 10, 2015

    maicasajusta , Feb 10, 2015 :
    now rebooting. looks like it worked, thanks.

    edit: ok, it worked really nice. thanks again!
     

    #3
  4. leemartin
    Lollipop Feb 10, 2015


    #4
    House_Maniac likes this.
  5. rajaspardeshi
    Ice Cream Sandwich Feb 10, 2015

    rajaspardeshi , Feb 10, 2015 :
    Awesome info, but I'm currently trying to flash via stock recovery. I downloaded the file, its in the internal memory, but everytime i try to install it, it says the signature isn't verified etc and aborts the installation. Any solution?
     

    #5
    arvinmradze likes this.
  6. Crackass
    Froyo Feb 10, 2015

    Crackass , Feb 10, 2015 :
    Idk much about the stock recovery. Since you have the stock recovery I'm going to assume you aren't rooted. I would just wait for the OTA to be pushed to your phone since you most likely won't have an error.
     
    Last edited: Feb 10, 2015

    #6
    rajaspardeshi likes this.
  7. ginchiller
    Cupcake Feb 10, 2015

    ginchiller , Feb 10, 2015 :
    holy ****,...thank god I flashed the franco kernel and everything works again... make a backup and dontz be so stupid as me,...you may not be as lucky ;)
     

    #7
  8. Elas
    Jelly Bean Feb 10, 2015

    Elas , Feb 10, 2015 :
    Is the modified ota 05Q ?
    Edit : flashed it works like a charm
     
    Last edited: Feb 10, 2015

    #8
  9. tjunkie
    Gingerbread Feb 10, 2015


    #9
  10. gmo8492
    Lollipop Feb 10, 2015


    #10
  11. Slayfer
    Honeycomb Feb 10, 2015


    #11
    darkturtle likes this.
  12. uao
    Gingerbread Feb 10, 2015


    #12
  13. Allzweckreiniger
    Cupcake Feb 10, 2015


    #13
  14. termin8her
    Cupcake Feb 10, 2015

    termin8her , Feb 10, 2015 :
    Thanks so much. Difficult to find guys that write concise, easy to follow guides like this (on any forum). +1
     

    #14
    crevax likes this.
  15. crevax
    Froyo Feb 10, 2015

    crevax , Feb 10, 2015 :
    Hi! A big thanks for this thread.
    I always have to use the first method every time they release a new OTA since I've rooted my OPO.
    Does the second solution avoid this problem for further update? I don't use all the apps you mentionned, just SuperSU to have the root access.
    And if I do use the second method, will all my data be erased?

    Thanks for you job and for the answer you will obviously give me. :p
     

    #15
  16. Clark789
    Eclair Feb 10, 2015

    Clark789 , Feb 10, 2015 :
    Thanks, Crackass!!! Worked great!!

    I did it with Method 1.

    Cheers
    Clark
     

    #16
  17. Bolert
    Eclair Feb 10, 2015

    Bolert , Feb 10, 2015 :
    Didn't receive OTA - Rooted with TWRP custom rom. Option 1 all good with me, thanks.
     

    #17
  18. Crackass
    Froyo Feb 10, 2015

    Crackass , Feb 10, 2015 :
    If you and your apps that you gave root to leave your /system untouched then yes it would clear up the problem for future OTAs. Both methods leave your user data and apps untouched.
     

    #18
    crevax likes this.
  19. ribayza
    Cupcake Feb 10, 2015


    #19
  20. OW3N111
    Jelly Bean Feb 10, 2015

    OW3N111 , Feb 10, 2015 :
    I get failed : mount / data

    When trying to sideload anyway I can get it to work.

    I have encrypted phone maybe why???

    I havnt flashed or put another rom on I'm all stock
     

    #20