49
[FIX] Bluetooth Turning On Automatically

  1. McJader
    Marshmallow Jul 19, 2021

    McJader , Jul 19, 2021 :
    Hello Everyone,
    As many of you may have noticed, in some devices, Bluetooth is turning on automatically.
    This is because the Bluetooth Scanning function is misbehaving in these devices.
    To Solve this "issue", simply search for Bluetooth Scanning in Device Settings and toggle it off.
    1.
    Screenshot_20210719-144308__01.jpg
    2.
    Screenshot_20210719-144317__01.jpg
    You may restart your device once for good measure.
    Also make sure you submit a bug report here
    or through the community app (red plus icon>feedback)
    Screenshot_20210719-144459__01.jpg
    Another case:
    Some apps like contact tracing apps for Covid require Bluetooth and may turn it on automatically when started.
    This is not a bug.
    (Thanks to @strafer )
    Please refrain from creating new threads about these issues.
    Thanks.
     
    Last edited: Jul 30, 2021

    #1
  2. McJader
    Marshmallow Aug 25, 2021

    Stickied Post
    McJader , Aug 25, 2021 :
    Reset all network settings:
    System>reset options>reset WiFi, mobile, and Bluetooth>reset settings
    In the same menu, reset app preferences.
    upload_2021-9-7_10-46-46.jpeg
    Restart your device and if Bluetooth Scanning is on, turn it off.
    Keep an eye on any app that asks for Bluetooth permissions and see if running that app causes Bluetooth to turn on automatically.
     
    Last edited: Sep 7, 2021

    #44
    Dresa91 and Bobbie63 like this.
  3. Yash Pratap Singh.
    Lollipop Jul 19, 2021


    #2
    Tobikage, Caomhin, the_o2 and 3 others like this.
  4. Bobbie63
    Marshmallow Jul 19, 2021

    Bobbie63 , Jul 19, 2021 :
    🤔🤔🤔 But people like that big red button so much.

    Wouldn't it be better to have this thread in the support section? (and mark this as best answer)
     

    #3
  5. McJader
    Marshmallow Jul 19, 2021

    McJader , Jul 19, 2021 :
    Nope, it just encourages support section spamming, people will keep posting here till months after.
     

    #4
  6. Dresa91
    User of the Year 2016; Most Active User 2020 Jul 19, 2021

    Dresa91 , Jul 19, 2021 :
    There are already several threads answered and marked as answered with this solution.
    But this won’t stop people creating threads
     

    #5
  7. Bobbie63
    Marshmallow Jul 19, 2021

    Bobbie63 , Jul 19, 2021 :
    Well like I said, people love Big red buttons:rolleyes:
     

    #6
  8. Dresa91
    User of the Year 2016; Most Active User 2020 Jul 19, 2021

    Dresa91 , Jul 19, 2021 :
    Yes ;)
     

    #7
    Caomhin, Bobbie63 and McJader like this.
  9. Caomhin
    OnePlus 9 Series Expert Community Expert Jul 19, 2021


    #8
  10. Tobikage
    Nougat Jul 19, 2021

    Tobikage , Jul 19, 2021 :
    If only people were smart enough and bothered to explore the various features of their "I paid xx,xxx thousands K for this" phones.

    :rolleyes:
     

    #9
  11. McJader
    Marshmallow Jul 19, 2021

    McJader , Jul 19, 2021 :
    27088349._SX318___01.jpg
     

    #10
  12. Tobikage
    Nougat Jul 19, 2021


    #11
  13. Mr. BG
    Community Hero 2020 Jul 19, 2021

    Mr. BG , Jul 19, 2021 :
    No feature can fix ignorance/stupidity.

    Not to mention entitlement.

    "Will not buy again"

    Good riddance!
     

    #12
  14. saurabh7045
    Eclair Jul 23, 2021


    #13
  15. McJader
    Marshmallow Jul 23, 2021


    #14
    5l4rtysCell, rHITkM. and Dresa91 like this.
  16. saurabh7045
    Eclair Jul 23, 2021

  17. ParamK.
    Moderator Moderator Jul 23, 2021

    ParamK. , Jul 23, 2021 :
    Thread Merged
     

    #16
    rHITkM., Dresa91 and McJader like this.
  18. D1600367528984
    Cupcake Jul 28, 2021


    #17
    Dresa91 and McJader like this.
  19. goncaloferreira
    Cupcake Jul 29, 2021


    #18
  20. McJader
    Marshmallow Jul 29, 2021

    McJader , Jul 29, 2021 :
    You turned off Bluetooth scanning?
     

    #19
    rHITkM. and Dresa91 like this.
  21. goncaloferreira
    Cupcake Jul 29, 2021

    goncaloferreira , Jul 29, 2021 :
    Yes I have this option turned off... I also did system upgrade today to OP6T_O2_BETA_77 but it didn't fix the problem. I have tried to clear bluetooth cache and storage in system apps, didn't work too.

    It's very annoying, it turns on and off by itself over and over again.
     

    #20