77
[FIX] Call Quality Issue

?

Did this help you in solving your problem ?

  1. Yes

    83 vote(s)
    68.0%
  2. No

    39 vote(s)
    32.0%
  1. Apfelsack
    Donut Jun 14, 2016

    Apfelsack , Jun 14, 2016 :
    • Switch to loud speaker and see if Quality is good now . if yes then follow the end post .
    Okay, I got this problem the other way round. Mic quality and volume are good on ordinary mode, but really bad on speakers. I can't hear my voice (during Echo-Calls) and no one else can hear me during calls on speaker mode. If I switch to ordinary mode, everything works fine. I know the mic is only very low because if I scratch near the mic on the back during speaker mode I can hear the scratching. Do you have any idea how to fix this?

    Edit: Didn't try to change the build.prop because I thought it would only work for people who have a better quality on speaker mode.

    Edit2: Changed the fluencetype in build.prop to none, still no improvement in mic volume on speaker mode.
     
    Last edited: Jun 14, 2016

  2. vCillusion
    Eclair Sep 20, 2016

  3. gagz89
    Cupcake Jan 13, 2017

    gagz89 , Jan 13, 2017 :
    Hi I followed all the above mentioned steps yet still I face the same issue. Anything more I need to do for OPO ?
    Thanks in advance.
     

  4. mkoelsch
    Gingerbread Apr 22, 2017

    mkoelsch , Apr 22, 2017 :
    Hi,

    I had this problem with the mic on my OPO on Cyanogen 13. After an Update to Oxygen 2.1.4 the problem still exists. Voice-calls have terrible quality, WhatsApp-Calls are awesome quality. So I guess it has to be some software setting.

    The build.prop of OxOS already contains

    ##fluencetype can be "fluence" or "fluencepro" or "none"
    ro.qc.sdk.audio.fluencetype=none
    persist.audio.fluence.voicecall=true
    persist.audio.fluence.voicerec=false
    persist.audio.fluence.speaker=true


    But no: <device name="SND_DEVICE_IN_HANDSET_MIC" acdb_id=

    Question: who has fixed the issue on a OPO with OxOS 2.1.4?
     

  5. G_shubham_katakdhond_JDa
    Froyo Apr 25, 2017


  6. adrienb
    Donut Jun 13, 2017

    adrienb , Jun 13, 2017 :
    2 years later and problem still applies for LineageOS 14.1 !!!!
    The fix from this thread solved it (I had already applied it on Cyanogen Mod previously)

    Thanks
     

  7. G_Manu_g_kICu
    Gingerbread Jun 26, 2017


  8. romano794
    Cupcake Aug 17, 2017

    romano794 , Aug 17, 2017 :
    Yes I am having the same problem. Cannot find the audio platform nor the one you just put. Have you had any luck?
     

  9. romano794
    Cupcake Aug 17, 2017

    romano794 , Aug 17, 2017 :
    Alos I have one plus one, oxygenos 1.0.3
     

  10. K1514060037431
    Cupcake Dec 23, 2017

    K1514060037431 , Dec 23, 2017 :
    Will this work on S6 edge??? problem with my mbl is that every person on call listens very low from my side
     

  11. extreme79
    Froyo Jan 5, 2018

    extreme79 , Jan 5, 2018 :
    This happen to me too. Until 25 december all works good.
    After 25/12 lineage nightly install.. mic turned low on call (no problems in speakers mode).
    Latest nighlty doeas not solve the issue.
    :(
    I already know the the first post fix works.. but.. if the mic previously works.. why not anymore??
     

  12. gupta.nikhil.gn
    Cupcake Feb 28, 2018

    gupta.nikhil.gn , Feb 28, 2018 :
    You can update the post with alternate method, which doesn't require rooting.
    Note : Replace the Red items with your respective filenames and file path in your computer.
    1. Download latest twrp for bacon and copy in the folder which contain your adb and fastboot
    2. Get into fastboot mode and connect your phone to laptop
    3. Type in cmd "fastboot devices", it should list your device, if it doesn't check drivers
    4. Give the below command, replace the name of file with your file name
      fastboot boot twrp_xxxx___.img
    5. Your phone will boot into twrp recovery mode, click on mount and select tick the checkbox against system
    6. Give below command on laptop
      adb pull /system/build.prop F:\Downloads\mfastboot-v2\build.prop
    7. Perform the necessary changes in build.prop file and then push it back into phone using below commands.
      adb push F:\Downloads\mfastboot-v2\build.prop /system/build.prop
      adb shell chmod 644 /system/build.prop
    8. Similarly pull audio_platform_info.xml file, perform change and push as above.
      adb pull /system/etc/audio_platform_info.xml F:\Downloads\mfastboot-v2\audio_platform_info.xml
      adb push F:\Downloads\mfastboot-v2\audio_platform_info.xml /system/etc/audio_platform_info.xml
      adb shell chmod 644 /system/etc/audio_platform_info.xml
    9. now reboot using adb reboot
    And coming to the changes you suggested, It didn't work for me after making those two changes only.
    I had to make a third change, which I read somewhere on XDA Forum and now it's working fine for me. So others can also try below

    Fix for Mic Issue :

    Changes in /system/build.prop
    persist.audio.fluence.voicecall=true change to persist.audio.fluence.voicecall=false
    ro.qc.sdk.audio.fluencetype=fluence change to ro.qc.sdk.audio.fluencetype=none

    Changes in /system/etc/audio_platform_info.xml
    <device name="SND_DEVICE_IN_HANDSET_MIC" acdb_id="40" /> Change to <device name="SND_DEVICE_IN_HANDSET_MIC" acdb_id="4" />
     

  13. robertopato
    Cupcake Oct 18, 2018

    robertopato , Oct 18, 2018 :
    Does this solve my issue? I have problems hearing what the other person says but the other person ears me well.
     

  14. kodlz
    Eclair Mar 10, 2019

    kodlz , Mar 10, 2019 :
    do you have somebody new LineAgeOS_16? did you make any change regarding mic.issue?
    In new LineageOS16 is no persist.audio.fluence.voicecall=true and
    ro.qc.sdk.audio.fluencetype=fluence

    but

    persist.vendor.audio.fluence.voicecall=true and
    ro.vendor.audio.sdk.fluencetype=fluence

    Is it same?
     
    Last edited: Mar 10, 2019

  15. pvelumuruga
    Cupcake Mar 10, 2019

    pvelumuruga , Mar 10, 2019 :
    I am using 6T and since moving to this device, many have been complaining that when they call it states "My phone is busy on a different call". Have swapped SIM also, but still the problem persist. Note, this issue is only with some callers, while others don't complain of this.

    anyone can help?
     

  16. MaximChicu
    Gingerbread Feb 18, 2021

    MaximChicu , Feb 18, 2021 :
    Guys, is this some sort of a "conspiracy" between OnePlus and Google?

    Out of the box -- microphone(s) don't work as expected, turn on "Hey, Google" in Google app and "suddenly" microphone(s) do work as expected! What the?