22

[Fix] CM13 GPS fix, flashable zip by TugaPower

  1. nirmoyal10 Gingerbread Jan 10, 2016


    #21
  2. bcmicros Gingerbread Jan 10, 2016

    bcmicros, Jan 10, 2016 :
    many thanks tugapower! seems to have sorted the problem... will test over next few days with google maps and the newer version of the geocaching app.
    will keep you posted!
    again many thanks!!!!
     

    #22
    TugaPower likes this.
  3. fred2028 Gingerbread Jan 10, 2016

    fred2028, Jan 10, 2016 :
    Been on 0110 since last night and flashed the fix + reset aGPS. It seems resetting aGPS with GPS Toolbox fixes the Google Maps navigation issue for a couple of hours, after which I need to reset again.
     

    #23
  4. sfinny Donut Jan 11, 2016

    sfinny, Jan 11, 2016 :
    This is amazing. Fixed a bunch of GPS issues I've been having since 5.1.1. Working great on CM13. Thanks!!
     

    #24
    TugaPower likes this.
  5. zadock Gingerbread Jan 11, 2016


    #25
    TugaPower likes this.
  6. bikas Ice Cream Sandwich Jan 11, 2016

    bikas, Jan 11, 2016 :
    @TugaPower One observation with CM13 GPS -

    If you run the GPS apps (map, or apps that uses GPS) for prolonged period, GPS tries to fix itself. Also, GPS somehow knows the correct location, but it also find user in other place. So, if you open Google Maps and let it auto-adjust, you'll see the pointer jumping from correct location to arbitrary location frequently.
    Informing you in case you want to fix GPS with CM13 libraries.
     

    #26
  7. absolem Eclair Jan 12, 2016

    absolem, Jan 12, 2016 :
    First of all thanks a lot for sharing this fix!

    I've been trying it out for the last two days and while I can say that the location now is far more accurate since it doesn't place my position in the middle of the ocean I still can not confirm that it works as precise as it used to on Lollipop.
    My position would always be detected about 100m around my actual location, locked on. Often the direction I'm moving in is shown wrong, also due to the fact that it's not entirely right, my location on the map still 'jumps' within these 100m to different places every few seconds.

    Navigating in a big city like Tokyo is still no fun with that, unfortunately.
     

    #27
  8. cssharda Donut Jan 12, 2016

    cssharda, Jan 12, 2016 :
    Lot of thanks. By flashing GPSfixcm13 my GPS problem has gone away. Now Google Maps show my position correctly which was being shown in some other State before.
     

    #28
    TugaPower likes this.
  9. linkswordie Cupcake Jan 12, 2016


    #29
    TugaPower likes this.
  10. bcmicros Gingerbread Jan 12, 2016

    bcmicros, Jan 12, 2016 :
    update: tried gps over the last few days had the following results.
    google maps and the newer geocaching app (uses google maps) i can get a gps fix but if i try to navigate anywhere the gps position doesnt update as often as it should and when it does the position jumps around.
    when using "here" maps i get gps position and can navigate, but while navigating will loose the gps position for a short while.
    the original geocaching app works ok apart from the occasional loss of gps.
    does any one have any idea when this issue will be sorted??? does it affect all marhmallow / cm13 based roms??
    any info would be helpfull may have to reflash a 5.1.1 rom if issue not sorted soon.
    laters.
     

    #30
  11. Buzz417 Gingerbread Jan 16, 2016


    #31
  12. bcmicros Gingerbread Jan 18, 2016

    bcmicros, Jan 18, 2016 :
    UPDATE 18/01/16.
    gave up with the issues i was still having with nightly cm13 and this fix, ended up reflashing again from scratch with omnirom . gps has been spot on since then. would like to go back to cm13 but have not seen anything on the cm logs to indicate the gps prob has been fixed.

    laters.
     

    #32
  13. mikene Cupcake Jan 19, 2016

    mikene, Jan 19, 2016 :
    Wow. My GPS stopped working and as above downloaded GPS toolbox from the play store and it worked in less than a minute.
     

    #33
  14. ooscrewyou Cupcake Jan 19, 2016

    ooscrewyou, Jan 19, 2016 :
    How do I verify that Google maps is utilizing my GPS? With or without this fix Google maps doesn't work in GPS only mode, it only works in high accuracy and battery saving mode. Without the fix Google maps reports totally wrong location(thousand miles away). I don't have any problem in other maps app.
     

    #34
  15. VitorMSA Gingerbread Jan 19, 2016

    VitorMSA, Jan 19, 2016 :
    Same thing here. Using only GPS from device I can't get GPS signal....
     

    #35
  16. TugaPower Jelly Bean Jan 21, 2016

    TugaPower, Jan 21, 2016 :
    Assume you are outdoor?
     

    #36
  17. VitorMSA Gingerbread Jan 21, 2016

    VitorMSA, Jan 21, 2016 :
    Sygic GPS said I've inaccurate position when I'm indoor or outdoor
     

    #37
  18. TugaPower Jelly Bean Jan 21, 2016

    TugaPower, Jan 21, 2016 :
    Indoor it's normal because Sygic uses real GPS signal. Outdoor it's not normal. Wich version of Sygic are you running?
     

    #38
  19. VitorMSA Gingerbread Jan 22, 2016

    VitorMSA, Jan 22, 2016 :
    I will try with your last version of Tuga Power Cm 13 (continua o bom trabalho. Por enquanto ando com a v100 CM 12.1 :))
     

    #39
  20. fred2028 Gingerbread Jan 22, 2016

    fred2028, Jan 22, 2016 :
    Is it normal for me to need to reset aGPS each time I boot, else have an unusable Google Maps navigation view?
     

    #40