15
Fix Compass COS 12.1 and CM 12.1 nightlies

  1. andreavndt
    Froyo Aug 27, 2015

    andreavndt , Aug 27, 2015 :


    In latest COS update the compass is still giving troubles with correct direction... Fixing the compass is as stupid as CM mantainers that didn't merge the fix for OPO. Here is how to manually fix:

    1. delete /data/misc/sensors/sns.reg (root required)
    2. manually modify /system/etc/sensor_def_qcomdev.conf:
    • line 66: :version 0x00010004 (instead of 3)
    • line 87: 900 1 0x00010004
    • line 88: 901 2 0x00010004
    • line 89: 902 3 0x00010004 (instead of -3)
    3. Reboot and test with https://play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2&hl=it




    EDIT 06/09:
    Made an easy flashable zip!


    source: https://github.com/sultanxda/propri...mmit/0cf2594584e89350d8e881f3257f0c6a29b1e361

    Thank you @Sultanxda
     

    Attached Files:

    Last edited: Sep 14, 2015

    #1
  2. techygeek
    Ice Cream Sandwich Aug 27, 2015


    #2
  3. Sultanxda
    Recognized developer Recognized Developer Aug 27, 2015

    Sultanxda , Aug 27, 2015 :
    @andreavndt the patch you referenced is the old one, this is the correct one: https://github.com/sultanxda/propri...mmit/2d48d254d3d330d3d2304e64fef68978611a4d1f

    If you change all the version numbers to 0x00010004 like in the correct version of my change for the magnetometer, then you don't need to delete /data/misc/sensors/sns.reg. Or, what you can do is not change any of the version numbers (and instead only change line 89 from -3 to 3), but you would need to delete /data/misc/sensors/sns.reg. Either of these ways works.
     

    #3
    Mind541, vladsprizza, kk22 and 4 others like this.
  4. jjrojoc
    Froyo Aug 27, 2015

    jjrojoc , Aug 27, 2015 :
    Confirmed, it work horizontal and vertical, thank you all.
     

    #4
  5. jjrojoc
    Froyo Aug 27, 2015

    jjrojoc , Aug 27, 2015 :
    If you put your phone in vertical mode, for example with maps application, the sensors data is wrong, with this fix compass work fine anyway how should be.
     

    #5
  6. Zachsaxe
    Lollipop Aug 27, 2015


    #6
  7. jjrojoc
    Froyo Aug 27, 2015

    jjrojoc , Aug 27, 2015 :
    @Sultanxda I was testing cos12.1 camera slow shutter and into settings have up to 8 seconds but i believe it take no more the two second like you said.
     

    #7
  8. jartukovic
    Ice Cream Sandwich Aug 28, 2015

    jartukovic , Aug 28, 2015 :
    I have the same problem since yesterday when i upgraded from COS 11 to 12.1, tried the fix from GitHub but doesn't work for me. Any ideas ?
     

    #8
    metienne and pablofg1978 like this.
  9. abhibnl
    Ice Cream Sandwich Aug 28, 2015

    abhibnl , Aug 28, 2015 :
    C
    Can you share your "/system/etc/sensor_def_qcomdev.conf" file?
     

    #9
  10. jartukovic
    Ice Cream Sandwich Aug 28, 2015

    jartukovic , Aug 28, 2015 :
    Sure i'll copy paste it but this attached screenshot is more interesting, the COS 12.1 cant see the sensors, and i tried to dirty flash it again with the TWRP 2.8.6.1 but it didnt help. I'll try again dirty flash with 2.8.6.0 Screenshot_2015-08-28-19-49-47.png
     

    #10
  11. jartukovic
    Ice Cream Sandwich Aug 28, 2015

    jartukovic , Aug 28, 2015 :
    I got it, i downgraded to TWRP 2.8.6.0 and again dirty flashed COS 12.1 and everything is working.
    I just also noticed that now it flashed the baseband also correctly.
    It was TWRP to blame.
    :D

    EDIT: the sensors are back online but they act a little crazy like in the first post. I did the full fix again but the problem is still there after the reboot.

    EDIT2: after calibration and 2 power off sessions everything is in order, or so it seams.

    The text file is attached.
     

    Attached Files:

    Last edited: Aug 29, 2015

    #11
    andreavndt and ScorpioPirate like this.
  12. MediocreBadGuy
    Gingerbread Aug 29, 2015

    MediocreBadGuy , Aug 29, 2015 :
    I've always had the compass off in GoogleMaps after every new ROM flash. I just do a figure 8 with my phone and it calibrates and remains perfect until I flash something else. Tested these apps with no issues
     

    #12
  13. jjrojoc
    Froyo Aug 29, 2015

    jjrojoc , Aug 29, 2015 :
    I told you, 2.8.6.0 was you friend for not problems
     

    #13
    jartukovic likes this.
  14. beltway
    Gingerbread Aug 29, 2015


    #14
    andreavndt likes this.
  15. alperion37
    Eclair Aug 31, 2015


    #15
  16. Oritsuro
    Honeycomb Aug 31, 2015


    #16
  17. daSnoop
    Honeycomb Sep 2, 2015

    daSnoop , Sep 2, 2015 :
    On my OPO this solved it but is there anything I can do on my girlfriends non rooted OPO? (beside rooting of course ;p )
     

    #17
  18. Flic3D
    Cupcake Sep 17, 2015

    Flic3D , Sep 17, 2015 :
    Had the same problem with GPS not locking for a long time on my OPO since the 12.1 update. This fix seemed to do the trick for me. Flashed the zip with TWRP 2.8.6.0 and rebooted. Now locks on in a reasonable time. Makes using Google Maps functional again! Thanks!
     

    #18
    andreavndt likes this.
  19. mohant
    Donut Sep 24, 2015

    mohant , Sep 24, 2015 :
    When can we get this fix officially? I do not want root OPO. I do not want to download to replace by myself.
     

    #19
  20. beltway
    Gingerbread Sep 24, 2015

    beltway , Sep 24, 2015 :
    That's a question for Cyanogen. Not sure if they're going to release any more updates, but I'd hope so. This is a pretty serious problem for mobile devices.
     

    #20