8
Fix for Dead Home button

  1. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    So most of them now known about the Home button and fingerprint issues and its increasing day by day. Know one has the exact solution, some of them has fixed by flashing the default rom and some of them by restoring TWRPbackup and most of them choose to RMA.

    Here is my previous thread:
    https://forums.oneplus.net/threads/need-real-solution-captive-home-button-dead-poll.383758/

    So i'm going to show u how i fixed mine:
    Suggested by @Martino1plus

    My OPT home button is now fixed. last thing i did was:SETTING==>APPS==>ALL APPLICATIONS==>COM.ONEPLUS.FINGERPRINT.SERVICE, Clear cached and Forced close and restart.

    If it didnt work do a Factory Reset From the setting:SETTING==>BACKUP AND RESET.


    Suggested by : @59.aditya
    If the above solution didnt work, let the phone battery die, and then do a full Charge.

    If by letting the phone battery die didnt work, u can again flash the full RoM that came default with ur phone.

    This method is not a 100% guaranteed, but u can try ;) i'm very much sure its a software issue, bcox mine was fixed after 25days of trying;)

    If above solutions failed to fix ur home button, than i suggest RMA ;)
     
    Last edited: Nov 13, 2015

    #1
    jbejarano, Papao, pnovak and 5 others like this.
  2. abhimanyu156 Donut Nov 3, 2015

    abhimanyu156, Nov 3, 2015 :
    Thanks Buddy. The first Method worked. I had called customer support and they were like we will have to change the home button and all. I did a little modification of the first method
     

    #2
    Papao, HaxxaN and Gaurav Rohilla like this.
  3. abhimanyu156 Donut Nov 3, 2015

    abhimanyu156, Nov 3, 2015 :
    My OPT home button is now fixed. last thing i did was:SETTING==>APPS==>ALL APPLICATIONS==>COM.ONEPLUS.FINGERPRINT.SERVICE, Clear cached and Forced close and restart. It worked after that itself..
     

    #3
  4. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    I'm glad it worked for u :)
     

    #4
  5. yekenuk Donut Nov 3, 2015

    yekenuk, Nov 3, 2015 :
    Ah thanks... having this problem too.. however the "clear cache" button doesn't seem to work?

    I can force stop and restart but makes no difference?
     

    #5
    acemachine301 likes this.
  6. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    do a factory reset
     

    #6
  7. yekenuk Donut Nov 3, 2015


    #7
  8. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    Ok try to boot in safe mode,
     

    #8
  9. yekenuk Donut Nov 3, 2015


    #9
  10. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    If u dnt wanna do a factory reset, then there is nothing i can do..i have already explain the possible solution,now its up to u.
     

    #10
  11. yekenuk Donut Nov 3, 2015

    yekenuk, Nov 3, 2015 :
    Yeah looks like a reset. Joke - only had it a few weeks! What's to say it wont happen again... :(
     

    #11
  12. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    Yes there is no guarantee, but at least now i know its a software issue, and it can be fixed.
     
    Last edited: Nov 3, 2015

    #12
    yekenuk likes this.
  13. yekenuk Donut Nov 3, 2015


    #13
    HaxxaN likes this.
  14. Martino1plus Ice Cream Sandwich Nov 3, 2015


    #14
    HaxxaN likes this.
  15. Satish18 Cupcake Nov 3, 2015


    #15
    npt likes this.
  16. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    Just force close and reboot
     

    #16
  17. HaxxaN Ice Cream Sandwich Nov 3, 2015

    Last edited: Nov 3, 2015

    #17
  18. X_mg Froyo Nov 3, 2015

    X_mg, Nov 3, 2015 :
    can you say what you have modified?
    my home button is completely dead :(
     

    #18
  19. HaxxaN Ice Cream Sandwich Nov 3, 2015

    HaxxaN, Nov 3, 2015 :
    My OPT home button is now fixed. last thing i did was:SETTING==>APPS==>ALL APPLICATIONS==>COM.ONEPLUS.FINGERPRINT.SERVICE, Clear cached and Forced close and restart. It worked after that itself..

    This is how he fixed.
    If it didnt work for u, then i suggest do a factory reset
     

    #19
    VenomousPL likes this.
  20. X_mg Froyo Nov 3, 2015


    #20