10
[FIX] Google Play Services battery drain fix (no apk, root, privacy guard or script needed)

  1. weresloth
    Honeycomb Apr 15, 2015

    weresloth , Apr 15, 2015 :
    If you experience high battery drain and Google Play Service consumption is quite high in your battery stats, you can try this fix to solve the issue.

    1) Go to Settings / Apps.
    2) Swipe down until you find Google Play services. Tap on it. Tap on "Uninstall updates".
    3) Go to https://play.google.com/store/apps/details?id=com.google.android.gms and update Google Play services.
    4) Reboot.

    Even though it's counter intuitive that removing and re-installing the same version of Google Play Services would do anything, it worked perfectly for me. After I recharged my OPO, Google play services wasn't present in the battery stats anymore and battery consumption was back to normal.

    I'm currently on 05Q, so I don't know if this works on Lollipop. It would be nice to know if this fix can be used on OxygenOS, since it doesn't have privacy guard.

    Credit goes to @konaparthiseshank :
    https://forums.oneplus.net/threads/cm12s-google-play-services-battery-drain.297022/#post-10873051

    I tried it, it worked like a charm and I though it deserved its own thread. As far as I know other threads about Google Play Services fixes either use Privacy Guard, scripts or the GServiceFix apk. Otherwise, mods feel free to delete.


    Edit: a screenshot after the procedure above:
    wakelock fix.png
     
    Last edited: Apr 15, 2015

    #1
  2. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    Screenshot_2015-04-15-16-02-51.png
    Hey. This is what comes in play services. I cannot click on uninstall updates. Help?
     

    #2
  3. weresloth
    Honeycomb Apr 15, 2015


    #3
  4. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    You need to go to Settings -> Security -> Device Administrators and temporarily disable Android Device Manager.
     

    #4
    doekus, MrAmazing360 and Astraion like this.
  5. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    @weresloth I've tried this fix, and it didn't work for me, unfortunately. Allowing Google Services to update simply brought back the wakelocks. :(

    I have since found an alternative, but it only works with root access. I'll post a new thread with the sources and the instructions post haste.
     

    #5
  6. weresloth
    Honeycomb Apr 15, 2015

    weresloth , Apr 15, 2015 :
    Thanks for your feedback.

    By "allowing Google Services to update" do you mean you left the previous version of Google Play services running until it re-updated itself automatically? Maybe if you manually update from the play store something different happens.

    Also, can you provide a bit more details about your ROM, so that it might be possible to understand which conditions need to be met for this fix to work like in my case?
     

    #6
  7. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Sure thing man: I'm using CM11S build 44S with stock kernel, TWRP recovery and SuperSU root.

    After uninstalling Google Play Services and rebooting the phone, I installed the 7.0.99 build from the Play Store manually, after which the wakelocks just persisted. I'm currently working on writing a new thread with the fix that worked for me, I'll post the link here once I'm done with it.

    Cheers.
     

    #7
  8. weresloth
    Honeycomb Apr 15, 2015

    weresloth , Apr 15, 2015 :
    Thanks for the details.

    It would be nice to know what ROM @konaparthiseshank has. He's the one who originally posted the fix. The more data we have the higher the probability to understand why it works in some cases and it doesn't in others.
     

    #8
    rez1_k likes this.
  9. rez1_k
    Ice Cream Sandwich Apr 15, 2015


    #9
  10. Nisarg M
    Jelly Bean Apr 15, 2015


    #10
  11. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    Tried. Its not getting disabled.
     

    #11
  12. weresloth
    Honeycomb Apr 15, 2015

    weresloth , Apr 15, 2015 :
    It's weird you can't uninstall updates. I'm on 05Q as well and the uninstall button is enabled.

    Your ROM behaves like the latest version was flashed instead of updated on top of the default one.
     

    #12
  13. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    Didn't flash though. Got an OTA for it. Can't even deactivate android device manager.
     

    #13
  14. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Click on the "Android Device Manager" checkbox and select "Cancel" instead of "Activate".
     

    #14
  15. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    I'll try.
     

    #15
  16. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    Didn't work
     

    #16
  17. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Sorry man, that's all I got... If you're rooted, why don't you try my proposed fix?
     

    #17
  18. Nisarg M
    Jelly Bean Apr 15, 2015

    Nisarg M , Apr 15, 2015 :
    Not rooted. Figure I will get 12 soon. Might as well wait.
     

    #18
  19. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Okay, good luck.
     

    #19
  20. Nisarg M
    Jelly Bean Apr 15, 2015


    #20
    rez1_k and weresloth like this.