3
[FIX][ROOT][CM11&12] An alternative fix for Google Services wakelocks (without using Privacy Guard)

  1. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    A little background first: I got this Google Play Services wakelock issue the first time a month ago. Simply updating the queued apps in the Play Store fixed the problem for me. Two weeks ago while I was on a trip abroad, it came back with a vengeance! No matter what I did, the wakelock wouldn't go away. I wouldn't resort to using Privacy Guard to fix the issue because it wouldn't be a "fix", it would simply be a workaround and introduce the possibility of random reboots.

    Earlier today, I came across this useful subreddit:
    http://www.reddit.com/r/Android/com...s_the_new_play_services_7x_presenting/cpg8bad

    Lo and behold! It works! According to this info, the wakelock occurs due to a problem in CM11S which causes the system update service to force the device to stay awake indefinitely. Strangely, it's not due to this service being enabled, but rather being disabled that the issue occurs.

    I downloaded the recommended Disable Service app by WangQi from the Play Store (https://play.google.com/store/apps/details?id=cn.wq.disableservice) and the mere act of installing the app fixed the issue for me. Most others might need to give it root access and enable the system update service from here:

    Screenshot_2015-04-15-16-50-27.png Screenshot_2015-04-15-16-50-36.png

    After over a week of dealing with sub-par battery life, it's such a relief to have my OPO working the way it used to. Following are some shots of the current state of wakelocks:

    Screenshot_2015-04-15-17-01-55.png Screenshot_2015-04-15-17-01-39.png Screenshot_2015-04-15-17-10-00.png

    As you can see in the screenshots above, the system is only awake for a hair over the time that the screen is on. So if anyone is still having this problem, or you're not happy with the Privacy Guard wakelock block fix, give this method a try and let us know how it works for you.

    A big thanks to PumpkinCrook on the android subreddit for posting this fix.
     

    #1
    Polie, alexcase93 and fazEp like this.
  2. rez1_k
    Ice Cream Sandwich Apr 15, 2015


    #2
  3. sushant.butta
    Cupcake Apr 15, 2015

    sushant.butta , Apr 15, 2015 :
    It will pop up when you reboot the device. you will have to do it every time you reboot the device.
     

    #3
  4. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    When you say "it", do you mean the wakelock? I've rebooted the device once after using TWRP to clear the cache and Dalvik cache before trying the fix. So far, everything seems okay.

    Edit: Also, I rarely find myself rebooting more than once or twice a week... Sometimes even less. I think the same applies for most users - Android's efficient memory management lets you have months of continuous use before the performance takes a hit. Still, I get your point. For people who reboot everyday, for example, this fix might not be entirely convenient.
     

    #4
  5. aesalem
    Cupcake Apr 15, 2015

    aesalem , Apr 15, 2015 :
     

    #5
  6. aesalem
    Cupcake Apr 15, 2015


    #6
  7. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    @aesalem Sir, please do not spam the forums with requests for invites - this is not the right place to ask for an invite, there is a whole forum thread dedicated to invites. Search for it. Also, you don't need invites anymore. You can just buy the phone outright without any invites every Tuesday.
     

    #7
  8. ReRunRod
    Gingerbread Apr 15, 2015


    #8
    cruxjc138 and rez1_k like this.
  9. DarkSteemex
    Ice Cream Sandwich Apr 15, 2015


    #9
  10. Frederick
    Ice Cream Sandwich Apr 15, 2015

    Frederick , Apr 15, 2015 :
    I also need to redo the whole process after a reboot. I find the privacy guard method more permanent. I didn't enable the system update however. I enabled the update from Google play service and Google services framework
     

    #10
  11. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Check your battery stats to see if your phone is awake like 100% of the time. If it still is, disable the service and re-enable it. Make sure you reset your battery stats and let your phone sit on standby for a few minutes before your evaluate the state of the wakelocks. Also, try using Wake Lock Detector... It works effectively at tracking down what's keeping your device awake.
     

    #11
  12. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Maybe that's why it's not working? According to the reddit post, the problem is supposedly in the conflict between Google's monitoring of system updates and the CM updater service reporting its current state of updatedness. Enabling Google Services' updater won't likely contribute to a fix... If anything, it'll make things worse.
     

    #12
  13. gauravnandanwar40
    Gingerbread Apr 15, 2015

    gauravnandanwar40 , Apr 15, 2015 :
    sir what is Google Play Services wakelock???
     

    #13
  14. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Since the latest update to Google Play Services, a lot of Cyanogenmod users have been getting awful (like half or worse) battery life. The cause for this is Google Services keeping the phone awake continuously regardless of whether it needs to or not. The ability of an app or service to keep your device "awake" or keep using the CPU despite your screen being off is called a wakelock. Apps like Facebook, Messenger and Skype also utilize aggressive wakelocks, which is why a lot of Android users see poor battery life after installing these apps.
     

    #14
  15. rez1_k
    Ice Cream Sandwich Apr 15, 2015


    #15
    DaxNagtegaal likes this.
  16. DarkSteemex
    Ice Cream Sandwich Apr 15, 2015


    #16
  17. gauravnandanwar40
    Gingerbread Apr 15, 2015

    gauravnandanwar40 , Apr 15, 2015 :
    thanks sir....so how i resolve that issue???
     

    #17
  18. konaparthiseshank
    Gingerbread Apr 15, 2015

  19. Bloodpuke
    Honeycomb Apr 15, 2015


    #19
    TakeMyMoney and rez1_k like this.
  20. rez1_k
    Ice Cream Sandwich Apr 15, 2015

    rez1_k , Apr 15, 2015 :
    Depends on your SoT. Ordinarily, your screen would take the most of your battery (around 40 to 60%) with games coming up second and Android System coming in third or fourth... 30% is perfrectly fine, provided that your screen isn't on for too long. Remember, a percentage figure doesn't quantify the exact amount of battery something consumes, it's just representative of the usage ratio against other variables.
     

    #20