29

Fix the horrible GPS

  1. Deactivated User Jun 14, 2017


  2. f.jusdado Froyo Jun 15, 2017

    f.jusdado, Jun 15, 2017 :
    But the problem of GPS is interference with LTE carrier. Try to use sygic without data, you will see how you have no losses. Like I said (if u did read) with my O2 simcard I face problems, with the Vodafone Germany I don't,with the Czech Vodafone I don't, and on roaming I don't.
     

  3. f.jusdado Froyo Jun 20, 2017

    f.jusdado, Jun 20, 2017 :
    After some time trying, i loose connection some times... But much less than before... C'mon One plus... Almost done!!!!!
     

  4. G_Godfrey_H._vCHr Gingerbread Jun 28, 2017


  5. sethilakshay Cupcake Jul 5, 2017


  6. Henry78 Eclair Jul 5, 2017

    Henry78, Jul 5, 2017 :
    Upgraded to 4.1.6 to days ago and up to now its *far* better. Fix in 3-10 seconds, mostly 4-5. Previously it took up to several minutes.

    I'm in Austria, provider is "3"

    [edit] I didn't touch the gps.conf
     

    remedy and G_Godfrey_H._vCHr like this.
  7. G_Godfrey_H._vCHr Gingerbread Jul 6, 2017

    G_Godfrey_H._vCHr, Jul 6, 2017 :
    Which problem did you have before? Frequent drops? Or long time before first fix only?
     

  8. Henry78 Eclair Jul 6, 2017


    G_Godfrey_H._vCHr likes this.
  9. shifatkhan Cupcake Jul 9, 2017

    shifatkhan, Jul 9, 2017 :
    I read somewhere that swapping SIM card slots can fix this issue.
    I will try it when I get access to my pin back at home.
     

  10. Henry78 Eclair Jul 9, 2017

    Henry78, Jul 9, 2017 :
    Didn't help here.
     

  11. G_Godfrey_H._vCHr Gingerbread Jul 9, 2017

    G_Godfrey_H._vCHr, Jul 9, 2017 :
    Didn't help me either
     

  12. shifatkhan Cupcake Jul 13, 2017

    shifatkhan, Jul 13, 2017 :
    Here's some information on my issue, it might help narrow down the problem:
    1. GPS works fine when connected to WiFi
    2. GPS does not work when connected to Mobile Data
    3. Tried "GPS test" app + update and clear = failure
    4. Tried rebooting device and clear cache = failure
    5. Tried to alternate between High accuracy and GPS only in settings = failure
    6. All tests were done on Google Maps and Pokemon GO
     

  13. KibbelKing Donut Jul 14, 2017

    KibbelKing, Jul 14, 2017 :
    I found only one solution.
    Only changing my mobile data to 2G, did the trick for me.
    Now i got a quick gps connection and no connection drop.

    Android 7.x
    1. config
    2. sim & network
    3. preferred network type
    4. select 2G
     

  14. G_Godfrey_H._vCHr Gingerbread Jul 14, 2017

    G_Godfrey_H._vCHr, Jul 14, 2017 :
    Editing the gps.conf as mentioned in several posts in this thread also might work for you. I had the same issue (2g solved the problem when nothing else did, except for switching carriers). However, no one here has confirmed whether the gps.conf edit works with 7.x - I haven't updated yet to try it.
     

    KibbelKing likes this.
  15. KibbelKing Donut Jul 14, 2017

    KibbelKing, Jul 14, 2017 :
    :) Sorry did not read all posts.
    I will try this evening, when driving long distance.
    thank you for this information.
     

    G_Godfrey_H._vCHr likes this.
  16. shifatkhan Cupcake Jul 14, 2017

    shifatkhan, Jul 14, 2017 :
    I found a FIX!

    This fix applies to those who disabled Data Usage on Google Play Services and Google Play Store.

    Go to Settings > Apps > Google Play Services and/or Google Play Store > Data usage > uncheck "DataUsage disabled"
    Note: The "Unrestricted data usage" setting does not affect this. So you can decide whether you want to check or uncheck this.

    GPS works perfectly with WiFi and Mobile Data (Tested with Google Maps and Pokemon GO)

    Let me know if this fixes your issue ;)

    [​IMG]
     
    Last edited: Jul 14, 2017

  17. KibbelKing Donut Jul 15, 2017

    KibbelKing, Jul 15, 2017 :
    good news
    after two hours of driving "it is now 02:25am -_-"
    no connection lose and instant connection to gps with Sygic

    Tested with Oxygen 4.1.6 "Android 7" and gps.conf modification. " Fix the horrible GPS"
    first route 100km normal weather
    second route 100km raining weather

    In both conditions no problems at all.
    I hope this will help others too.
     

    G_Godfrey_H._vCHr likes this.
  18. G_Godfrey_H._vCHr Gingerbread Jul 15, 2017

    G_Godfrey_H._vCHr, Jul 15, 2017 :
    2G?

    Either way, I'm backing up now to update and see what happens. Will post findings.
     

    KibbelKing likes this.
  19. KibbelKing Donut Jul 15, 2017

    KibbelKing, Jul 15, 2017 :
    :) no with 4g LTE

    I am very sorry, got the wrong link
    this link is the correct one:
    https://forums.oneplus.net/threads/fix-the-horrible-gps.465819/page-4#post-15298441
    "long version of my gps.conf"

    I have only changed the gps.conf nothing else.
    network type is "2G/3G/4G (Automatic)"

    i was co-driver at the first part of the route
    so i could check the network and it was 4G LTE
    sorry i forgot to take screenshots :)
     

    G_Godfrey_H._vCHr likes this.
  20. G_Godfrey_H._vCHr Gingerbread Jul 16, 2017

    G_Godfrey_H._vCHr, Jul 16, 2017 :
    Ok! So updated:
    Flashed back to stock recovery, downloaded 4.1.6 using update option in settings menu. Was surprised at how well everything went with the update. Very happy about that. Tested GPS - issues returned (was previously on the gps.conf fix in 3.x.x)

    So I warily tried this:
    ... It didn't work.

    Flashed TWRP to give me system write access through recovery and overwrote gps.conf again. All seems to be well for now. Will post if that changes.

    Thanks @KibbelKing for testing gps.conf fix on 4.1.6 as well!
     

    KibbelKing likes this.