1
[FIX]Wifi (no flash) static IP

  1. 98schaeffer
    Eclair May 11, 2015

    98schaeffer , May 11, 2015 :
    Just set a static IP-address, that's all!!
    Advanced guide:
    1. You have to make connection first (this is the only time it will be difficult), if you have trouble connecting you can try the following things:
    • Turn WiFi off and on again
    • Forget network and add again
    • Turn on airplane mode and off
    • Restart opo
    2. Tap and hold the WiFi network, select "edit network"
    3. Check "advanced options" and set IP settings to "static" (or non dhcp)
    4. Fill in the IP-address you've got (visible at top of the settings screen)
    5. Save and you're done!!

    Note: it may not work on every network but give it a try
     
    Last edited: May 11, 2015

    #1
    galina.keremidska likes this.
  2. AndyPober
    Ice Cream Sandwich May 11, 2015

    AndyPober , May 11, 2015 :
    When I did it it seemed to eat battery. Also I had to configure DNS servers, gateway... If you're rooted, just replace the dhcpcd file with the onefrom KitKat. Fixes all the wifi issues.
     

    #2
  3. 98schaeffer
    Eclair May 11, 2015


    #3
  4. 70challenger
    Froyo May 21, 2015

    70challenger , May 21, 2015 :
    Thanks but didnt work for me, I have a connection with a exclamation point on my go pro or my dji phantom after this update, when are you going to fix this opo?
    I have tried static ips on both but still do not work...
     

    #4
  5. dirk.siron
    Cupcake Jun 24, 2015


    #5
  6. markbrak
    Donut Jun 24, 2015

    markbrak , Jun 24, 2015 :
    Mine did it on my wireless G signal. When it was on wireless N it didn't seem to do it. I set a static IP on my N network and fixed until 5.1 comes out.
     

    #6
  7. meor
    Ice Cream Sandwich Jun 24, 2015


    #7
  8. iggss13
    Cupcake Aug 13, 2015

    iggss13 , Aug 13, 2015 :
    Can someone please post a tutorial on how to flash the wifi fix from start to finish?
    I would really appreciate it.
     

    #8
  9. washidbasith
    Donut Dec 15, 2015


    #9
  10. SloppyJo_
    Cupcake Feb 2, 2016

    SloppyJo_ , Feb 2, 2016 :
    I've had countless wifi issues with my OPO. I've rooted it, flashed files from various posts, restored factory defaults, and tried the static IP fix. All of these "fixes" either don't work or are merely temporary. This is unlikely, but does anyone have a one-shot deal fix that I could either flash? Is there a file I can modify to fix this? I'm getting desperate!
     

    #10