73
[FIXED] [FOR GOOD] Microphone issue

  1. jordym Honeycomb Dec 30, 2014

    jordym, Dec 30, 2014 :
    Hi this is for those who suffer from the microphone issue. I finally stumbled upon a solution:

    if updating, rooting and changing mixer_paths did not work. Here is how you can fix it.

    First you need a rooted device.

    If you could, edit using a file explorer such as ES Explorer with root access

    /system/build.prop. Change

    ro.qc.sdk.audio.fluencetype=fluence

    to

    ro.qc.sdk.audio.fluencetype=none

    Then, edit /system/etc/audio_platform_info.xml

    <device name="SND_DEVICE_IN_HANDSET_MIC" acdb_id="40" />

    to

    <device name="SND_DEVICE_IN_HANDSET_MIC" acdb_id="4" />

    Reboot.

    this is the reason why even flashing mixer_paths was useless. if required, i will be able to post links for the files involved in other to flash them.
     

    #1
  2. Hanness Donut Jan 1, 2015


    #2
    remedy, punitdaga31, JHong and 4 others like this.
  3. shawn0223 Honeycomb Jan 1, 2015

    shawn0223, Jan 1, 2015 :
    Yes, which issues are you referring to? And what exactly is it doing when we edit those lines?
     

    #3
  4. Hanness Donut Jan 1, 2015

    Hanness, Jan 1, 2015 :
    I've did some research and this should suppress the noice cancelling. In my case the problem that the other side can't hear me during a call (they can only hear me on speaker mode) is fixed when I put my finger on the other microphone (next to the camera), so I'll try this solution tomorrow.
     

    #4
  5. toter4 Donut Jan 2, 2015

    toter4, Jan 2, 2015 :
    Has anyone else tried this solution? I've been having a problem with poor sound quality from the microphone in calls. The person I call complains that they can barely hear me. I've tried calling myself and I can confirm this. In my case I've also noticed that there's an echo whenever I said anything using the OPO. Seems like this could be due to the multiple microphones and a glitch in the noise-cancelling function.
     

    #5
  6. vdd65 Jelly Bean Jan 2, 2015


    #6
  7. kuhler Gingerbread Jan 2, 2015

    kuhler, Jan 2, 2015 :
    This =link=>
     

    #7
  8. Hanness Donut Jan 2, 2015

    Hanness, Jan 2, 2015 :
    It did not solve my problems unfortunately. I can only still call properly when I put on speakermode.
     

    #8
  9. erik725 Honeycomb Jan 2, 2015

    erik725, Jan 2, 2015 :
    This solved my problems during the call, excellent now the other person can hear me, thank you very much for the answer!!
     

    #9
    gmbruine, Oszy and SoniaB like this.
  10. dreniacdre KitKat Jan 2, 2015

    dreniacdre, Jan 2, 2015 :
    There is one in the top too, right?
     

    #10
    saadsid11 likes this.
  11. AuntieAnn Ice Cream Sandwich Jan 2, 2015

    AuntieAnn, Jan 2, 2015 :
    Thank you, kind citizen of OP. Here, I have procured 3 lovely ladies for a sacrifice in your honor. For those that try it, let us know how it goes.
    IMG_43178520284788.jpeg
     

    #11
  12. Hanness Donut Jan 2, 2015

    Hanness, Jan 2, 2015 :
    The solution here didn't work on its own. Now that I also modified the mixer-paths.xml, everything seems to work fine again.
     

    #12
    Dynamix likes this.
  13. Oxholm Donut Jan 2, 2015

    Oxholm, Jan 2, 2015 :
    Hi, I have the problem too, where the other person can't hear me.
    I've modified my mixer-paths.xml and it helped (in some cases only apparently).
    Should I revert the mod, for this to work or should I be okay?
     

    #13
    saadsid11, NISCHAL99 and JamesNicky like this.
  14. Oxholm Donut Jan 3, 2015

    Oxholm, Jan 3, 2015 :
    Can someone tell me this? :/
     

    #14
  15. Hanness Donut Jan 3, 2015

    Hanness, Jan 3, 2015 :
    What do you mean exactly?

    In my case it seems to work when I did both the modifications in this thread and adapting the mixer-paths.xml. You can always try it and see what works best, the changes are easily reversible.
     

    #15
  16. Oxholm Donut Jan 3, 2015


    #16
    tamzak likes this.
  17. Oxholm Donut Jan 3, 2015

    Oxholm, Jan 3, 2015 :
    lol... Now the phone doesn't even boot - How great!
    *Blows off head*
     

    #17
    marek.maurizio likes this.
  18. IWantOneNow Jelly Bean Jan 3, 2015

    IWantOneNow, Jan 3, 2015 :
    You can just reflash "system" in fastboot. Is your bootloader unlocked?
     

    #18
  19. Oxholm Donut Jan 3, 2015

    Oxholm, Jan 3, 2015 :
    yea, it is :) How much will I wipe doing that? :p

    I'm on Lollipop btw., if that changes anything :)
     

    #19
  20. Oxholm Donut Jan 3, 2015

    Oxholm, Jan 3, 2015 :
    "Unable to mount system" - auch..
    How do I reflash "system" then?

    Edit: Fixed it by re-flashing my ROM..
    So, note to all: Don't do this on Lollipop - At least, if you did, do tell me how you solved it :)
     
    Last edited: Jan 4, 2015

    #20