24
[FLASHABLE ZIP] Enable integrated superuser

  1. tekkfreak
    Eclair Oct 14, 2014

    tekkfreak , Oct 14, 2014 :
    Of course but what's the difference between that and an already rooted or phone with a CWM / TWRP recovery? Surely same level of security issue!

    And in any case NO-ONE is getting their hands on my OPO .. it's mine and it will never be leaving my sight!! :mad:

    Perhaps if it was made available via the Cyanogen account, and the script self deleted the zip file afterwards, then that would reduce the risk.
    Perhaps even if it was ID'd to that Cyanogen account, it would stop the spread by casual users knowing they would be identified!

    Anyway I still think on balance this is something that most serious OPO users would accept as a risk, and live with. If not they could go buy an iPhone6+ .. :D
     

    breeze, Chugz and Link_of_Hyrule like this.
  2. EpiphanyOfMusic
    Donut Oct 14, 2014


  3. tekkfreak
    Eclair Oct 14, 2014

    tekkfreak , Oct 14, 2014 :
    Nothing functionally different, just better integrated to Koush's Superuser UI already in all the CM11S ROM. And MUCH easier to install .. if a proper signed version was ever made available .. ;)
     

  4. RickyWars1
    Gingerbread Oct 14, 2014

    RickyWars1 , Oct 14, 2014 :
    Because this package is signed, do I require an unlocked bootloader or a custom recover (TWRP) to install it. Apologies for a noob question, I'm not too educated about this kind of stuff.
     

  5. tekkfreak
    Eclair Oct 15, 2014

    tekkfreak , Oct 15, 2014 :
    This is the main argument point .. if we did get a "cyanogen" signed superuser.zip, then no you would not, this would be then the most trivial way to root. See my comment here earlier in the thread ..
    https://forums.oneplus.net/threads/...ntegrated-superuser.75511/page-5#post-6315567

    and it was also raised as a petition, so go vote on Breeze's poll here .. https://forums.oneplus.net/threads/poll-petition-for-a-stock-recovery-flashable-root.91425/

    If you are talking about jak's version at the start of this thread, unless you have an 30O or older CM11S recovery version, then you still have to unlock the bootloader and wipe the phone. Using a custom recovery is still of course mandatory for the final zip install.
     
    Last edited: Oct 15, 2014

  6. oscarvanl
    Jelly Bean Oct 15, 2014

    oscarvanl , Oct 15, 2014 :
    I have the light version of this installed and want to copy the "TWRP" folder in the root of my device to my PC to backup a nandroid backup. I'm trying to do this with ADB because the Internal Storage when connected to my PC can't see this as it's in a root folder. For some reason ADB says "device not found". Any ideas? Is it related to this - I assumed it might be due to the light version interfering with ADB in some way.
     

  7. jak
    Ice Cream Sandwich Oct 15, 2014

    jak , Oct 15, 2014 :
    It's not interfering with adb, adb should work fine as normal user. But adb root only works if you flash the debuggable boot img or Franco's kernel.
     

  8. inscythe
    Eclair Oct 16, 2014

    inscythe , Oct 16, 2014 :
    Do you have any issues with sometimes the allow button can't be tapped? I'm using the full su binary (not the light version) and the latest 38R debuggable stock kernel. I checked CM11 thread, apparently it is a common bug...

    EDIT: Sorry, it wasn't a bug, but rather a conflict with the tapjacking protection and Lux
    https://plus.google.com/ ChanCheeChiew/posts/1oMYsnZVrhy
     
    Last edited: Oct 16, 2014

  9. Yaffle
    Froyo Oct 28, 2014

    Yaffle , Oct 28, 2014 :
    Thanks for this. I've just received my OPO today and didn't spot a SuperUser option where it usually is on my other devices. I've installed the Light version and am getting the prompts when I first use apps that need SuperUser but still no SuperUser GUI that I can see. Am I missing something obvious (more than likely)?
     

  10. Yaffle
    Froyo Oct 28, 2014

    Yaffle , Oct 28, 2014 :
    I think I may have just found my answer on XDA. I'm just switching to ART but will have a play in a minute.

    Edit

    Yeap, I had to run "setprop persist.sys.root_access 3" from Terminal
     
    Last edited: Oct 28, 2014

    jak likes this.
  11. Link_of_Hyrule
    Froyo Nov 8, 2014

    Link_of_Hyrule , Nov 8, 2014 :
    So I tried to use that command to bring back the Super User options in the settings with the latest OTA (44S) but it didn't seem to work has anyone figured this out?
     

  12. Yaffle
    Froyo Nov 8, 2014

    Yaffle , Nov 8, 2014 :
    Same problem here. I had to reflash the Lite zip and reset data on Android Terminal Emulator as it wouldn't do anything. The command above definitely isn't working for me now though.
     
    Last edited: Nov 8, 2014

  13. Yaffle
    Froyo Nov 8, 2014


  14. aarynb1
    Cupcake Nov 8, 2014


  15. Yaffle
    Froyo Nov 8, 2014


  16. tekkfreak
    Eclair Nov 8, 2014

    tekkfreak , Nov 8, 2014 :
    This is very sad, Cyanogen removing Koush's SuperUser menu in 44S .. such a backwards step and a sign they will never formally allow a simple rooting method. And I really thought the OPO with CM11S was the new revolution in the Android paradigm ..

    Thinking of selling my OPO now the open strategy is being locked down bit by bit .. :(
     

  17. fkrone
    Froyo Nov 8, 2014

    fkrone , Nov 8, 2014 :
    I am on 44S and the Superuser menu is available for me. I hope this menu will survive in Lollipop as it seems for me the "cleaner" way to manage superuser requests.
     

  18. Link_of_Hyrule
    Froyo Nov 9, 2014

    Link_of_Hyrule , Nov 9, 2014 :
    Yeah it looks like the menu was removed which is totally lame. If someone created a mod to add it back in that would be cool but I guess that would make OTAs not work any more.
     

  19. jak
    Ice Cream Sandwich Nov 9, 2014

    jak , Nov 9, 2014 :
    No, the menu was not removed, just hidden on standard kernels. It only appears on a debuggable kernel image, as far as I can tell. So, if you use Franco Kernel, for example, it is still there.

    Nevertheless, even on normal kernels, without the menu appearing in settings, the actual superuser code still works, and will respect previous settings and pop up dialogs as needed.
     

  20. fkrone
    Froyo Nov 9, 2014

    fkrone , Nov 9, 2014 :
    That could explain why I see the menu. I use franco kernel. For me, this solution is really good as OTAs usually don't check kernels so you can flash a custom kernel / debuggable kernel and still receive and flash OTAs without any problems.