3
Flashlight, YouTube, snapchat, back & front camera not working after Oxygen 10.0.10 update via OnePlus 7 Pro

  1. J4t1np4r3kh
    OnePlus Accessory Tester Dec 3, 2020


    #2

  2. #3
  3. Oreo.
    OnePlus Accessory Tester Dec 3, 2020

    Oreo. , via OnePlus 5 , Dec 3, 2020 :
    If you have developer settings unlocked,
    Go to Settings > System > Developer options > Quick setting developer tiles > Enable Sensors Off
    1606997348768.jpg
    Now open your notification panel and add "Sensors Off" tile to the tile area.
    1606997417065.jpg

    Toggle Sensors On then Off. Verify whether your issue resolved or not.
     

    #4
  4. Hitzilla4
    Gingerbread Dec 3, 2020


    #5
  5. danny_hale
    Cupcake Dec 3, 2020

    danny_hale , Dec 3, 2020 :
    Same issue here, I've factory reset. Used msm unbrick tool, flashed 10.0.4 + 10.0.9. nothing works, still broken can also confirm above sensor fix doesn't work. Just tried it
     

    #6

  6. #7
    Oreo. likes this.
  7. Oreo.
    OnePlus Accessory Tester Dec 3, 2020


    #8
  8. Danielbub
    Donut Dec 3, 2020

    Danielbub , Dec 3, 2020 :
    Same
    So I updated my op7p to beta 19 and the issues I have are
    Front and rear camera not working at at all (black screen not crashing)
    teams call not connecting (which is the main deal breaker for me)
    youtube keeps loading main page
    flash not working

    What I tried:
    factory reset
    switching between EU / Global different android 10 versions including 10.0.10.
    Flashing from EDL /TWRP
    With or without magisk
    Different versions of kernels. (After/ stock)
    Downgrading / updating camera and camera service apk.
    Flashing hydrogenOS.
    Custom ROMs..

    Using adb logcat I found that the camera service isn't responding.

    Notes:
    I don't have warranty..
    Device GM1913
    The device works without selfie camera in android 9.5.1.

    Let's try to debug this, comment your's ideas!

    Thanks!
     

    #9
    novrainn06 likes this.
  9. X1568209099905 , via OnePlus 7 Pro , Dec 5, 2020 :
    Same
     

    #10
  10. novrainn06
    Cupcake Dec 7, 2020

    novrainn06 , Dec 7, 2020 :
    Hi I have same issue after Beta 17 update. (device OnePlus 7 pro 12/256 GM1910) front camera, youtube, flashlight.
    The Official Android latest 10.3.2 also both camera, youtube flashlight not work.
    then downgraded to Android 9.5.1 to 9.5.13 (also found 10.0-10.0.1 also same) now all problem solved except front camera not working, it does not crashes, but nothing happens when click switch front camera button.
    I hope its not a hardware issue, and expecting to solve by next software update.
    If u have found any solution please inform here.
     

    #11
  11. C1599895606710
    Cupcake Dec 15, 2020


    #12
  12. X1608021392961
    Cupcake Dec 15, 2020


    #13
  13. lijop
    Eclair Dec 15, 2020


    #14
  14. _Bharat_
    Gingerbread Dec 18, 2020


    #15
  15. JulianAB6
    Froyo Dec 19, 2020


    #16
  16. novrainn06
    Cupcake Dec 28, 2020


    #17
    lijop likes this.
  17. novrainn06
    Cupcake Jan 10, 2021

    novrainn06 , Jan 10, 2021 :
    follow this method youtube veideo,
     

    #18
  18. novrainn06
    Cupcake Jan 10, 2021

    novrainn06 , Jan 10, 2021 :
    Follow the procedure in this youtube vide and download to downgrade to android 9, hope camera will work again. but keep in mind, if u OTA upgrade again to android 10, then camera, youtube, flashlight wont working. you have to again downgrade to android 9.
     

    #19
  19. lijop
    Eclair Jan 10, 2021

    lijop , via OnePlus 7 Pro , Jan 10, 2021 :
    Thanks, I rma'd it to Poland, they fixed and send me back. Both cameras and all apps work now.
     

    #20
    novrainn06 likes this.