12
For Auto-Rotate Not Working

  1. Xiaohuamm
    Froyo Feb 5, 2018

    Xiaohuamm , Feb 5, 2018 :
    In case anyone else notices auto-rotate not work well, here's how I fixed mine. Hope it helps someone!

    1) Dial *#808# in your dialer

    2) In the menu, go to the "Device debugging" tab and scroll all the way down

    3) Set your phone on a flat surface and press "Sensor self-test and calibration"

    4) Tap Gyroscope and Accelerometer options about 5 times each

    5) Try it out!

    Originally suggested by user @codyjames223 on the OnePlus forums.
     

    #1
  2. bboylaiiz
    Donut Apr 25, 2018

    bboylaiiz , Apr 25, 2018 :
    I can confirm that it works after sensor calibration! It was a really annoying issue. Thanks a lot!
     

    #2
    Xiaohuamm likes this.
  3. Xiaohuamm
    Froyo May 13, 2018

    Xiaohuamm , May 13, 2018 :
    ur welcome bro
     

    #3
    bboylaiiz likes this.
  4. Ludo_Mansio
    Gingerbread May 22, 2018


    #4
    Xiaohuamm and bboylaiiz like this.
  5. sreenesh 1980
    Cupcake Jun 5, 2018

    sreenesh 1980 , Jun 5, 2018 :
    Friend it worked, I tried to reset the phone earlier without any luck.
     

    #5
    Xiaohuamm likes this.
  6. krishankumar77
    Cupcake Jun 7, 2018


    #6
  7. airness456
    Cupcake Jul 20, 2018

    airness456 , Jul 20, 2018 :
    Still doesn't Work for me. The screen rotation is not working at all, I tried everything you said, even reboot multiple times and nothing.

    Here what it looks After doing the calibration, everything works but the last option accelerometer
     

    Attached Files:


    #7
  8. zWhoHeBe
    Cupcake Jul 24, 2018

    zWhoHeBe , Jul 24, 2018 :
    Same exact thing for me .High bias. Please escalate OP! Using OP6. Issue happened with update to 8.1
     

    #8
  9. N1534337645140
    Donut Aug 15, 2018

    N1534337645140 , Aug 15, 2018 :
    my OP6 same problem auto rotate not working....but ur information is very helpfull...now its work ... good ...thanks a lot .
     
    Last edited: Aug 15, 2018

    #9
  10. mazzu
    Cupcake Aug 21, 2018

    mazzu , Aug 21, 2018 :
    Thank you so much, it works! Months with rotation problem till I found your post...
     

    #10
  11. H1518223333858
    Cupcake Feb 10, 2019

    H1518223333858 , Feb 10, 2019 :
    Hi OP5

    My auto rotating not working have tried above all option but still no luck, m after doing calibration test for sensor getting failed test in accelerometer bmi160

    Request your help to fix it
     

    #11
  12. J1538667611487
    Eclair Apr 14, 2019

    J1538667611487 , Apr 14, 2019 :
    my op6 also shows the same and auto rotate is not working. did you get yours fixed?
     

    #12
  13. dibyendu.cts07
    Cupcake Jul 3, 2019

    dibyendu.cts07 , Jul 3, 2019 :
    I am facing same issue. I followed the above steps but I am also getting error message as "high bias". I have done factory reset but still same issue.
    Can someone tell what to do next?
     

    #13
  14. dibyendu.cts07
    Cupcake Jul 6, 2019

    dibyendu.cts07 , Jul 6, 2019 :
    Yesterday I have received oxygen upgrade and after upgrading, auto rotation is working fine. After upgrading, just do the steps as mentioned above. Like *#8088# then "Device debugging" tab and so on. Thanks for your support.
     
    Last edited: Jul 6, 2019

    #14
  15. F_Rokas_Paliulis_Ntkb
    Cupcake Jul 30, 2019

    F_Rokas_Paliulis_Ntkb , Jul 30, 2019 :
    I have oneplus7pro and my autorotate with display sleep time keeps turning off into off and 30secs to standarts and how hard i i t to keep it on or display sleep time longer it just backs to first stage and i cant fix it. Any dialing codes are not working to my phone! Can i maby try to hive this phonr to my courier??!
     

    #15
  16. susajsnair
    Cupcake Oct 10, 2019

    susajsnair , Oct 10, 2019 :
    i have this issue with my OP7, and i couldn't get any response when i dial *#808#. can someone help
     

    #16
  17. twinnmann
    Cupcake Dec 16, 2019

    twinnmann , Dec 16, 2019 :
    Any update on this? I'm having slow rotation responses with my 7T pro. I too, cannot dial the number.
     

    #17
  18. olly2009
    Eclair Jan 22, 2020


    #18
  19. D1579905019308
    Cupcake Jan 24, 2020

    D1579905019308 , Jan 24, 2020 :
    That really works ... Thanks
     

    #19
  20. G1589222368436
    Cupcake May 11, 2020

    G1589222368436 , May 11, 2020 :
    Hi, when I open the diaper and type *#808# it doesn't do anything. It erases what I typed and is just back to the dialer... What do I do? My auto rotate hang been working for a while
     

    #20