17
Guide Formatting EXT4 to F2FS without losing internal storage & data

  1. hh336
    Cupcake Sep 17, 2016

    hh336 , Sep 17, 2016 :
    Thanks for your guide. I was using my sd card as adopted storage and lost my decryption key in the process (not a OnePlus device though). I didn't use your method but rather did a full backup in TWRP 3.0.2-0 and copied the backup files to my PC over MTP. Would the /data/misc/vold/expand_$PARTGUID.key file have been included using your method?
     
    Last edited: Sep 17, 2016

    #41
  2. niTe_RiDeR_Pro
    Ice Cream Sandwich Sep 25, 2016

    niTe_RiDeR_Pro , Sep 25, 2016 :
    Sorry, IDK what that file is, & I am not sure whether this guide works properly for devices other than the OPO... I would not recommend to do this in another device without high-level advanced knowledge of android formatting, filesystems, backup, recovery etc. Please do some research on the internet & continue with my steps. Thanks.
     

    #42
  3. kryshnakishore
    Ice Cream Sandwich Sep 25, 2016


    #43
  4. GuitarGuy
    Cupcake Oct 29, 2016


    #44
  5. keen36
    Gingerbread Oct 30, 2016

    keen36 , Oct 30, 2016 :
    since nandroid backups are stored on the internal memory which gets wiped during this process, you must save the twrp folder from the sdcard to your computer or somewhere else.

    oh and btw. @op, i did this and ran into problems with adb not authenticating after the format, since the adb keyfile was missing. this was quite annoying, i had to adb sideload a temporary rom just to boot up and enable usb debugging to get the prompt that authorized my computer to make adb connections again. i couldn't find another way to push the keyfiles on the phone (i guess a fastboot rom flash would have worked, too). also i had to add a trailing slash after the "/sdcard" of the adb pull command and i had to remove the "sdcard" from the adb push command output path and add it to the input path to get the desired result. also, the push command doesn't push empty directories and i couldn't find a way to make it do that (on linux it's apparently possible to create all the empty directories with a simple bash command before the push, i am running m$ windows though, so i couldn't try it). it's still restoring, but i assume a few empty directories missing won't be a problem.

    edit:
    so, after restoring everything i ran into a problem with the camera app not saving photos correctly and google camera even crashing when taking a photo. it's a permission issue which apparently manifests itself when adb push is being used to restore the data on the sdcard. fix can be found here:
    http://forum.xda-developers.com/showthread.php?t=2222297
     
    Last edited: Oct 30, 2016

    #45
  6. SciLor
    Cupcake Nov 12, 2016

    SciLor , Nov 12, 2016 :
    I have just migrated to f2fs, everything seems to be ok, phone boots, but I cannot unlock my phone.Fingerprint Sensor does nothing.
    SDCard Permissions are fixed, cache / dalvic cleared.

    I cannot unlock it via adb, because adb is not working when my phone is locked. ADB is only working via recovery. Any chance to get adb working under lockscreen to debug?

    It seems that WiFI isn't working correctly, because its connected, but with an "!" beside it.

    EDIT:
    Reflashing the latest nightly, gapps and xposed fixed everything for me :)
     
    Last edited: Nov 12, 2016

    #46
  7. niTe_RiDeR_Pro
    Ice Cream Sandwich Nov 13, 2016

    Last edited: Nov 14, 2016

    #47
    keen36 likes this.
  8. SoniaB
    Nougat Head Moderator Nov 13, 2016

    SoniaB , Nov 13, 2016 :
    Looks like he opened his own thread

    I have removed his posts from this one :)
     

    #48
    keen36 and Gonzo01 like this.
  9. keen36
    Gingerbread Nov 17, 2016

    keen36 , Nov 17, 2016 :
    to expand on my post above concerning the adb keyfiles. you will only run into problems with them if you reboot between the wipe and push steps. if you connect adb in recovery before you wipe and then push the files back while still connected, this problem does not occur. i'm guessing that as long as there is no reboot, the session remains active, even if the keyfiles are removed.

    oh, and another thing i noticed: if you adb pull while in recovery, the stuff in /sdcard/android/obb/ won't be transfered, i would guess that is because the directory isn't mounted properly, idk. you can make a separate backup of those (via mtp or something) if you do not want to download them again on the first start of those apps. if you don't mind redownloading, then you don't need to do this, because apps should not rely on them being there anyway and will have implemented a procedure to download them if they are missing
     
    Last edited: Nov 17, 2016

    #49
  10. G_Ariel_Lopez_UUCm
    Eclair Dec 4, 2016

    G_Ariel_Lopez_UUCm , Dec 4, 2016 :
    How is possible to have cache with Ext4 file system and userdata with F2fs? I thought that after full reset they gonna be in F2fs...
     

    #50
  11. RBeck
    Eclair Dec 26, 2016

    RBeck , Dec 26, 2016 :
    Thanks a lot for this guide. Works perfectly on my OnePlus One CM14.1!
     

    #51
    remedy likes this.
  12. Dennis wensink
    Cupcake Jan 2, 2017

    Dennis wensink , Jan 2, 2017 :
    How Will it work with the new OxygenOS 4.0 on the oneplus 3?

    Wat is the newest stock kernel for OxygenOS 4.0 that will support f2fs?

    How do I install it on the OnePlus 3?
     

    #52
  13. Chriiis
    Gingerbread Jan 3, 2017

    Chriiis , Jan 3, 2017 :
    Same question here. I am coming from 3.2.8 on my Oneplus 3.
     

    #53
  14. remedy
    KitKat Jan 4, 2017

    remedy , Jan 4, 2017 :
    I'm on lineage-14.1 and I found this rom does not support f2fs for /system. So now my OPO /data and /cache folders are f2fs but /system remains ext4.
     
    Last edited: Jan 4, 2017

    #54
    Slatter191 likes this.
  15. Slatter191
    Lollipop Jan 4, 2017

    Slatter191 , Jan 4, 2017 :
    Hi @remedy ,

    How do you find Lineage 14.1, for OPO, vs COS 13.1.2?

    Care to post download link and what gapps have you installed..Micro or Nano?

    Thanks.
     

    #55
  16. Slatter191
    Lollipop Jan 4, 2017


    #56
  17. remedy
    KitKat Jan 4, 2017


    #57
    Slatter191 likes this.
  18. Slatter191
    Lollipop Jan 4, 2017

    Slatter191 , Jan 4, 2017 :
    Thanks. You flashed Lineage over CM or a clean flash?

    Download link for Lineage?



    Edit:

    Which date release.... Jan 4?
     

    #58
  19. remedy
    KitKat Jan 4, 2017

    remedy , Jan 4, 2017 :
    Dirty flash. Just flashed the rom and cleared cache before rebooting. Got the Lineage rom from this link.
     

    #59
    Slatter191 likes this.
  20. Slatter191
    Lollipop Jan 4, 2017

    Slatter191 , Jan 4, 2017 :
    Thanks again, must be satisfied with the ROM and OPOs performance?
     

    #60