Found a fix for Google Play services crashing constantly

  1. cakalusa
    Honeycomb May 27, 2015

    cakalusa , May 27, 2015 :
    If you're currently experiencing an error message that Google Play services has crashed, go to: Setting>Privacy>Privacy Guard>Show built-in apps>Long press Google Play services then put the Wake up and Keep awake back on. This will stop the crashes. From that point, run a few apps that were causing the issues and let it run for a minute or two, then turn off the Wake up and Keep awake toggle and it should stop the crashes and allow you to have the Privacy Guard options back to how you want it.

  2. Afzal Khan
    KitKat May 27, 2015

    Afzal Khan , May 27, 2015 :
    genious...did you tried clearing the cache. :D

  3. tilemover
    Honeycomb May 27, 2015

    tilemover , May 27, 2015 :
    Did anyone ever think that denying Google Play Services the ability to wake up may cause it to crash? Pick one, better battery life by turning off wake up and keep awake or deal with the crashes.

    ned82rt, svprsk and Flyologist like this.
  4. mohamed
    Ice Cream Sandwich May 27, 2015

    mohamed , May 27, 2015 :
    So will keeping them both on result in that message not coming up?

  5. gringoboy
    Lollipop May 27, 2015

    gringoboy , May 27, 2015 :
    I've had it denied for months and never had a crash.

  6. tilemover
    Honeycomb May 27, 2015

    tilemover , May 27, 2015 :
    I don't claim to be an expert, but my Google Play Services doesn't crash. I'm on Exodus 5/01 build with Franco kernel. I use Amplify and Greenify w/ Xposed for battery savings and I have no problems and good battery life. I don't deny Google Play Services the ability to wake up or keep awake in Privacy Guard either.

    BillBauman likes this.
  7. alexlam24
    Ice Cream Sandwich May 27, 2015

    alexlam24 , May 27, 2015 :
    Go to settings, apps -> all and then reset the default app preferences. This was mentioned on a thread a few days ago.

  8. herma007
    Cupcake May 27, 2015

    herma007 , May 27, 2015 :
    I experience the same issues. Mostly when I'm travelling. Maybe something with roaming. Also recieving phone calls triggers a crash.
    I tried tot clear the cache, even removed en re-installed play store..nothing helped.

    To try your solution ..how do I know which app are causing the crash?

  9. BillBauman
    Gingerbread May 27, 2015

    BillBauman , May 27, 2015 :
    I just made the Amplify recommendation in another thread/post. I'm not a OPO user, so I wasn't sure if it was valid. You've now clarified that. Great news.

    I am an avid user of Greenify and Amplify, myself, on my other devices.

    tilemover likes this.
  10. eromore189
    Gingerbread May 27, 2015

    eromore189 , May 27, 2015 :
    Still no luck for me. Been dealing with this issue for about a week. Have no clue what to do next. I thought it might have been amplify, but I disabled it with no luck and same error message. Any thing else to try?

  11. williamhaven
    Ice Cream Sandwich May 27, 2015

  12. ianyeo
    Honeycomb May 27, 2015

    ianyeo , May 27, 2015 :
    Seems like lots of users getting this annoying pop up. Here is the fix. No data will be lost.
    1. Go to settings
    2. Select apps
    3. Scroll left to all column
    4. Click on the 3 dots in top right
    5. Select Reset app preferences
    6. Reboot
    7. Reselect preferred launcher
    8. Thank me
    9. Done! Enjoy!

  13. BillBauman
    Gingerbread May 27, 2015

    BillBauman , May 27, 2015 :
    I'm not sure what all you have tried, exactly. But, you can try all of this as a cover-all that can fix many issues like this. Start with Settings, Apps, All, open Google Play Services and Google Play, in both, Clear Cache and Data. If you have Titanium and root, backup your current Play Store, then uninstall it. Remove your Google account. Reboot into recovery, wipe Cache and wipe Dalvik Cache. Reboot phone, re-add Google account, restore Play Store from Titanium WITHOUT data. Start Play Store.

  14. Walkin_mn
    Jelly Bean May 27, 2015

    Walkin_mn , May 27, 2015 :
    I also used this method and worked like a charm

    ianyeo likes this.
  15. CorB3n
    Jelly Bean May 27, 2015

    CorB3n , May 27, 2015 :
    I tried reinstall Gapps now I m stuck, every app asks to install Google Play services & Gapps did not do the trick : my GPS are gone, how Am I supposed to reinstall them ?
    My Google Account disapear too, I can't create another or login into it..

  16. mwayner
    Lollipop May 27, 2015

    mwayner , May 27, 2015 :
    Before Google decided that Privacy Guard was getting too big for it's britches :D. A sure-fire way to make sure Services plays nice is to suppress it with Amplify. Let it run for a while, check Amplify's wakelock and alarms logs and start limiting. I'm running 05Q but it should work for COS12 too.

    BillBauman likes this.
  17. NiTRON69
    Gingerbread May 27, 2015

    NiTRON69 , May 27, 2015 :
    Amplify requires xposed framework witch is only in Alpha stages and has to be flashed and there is no official uninstall of it so you have to manually delete files if you want to remove it.

  18. thomson.mathew
    Cupcake May 28, 2015

    thomson.mathew , May 28, 2015 :
    I think it worked for me. thanks

  19. nroneplusone
    Donut May 29, 2015

    nroneplusone , May 29, 2015 :
    This worked for me. But I had denied the permission keep awake/wakeup couple of months back, not sure why it had no issues until few days ago. Anyways glad the annoying pop-up is gone now. Thanks for sharing the info.

  20. AAB4K
    Jelly Bean May 29, 2015

    AAB4K , May 29, 2015 :
    Also if any app is crashing then force stop it and update from play store...