Found a fix for Google Play services crashing constantly

  1. soosheefan Eclair Jan 8, 2016

    soosheefan, Jan 8, 2016 :
    This worked well for me! Today is a first day without annoying message from Google Play services. Thanks a lot!

  2. Manas Gupta Froyo Jan 10, 2016

  3. prezes5 Ice Cream Sandwich Jan 10, 2016

    prezes5, Jan 10, 2016 :
    trying now...

    either way if works or not I will keep denying Google from waking up the device because it kills the battery

  4. sagittarioinverso Donut Feb 2, 2016

    sagittarioinverso, Feb 2, 2016 :
    Case 1: Google Play services Wake up and Keep awake ON. My battery doesn't last for a day.
    Case 2: Google Play services Wake up and Keep awake OFF. I can't use GPS.

    Is it possible to fix it?

  5. Davidred7697 Eclair Feb 26, 2016

    Davidred7697, Feb 26, 2016 :
    I tried the suggestion in the OP as well as the one repeatedly suggested of clearing app preferences (and having to read enable privacy for every single app manually again) to no avail. They did not work to solve the problem.

    It was fine for a while, until I toggled GPS/location settings. Then it went back to crashing Google Play services about once every 2 or 3 seconds (not a typo!).

  6. Wito Hoeben Cupcake Feb 26, 2016

  7. pitusr Cupcake Mar 17, 2016

    pitusr, Mar 17, 2016 :
    Clrearing cache done nothing, enabling GPS cause google play to crash continues..

  8. prince2k85 Froyo May 14, 2016

    prince2k85, May 14, 2016 :
    How to reselect launcher???

  9. prince2k85 Froyo May 16, 2016

    prince2k85, May 16, 2016 :
    My Background data is on, but still I am facing the App Crash problem since yesterday. I am unable to understand suddenly what happened to it? Please help

  10. prince2k85 Froyo Jun 10, 2016

    prince2k85, Jun 10, 2016 :
    These setting will not work on OOS. Since they have rmoved Privacy Guard settings.

  11. muesing Cupcake Jul 1, 2016

  12. G_Glenn_Stumpff_dORh Cupcake Jul 18, 2016

    G_Glenn_Stumpff_dORh, Jul 18, 2016 :
    My Samsung Galaxy doesn't have a Privacy setting and there's no option under Applications to reset the preference settings.

  13. G_Glenn_Stumpff_dORh Cupcake Jul 18, 2016

    G_Glenn_Stumpff_dORh, Jul 18, 2016 :
    As I said before in a reply that apparently got lost, I don't have any of the above mentioned settings options. I forgot to mention that my tablet wasn't having the issue until after the latest automatic update of Google Play Services.

  14. whiteoni Cupcake Oct 7, 2016

    whiteoni, Oct 7, 2016 :
    I can't find any Privacy option in settings page. Why? Where I can find that? That means that I haven't any type of privacy on my account? :-(

  15. vy.tenis Cupcake Oct 12, 2016

    vy.tenis, Oct 12, 2016 :
    I have found this solution in internet:

    "Your Play Services can stop working due to several other reasons.

    First - Install the latest Google Play Services .apk file!

    Second - If installing that doesn't fix, clear the Google Play Services cache. The Google Play Services app in your phone acts like a framework for all the Google and Google Play apps installed in your phone. You can try cleaning up its cache and see if that would fix the issue. This worked with one of our team members! Read these quick and easy steps :
    1. Go to Settings > Apps.
    2. Scroll to All apps and then scroll down to "Google Play Services" app.
    3. Open the app details and tap on the "Force stop" button.
    4. Then, tap on the "Clear cache" button."

      Written by harisn

      It worked for me.