12
front camera not working after update

  1. Saravanan.M.S
    Eclair Oct 28, 2020


    #61
  2. Naayt
    Cupcake Oct 28, 2020

    Naayt , Oct 28, 2020 :
    Not sure about that. For me it was an hardware issue. If you look at the picture in my previous message, you can see where was the problem.I changed the camera and then it works perfectly.
     

    #62
  3. JaimeM2
    Eclair Oct 28, 2020

    JaimeM2 , Oct 28, 2020 :
    It was working Ok from one week. Selfie, facial unlocked, back camera... all.
    Suddenly, the front camera started to fail... first, just open a half... then when press selfie button, cam app close. Back cam works Ok, App cam works ok in that moment.
    Reboot.
    Back cam dosent works. Black screen. Flash fails. Youtube fails (always loading).
     

    #63
    rotanak likes this.
  4. Naayt
    Cupcake Oct 28, 2020

    Naayt , Oct 28, 2020 :
    I had the same issue, like everybody on this thread. I don't think that the last update of oxygenOS caused that. It doesn't work because the front camera doesn't last in time.
     

    #64
  5. Saravanan.M.S
    Eclair Oct 29, 2020

    Saravanan.M.S , via OnePlus 7 Pro , Oct 29, 2020 :
    For these many how can the camera get damaged at the same time???
     

    #65
  6. Saravanan.M.S
    Eclair Oct 29, 2020

    Saravanan.M.S , via OnePlus 7 Pro , Oct 29, 2020 :
    Exactly my issue, for me after YouTube, message all also didn't work and the Amazon app also didn't work. It will either hang or be loading for long time.

    This is definitely not a hardware issue as most of the 7pro users facing same issue which is getting rectified after changing front camera for few which definitely conveys this is some serious bug.

    One plus has to come out and give a solution and not ask all users to change front camera at users cost
     

    #66
    JaimeM2 likes this.
  7. Naayt
    Cupcake Oct 29, 2020

    Naayt , Oct 29, 2020 :
    I don't know. I tried everything (except the factory reset) and the camera wouldn't work. But I had the same issue that had everyone here and changing the camera solved that issue. It cost me only 1 hour and 20€.
     

    #67
  8. Saravanan.M.S
    Eclair Oct 29, 2020

    Saravanan.M.S , via OnePlus 7 Pro , Oct 29, 2020 :
    Yes same here in India too 1200₹ which 15€ but that doesn't matter. For an issue of manufacturer why should a customer pay????
     
    Last edited: Oct 29, 2020

    #68
  9. Naayt
    Cupcake Oct 29, 2020

    Naayt , Oct 29, 2020 :
    Did you tried to downgrade the version of Oxygen OS ? (I don't know if it's possible without rooting or unlocking thé bootloader)
     

    #69
  10. Saravanan.M.S
    Eclair Oct 29, 2020

    Saravanan.M.S , via OnePlus 7 Pro , Oct 29, 2020 :
    After downgrading at the exclusive service centre only my other apps YouTube,rear camera, messages and Amazon apps started working
     

    #70
  11. Naayt
    Cupcake Oct 29, 2020

    Naayt , Oct 29, 2020 :
    Ok so it's a software issue for apps and a hardware issue for front camera in the most cases I think.
     

    #71
  12. Q1560774580446
    Cupcake Oct 30, 2020

    Q1560774580446 , via OnePlus 7 Pro , Oct 30, 2020 :
    Im having the same problem either. Just notice it when i cant use face unlock anymore. The camera still poped up but when i open the front camera the screen turn black. Back camera work fine
     

    #72
    Saravanan.M.S likes this.
  13. rotanak
    Donut Oct 30, 2020

    rotanak , Oct 30, 2020 :
    Actually I was able to roll back to Pie and everything seems to be working fine now other than the front camera. so it is definitely the software problem
     

    #73
    JaimeM2 and Saravanan.M.S like this.
  14. R1564141750015
    Cupcake Nov 2, 2020

    R1564141750015 , Nov 2, 2020 :
    Hello, it's same for me. First there was problem with front camera then with rear camera and then the apps message, YouTube, Amazon. I had mailed to OnePlus before nothing is helping out they just asked me to go to their store. It's still there, I thought they would take this seriously but there is nothing from their end. Atleast their should be acknowledgement saying it's a bug or they are testing out or there is nothing like this etc but nothing it's worst. Man I don't understand how this happens for all at once. We need to make them respond for this, they should test out this things and atleast respond.
     
    Last edited: Nov 2, 2020

    #74
    JaimeM2 likes this.
  15. rotanak
    Donut Nov 2, 2020

    rotanak , Nov 2, 2020 :


    In case anyone who is in dire need to use the back camera and don't want to wait until 1+ acknowledge the problems and finding solution, I was able get almost everything back to normal other than the pop-up camera by roll back to Pie.

    I followed instructions of the guy in the video and it is working.
    Just careful to backup so you don't lose any important data
     

    #75
    Q1560774580446 likes this.
  16. Q1560774580446
    Cupcake Nov 4, 2020


    #76
  17. shubhamagarwal3010
    Cupcake Nov 8, 2020

    shubhamagarwal3010 , Nov 8, 2020 :
    I am facing the same issue on OnePlus 7 Pro. My front camera stopped working after getting update 10.3.4 in August and now just after the latest update 10.3.6, my rear camera and flashlight also stopped working. Even after factory reset of phone, it is not working.

    I will never recommend anyone for buying OnePlus products anymore
     
    Last edited: Nov 9, 2020

    #77
    G_Motti_Va_LKUF and JaimeM2 like this.
  18. JaimeM2
    Eclair Nov 8, 2020

    JaimeM2 , via OnePlus 7 Pro , Nov 8, 2020 :
    I'm waiting for android 11. I'm done with OnePlus, sad after 1 month without using this mobile and no news or comments by the company.
    I have recommended lot of times, and now I feel a dissapoint sensation.
     

    #78
    shubhamagarwal3010 likes this.
  19. BaBaaLi
    Cupcake Nov 8, 2020


    #79
    JaimeM2 likes this.
  20. spot01
    Jelly Bean Nov 8, 2020

    spot01 , Nov 8, 2020 :
    If it was a simple software problem everyone would be getting same error and only a few people are when you consider the number of oneplus phones are in use.
    I'd guess its a software conflict between apps.

    You could use Permissions Manager to find apps that use the camera, disable all apps that you can in the list, reboot phone and try camera.
    If it now works re_enable each app one at a time testing camera after each one.
    It may be that camera will carry on working after all apps have been re_enabled as the disabling may have freed up locked camera link.
    Just something worth trying imho
     

    #80