12
front camera not working after update

  1. spot01
    Jelly Bean Nov 8, 2020

    spot01 , Nov 8, 2020 :
    If it was a simple software problem everyone would be getting same error and only a few people are when you consider the number of oneplus phones are in use.
    I'd guess its a software conflict between apps.

    You could use Permissions Manager to find apps that use the camera, disable all apps that you can in the list, reboot phone and try camera.
    If it now works re_enable each app one at a time testing camera after each one.
    It may be that camera will carry on working after all apps have been re_enabled as the disabling may have freed up locked camera link.
    Just something worth trying imho
     

    #81
  2. JaimeM2
    Eclair Nov 8, 2020

    JaimeM2 , Nov 8, 2020 :
    Factory reset, wipes, etc. Not fixed.
    No cams, no flash, no youtube.
     

    #82
  3. spot01
    Jelly Bean Nov 8, 2020

    spot01 , Nov 8, 2020 :
    I know but if it was pure software problem then everyone would have this problem there must be another factor
     

    #83
  4. JaimeM2
    Eclair Nov 8, 2020

    JaimeM2 , Nov 8, 2020 :
    Im not amd expert, but are all phones exactly the same? Components, versions of soft, kernel, Base band, etc, etc.

    ldk, but be sure the hardw was fine, and was a carefully treated phone. And when start to fail, first time, it was sleeping, and I tried to wake up with front cam. It was not in danger situation.
     

    #84
  5. Slokenz
    Cupcake Nov 10, 2020

    Slokenz , Nov 10, 2020 :
    Yeah I had the same issue and thought my entire system was just broken completely. Although the issue fixed it's self with the main camera working as well as the flash again. Although selfie camera is still unresponsive and camera app crashes so it's definitely a software issue.
     

    #85
    JaimeM2 likes this.
  6. JaimeM2
    Eclair Nov 10, 2020

    JaimeM2 , Nov 10, 2020 :
    In this point I would be settle with youtube working.

    OnePlus: "Never settle".
    Yeah, yeah... 😕[e]1f612[/e]
     

    #86
  7. Slokenz
    Cupcake Nov 10, 2020

    Slokenz , Nov 10, 2020 :
    Yeah although hopefully in update 10.3.6 fixed some issues.
     

    #87
  8. Vivekrvcse
    Donut Nov 10, 2020

    Vivekrvcse , Nov 10, 2020 :
    10.3.6 has not fixed this problem for me

    Only problem for me is that Front Camera is completely non functioning. there is no damage, definitely a software issue
     

    #88
    Slokenz likes this.
  9. Vivekrvcse
    Donut Nov 10, 2020


    #89
    Saravanan.M.S and R1564141750015 like this.
  10. Slokenz
    Cupcake Nov 10, 2020

    Slokenz , Nov 10, 2020 :
    yep if anything the issue still persist. I put my phone to charge and the rear camera began to work again as well as youtube and stuff like that. Updated it and now they don't work
     

    #90
  11. G1562619393545
    Cupcake Nov 10, 2020

    G1562619393545 , Nov 10, 2020 :
    Another use with the same issue. Have tried all the suggestions re clearing cache, soft reboot, factory reset but no joy 😡
     

    #91
    JaimeM2 likes this.
  12. paralit
    Cupcake Nov 11, 2020

    paralit , Nov 11, 2020 :
    Reporting in with the same problem as well. Front camera failed (still pops up but shows black screen, face unlock not working) since about 3 weeks ago, rear camera still working perfectly. Have tried disabling camera permissions but to no avail.
     

    #92
    JaimeM2 likes this.
  13. nopseudo00
    Cupcake Nov 11, 2020


    #93
    JaimeM2 likes this.
  14. nopseudo00
    Cupcake Nov 22, 2020


    #94
  15. CA_Srinidhi_S
    Cupcake Nov 23, 2020

    CA_Srinidhi_S , Nov 23, 2020 :
    Wow, Same issue here !
    1st the Front cam goes Kaput
    Then the back camera
    then YouTube
    now the flashlight isn't working since 3 days !!!
    Definitely a software bug .

    Restarted in safe mode , did a factory reset too.
    but to no avail !!!

    Hope we get an update soon.
     

    #95
    JaimeM2 and Ramit1616 like this.
  16. Q1541413542352
    Donut Nov 23, 2020

    Q1541413542352 , Nov 23, 2020 :
    I had done everything but nothing worked and i sent my device to one plus repair centre in poland, and they said i will have to replace the motherboard which will cost me nearly £350.00, what a solution?? if they can't find the fault they would ask to change the whole motherboard, better to buy a new phone then,

    i went back to Oxygen 9 and eveything else started working , flashlight, back camera, messaggin app, youtube.

    but front camera still dont work

    definately a software issue as many people are facing the same issue, only downgrading is a solution until oneplus find a proper solution for this issue.

    so many people are facing this issue but oneplus never bothered to look into it , i am facing this issue for last 5 months and i am tried of it.
    this was my lastr oneplus , better to buy highend samsung or iphone . No More oneplus.
     

    #96

  17. #97
    CA_Srinidhi_S likes this.
  18. Saravanan.M.S
    Eclair Nov 23, 2020

    Saravanan.M.S , via OnePlus 7 Pro , Nov 23, 2020 :
    +1
     

    #98
  19. JaimeM2
    Eclair Nov 23, 2020

    JaimeM2 , Nov 23, 2020 :
    How to downgrade to V.9? U need to be root?

    Thx.
     

    #99
  20. Ramit1616 , via OnePlus 7 Pro Nebula Blue , Nov 25, 2020 :
    Almost did everything like cleaning cache, reboot in safe mode and many other things as guided by OnePlus but still nothing happened and today my back camera also stopped working.