3
Front Camera Stopped Working in OP7 Pro Effective 13th October 2020 via OnePlus 7 Pro

  1. ypatadia
    Eclair Oct 13, 2020

    ypatadia , via OnePlus 7 Pro , Oct 13, 2020 :
    I m using OP7 Pro, and today I started facing issue in my front camera. First it was showing Black / blurred image (not visible) and then camera app started Crashing.
    Upon research I tried clearing Cache and Storage in Camera app and restarted my device, but issue didn't resolved.
    I called OnePlus team , and was advised to clear Cache from one plus launcher app and set permission for every app as advised by OP Customer Care technical staff but it didn't helped.
    Then I was advised to perform Wipe Data by rebooting the device using Power + Volume Up button. Post performing this activity I restarted my device, but still no solution.

    Can someone please assist

    Regards - Yatin
     

    #1
  2. Tokolozi
    Most Original Avatar Oct 13, 2020

    Tokolozi , Oct 13, 2020 :
    sounds like a hardware issue at this point. Best to contact support again or visit a service center if you have one nearby.
     

    #2
  3. Diogo Lucas de Oliveira , via OnePlus 7 Pro , Oct 18, 2020 :
    Estou enfrentando o mesmo problema. Há uma semana a câmera frontal abria mas não exibia imagem, após alguns segundos fechava. Mas as câmeras traseiras funcionavam normalmente. Hoje, a mensagem de erro pediu para que eu reiniciasse o aparelho. Após reiniciar, nenhuma das câmeras funcionou. A frontal sequer abre e a traseira não funciona. O app da câmera exibe uma tela preta. Fiz um downgrade para o Android 9 e as câmeras traseiras funcionaram, a frontal sequer abriu. Voltei para o Android 10, flash limpo, e as câmeras continuam não funcionando.
     

    #3
  4. ypatadia
    Eclair Oct 18, 2020

    ypatadia , via OnePlus 7 Pro , Oct 18, 2020 :
    English Please
     

    #4
  5. Diogo Lucas de Oliveira , via OnePlus 7 Pro , Oct 18, 2020 :
    I am facing the same problem. A week ago the front camera opened but did not display an image, after a few seconds it closed. But the rear cameras worked normally. Today, the error message asked me to restart the device. After restarting, none of the cameras worked. The front does not even open and the rear does not work. The camera app displays a black screen. I downgraded to Android 9 and the rear cameras worked, the front one didn't even open. I went back to Android 10, clean flash, and the cameras still don't work.
     

    #5
  6. YAJIV4VIJAY
    Gingerbread Oct 18, 2020


    #6
  7. Diogo Lucas de Oliveira , via OnePlus 7 Pro , Oct 18, 2020 :
    I hadn't used the front camera for a few days and I only realized the error when I went to a meeting through Google Meet, the popup camera opened, black screen and after a few seconds it closed. I tried again, and the same error. It was noted that there are more similar reports spread throughout the forum. first the frontal and now none of them. all apps that depend on booting the camera module also crash. Google Translate, the Messaging app, etc.
     

    #7
    YAJIV4VIJAY likes this.
  8. YAJIV4VIJAY
    Gingerbread Oct 18, 2020

    YAJIV4VIJAY , via OnePlus 7 Pro , Oct 18, 2020 :
    Is there any physical damage sort of thing, happened to your phone before that error?


    Try to hard reset everything!
     

    #8
  9. Diogo Lucas de Oliveira , via OnePlus 7 Pro , Oct 18, 2020 :
    No, without previous damage to the device. But what intrigues me is the fact that the rear cameras were working normally and after restarting they also stopped. I did cache wipes, data wipes, factory reset and the problem persisted. I flashed a fastboot ROM, Android 9 and the rear cameras worked, the front one didn't. When upgrading to Android 10, any version, everything stopped again.
     

    #9
  10. ypatadia
    Eclair Oct 18, 2020

    ypatadia , via OnePlus 7 Pro , Oct 18, 2020 :
    No Physical Damage in my OP7 Pro also. Reached out Customer care team again and I was advised to go to service centre for further resolution
     

    #10
  11. YAJIV4VIJAY
    Gingerbread Oct 18, 2020

    YAJIV4VIJAY , via OnePlus 7 Pro , Oct 18, 2020 :
    Once check the cameras with engineering mode. If it's still there and IF I WERE IN YOUR PLACE,
    STEP 1: Again reset everything, if possible I'll unlock and relock the bootloader and flash only the official ROMS

    If this fails too...

    STEP 2: I'll give it for a repair in the official service centre

    All the best guys! May your op7pro get back to normal.
     

    #11
  12. alessandro.pesce
    Cupcake Nov 3, 2020


    #12
  13. YAJIV4VIJAY
    Gingerbread Nov 3, 2020

    Last edited: Nov 3, 2020

    #13
  14. Z1604433883973
    Cupcake Nov 3, 2020

    Z1604433883973 , Nov 3, 2020 :

    Identical issues and steps to resolve the issues. OP tech support says they are aware of this issue. I imagine they'll release an update to resolve this ASAP, but in meantime, we're going to have to deal with the issue at hand. Going backward in OS won't resolve issue. That update appears to have affected hardware and/or kernel of operation which no OS will resolve, but an update that can resolve the issue we're experiencing.

    Attached is image of conversation with OP. They have had me go through various steps to get them the data/logs they need to locate the issue.
     

    Attached Files:

    Last edited: Nov 3, 2020

    #14
    ypatadia likes this.
  15. ypatadia
    Eclair Nov 4, 2020

    ypatadia , via OnePlus 7 Pro , Nov 4, 2020 :
    Thanks for your suggestion. I visited OnePlus Service Center, they did formatting, but it didn't helped. I was asked to keep my OP7 Pro for a week's time to have my front camera replaced, but since I don't have a spare phone I didn't kept it in service center, as this is the primary device I am using for internet in Work From Home Environment
     

    #15
    YAJIV4VIJAY likes this.
  16. ypatadia
    Eclair Nov 4, 2020

    ypatadia , via OnePlus 7 Pro , Nov 4, 2020 :
    I visited OnePlus Service Center, they did formatting, but it didn't helped. I was asked to keep my OP7 Pro for a week's time to have my front camera replaced, but since I don't have a spare phone I didn't kept it in service center, as this is the primary device I am using for internet in Work From Home Environment
     

    #16
  17. ypatadia
    Eclair Nov 4, 2020

    ypatadia , via OnePlus 7 Pro , Nov 4, 2020 :
    Thanks for your information. I visited OnePlus Service Center, they did formatting, but it didn't helped. I was asked to keep my OP7 Pro for a week's time to have my front camera replaced, but since I don't have a spare phone I didn't kept it in service center, as this is the primary device I am using for internet in Work From Home Environment
     

    #17
  18. YAJIV4VIJAY
    Gingerbread Nov 4, 2020

    YAJIV4VIJAY , via OnePlus 7 Pro , Nov 4, 2020 :
    Then what are you going to do? Are they charging any cost for this repair?
     

    #18
    ypatadia likes this.
  19. YAJIV4VIJAY
    Gingerbread Nov 4, 2020

    YAJIV4VIJAY , via OnePlus 7 Pro , Nov 4, 2020 :
    Now OnePlus has released a hotfix update for the stable version 7series 10.3.6/10.0.14/10.0.9. Try to install and see whether this problem still exists or not!
     

    #19
  20. ypatadia
    Eclair Nov 5, 2020


    #20