281
Guide

[Full Guide] Setting drivers up, unlocking bootloader, flashing recovery, roms, kernels & rooting

  1. steeh Eclair Oct 11, 2015

    steeh, Oct 11, 2015 :
    I was refered to this thread from the german region forum. I only can recommend this Guide for rooting the Oneplus One. Just want to say "Thank you!" :)
     

  2. lokesh3440 Ice Cream Sandwich Oct 12, 2015

    lokesh3440, Oct 12, 2015 :
    After flashing recovery with this command :
    fastboot flash recovery twrp-x.x.x.img(name may change depending upon your file)
    try following command :
    fastboot boot twrp-x.x.x.img(name may change depending upon your file)
    Please leave a feedback once done.
     

  3. Mark Christopher Eclair Oct 15, 2015

    Mark Christopher, Oct 15, 2015 :
    I had some issues with the MacOSX Toolkit myself, but it did a few tricks that helped me along.
    1. The toolkit was not successful in unlocking the bootloader.
    2. Installation of TWRP 2.8.6.0 was not successful even though the toolkit reported that it was.
    3. I could not root because of the first two issues.
    I used the toolkit (Option #7) to install the Fastboot and ADB drivers for the Mac because the versions I downloaded from the Android Developer site were not compatible with my OS version (Snow Leopard).

    Then I just used terminal command prompt to run the fastboot and ADB commands manually. Not the toolkit running inside terminal.

    This guide details what commands to type into terminal. See section 2. This did successfully unlock my bootloader. But I had other issues so I decided to go back to stock and start over.

    If all you want to do is go back to stock, use the MacOSX Toolkit's option 4 to do it, but do not choose a ROM you downloaded. Instead, Choose the option that allows the toolkit to download the stock ROM for the OPO.

    I did this and it worked without error or issue.

    After that, you can go back into terminal and run the aforementioned Fastboot and ADB commands (see section 3 of the guide) to flash TWRP and/or whatever else you want to do.

    Good luck.
     

  4. Sinful_Saint Ice Cream Sandwich Oct 15, 2015

    Sinful_Saint, Oct 15, 2015 :
    @DaxNagtegaal Sorry noob question - couldnt find it here..Does the kernel depend on the OS version only or the ROM also?
    i want to try color OS and heard its battery life aint that good so wanted to try a custom kernel.
    thanks
     

  5. sdkumar00 Cupcake Oct 18, 2015

    sdkumar00, Oct 18, 2015 :
    My oneplus one is stuck on cyanogen boot screen after doing factory reset also.
    From the logs its showing CM 12.1 25th Aug release. I do not have USB debugging enabled, so no adb.
    I tried doing fastboot boot twrp-2.8.7.0 and can see twrp. Can I use this to flash a new ROM(without having ADB)??
     

  6. sdkumar00 Cupcake Oct 18, 2015

    sdkumar00, Oct 18, 2015 :
    Continuing from above, I am unable to create a backup on twrp(recovery logs attached).

    "Updating partition details...
    I:Data backup size is 0MB, free: 56060MB.
    I:Unable to mount '/usb_otg'
    I:Actual block device: '', current file system: 'vfat'
    ...done
    I:Unmounting main partitions..."
     

    Attached Files:


  7. squadzero Ice Cream Sandwich Oct 18, 2015

    squadzero, Oct 18, 2015 :
    If you phone is empty, there is nothing to backup, so...
     

  8. AndroidKraken Froyo Oct 23, 2015

    AndroidKraken, Oct 23, 2015 :
    Stupid question:

    Booting into TWRP is just holding the power and volume down button at the same time right?
     

  9. theshinybeast Lollipop Oct 23, 2015

    theshinybeast, Oct 23, 2015 :
    Yes you got it
     

  10. swarnavasengupta Froyo Nov 1, 2015

    swarnavasengupta, Nov 1, 2015 :
    try to open supersu app and install backupscript maybe your supersu isnt ready yet
     

  11. Filip b Cupcake Nov 3, 2015

    Filip b, Nov 3, 2015 :
    I could use some help , It always says failed after trying to instal/flash the image with cm11s in TWRP..pleaseeee help :D
     

  12. ryzliqmn Cupcake Nov 10, 2015

    ryzliqmn, Nov 10, 2015 :
    Downloaded the TWRP image, latest version. A prompt came out asking me to burn the image, as soon as click 'Burn', the status will say 'The selected disc image file isn't valid'. PLEASE HELP!
     

  13. jbclowend Donut Nov 10, 2015

    jbclowend, Nov 10, 2015 :
    I hardly ever post in the forum, but this post was absolutely amazing. I've always wanted to know how to install a different os (aside from some toolkit), install a different recovery, root, and use Titanium. Thank you so much for writing/collecting all of this!
     

    ayk1982 likes this.
  14. 9820912721 Cupcake Nov 11, 2015


  15. ipankil Froyo Nov 13, 2015

    ipankil, Nov 13, 2015 :
    HELP! My device was rooted but when I did a reset from the device setting options the root access was gone. So get the root access back I am manually trying to flash it but the device is not showing the fastboot screen. Can someone help me out?
     

  16. brentsalamorin Eclair Nov 14, 2015

    brentsalamorin, Nov 14, 2015 :
    Hi need a little help. I finished running the adb installer but unfortunately no adb folder showed up in my drive C. I noticed it said 0 file(s) copied when I ran it. What should I do? tried to run it multiple times but still no adb folder
     

  17. sagardrokr Cupcake Nov 18, 2015

    sagardrokr, Nov 18, 2015 :
    I flashed H2OS. But there was no network. So restored my nandroid backup. But still there is no network.
    So I dirty flashed my previous rom(the same one in the nandroid backup),still no luck.
    Then I tried flashing the EFS fix from OP and I'm still stuck with no network.
    Then I flashed latest COS12.1 official build but still there's no network.

    Now I don't have my EFS backed up. What things can I do? Am I going to get my network back?
     

  18. jstepa KitKat Nov 18, 2015

    jstepa, Nov 18, 2015 :
    Flash TWRP 2.8.6.0 within TWPR, reboot to recovery again and see that the version has changed:
    http://dl.twrp.me/bacon/

    Then flash OnePlus official Firmware:
    https://www.androidfilehost.com/?fid=23991606952604019

    Then dirty flash your current ROM
     

    sagardrokr likes this.
  19. sagardrokr Cupcake Nov 18, 2015


    jstepa likes this.
  20. J_T Cupcake Nov 19, 2015

    J_T, Nov 19, 2015 :
    After spending half a day on YouTube watching outdated tutorials on rooting my OnePlus One and achieving only partial success, I found this thread and my salvation! I thought YouTubers knew everything (heh!) but I realize I should've came here first...duh! Thanks Dax!