282
Guide [Full Guide] Setting drivers up, unlocking bootloader, flashing recovery, roms, kernels & rooting

  1. ofer5813
    Cupcake Mar 12, 2016

    ofer5813 , Mar 12, 2016 :
    guys please help me I wanted to root and install custom rom through this guide and installed the 15 seconds adb installer but from some reason i didnt managed to find adb interface recognizing my device... it only show up on portable device a0001 what do i need to do to fix this?
     

  2. mriea159111
    Cupcake Mar 22, 2016


  3. liguin
    Donut Apr 4, 2016


  4. Pr3castDragon
    Cupcake May 17, 2016

    Pr3castDragon , May 17, 2016 :
    Should I be worried about my EFS data before I unlock bootloader / flash TWRP and SuperSU? Or am I good to do those things? (not currently rooted)
     

  5. theshinybeast
    Marshmallow May 17, 2016

    theshinybeast , May 17, 2016 :
    EFS backup is the 4th pointo_O You´re good to go but backup your EFS when you reach that point.
     

    Gonzo01 likes this.
  6. Gonzo01
    Lollipop May 18, 2016

    Gonzo01 , May 18, 2016 :
    if you have working phone, do EFS backup and unlock boot loader first, then do whatever you want.
    save EFS files in more than one location: pc, flash drive, etc. there are ways to recover EFS, but super hard and not always effective.
     

  7. Pr3castDragon
    Cupcake May 18, 2016

    Pr3castDragon , May 18, 2016 :
    I'm having quite a difficult time with this step. I'm on OOS 2.1.4 and I flashed SuperSU. I flashed this script with TWRP and the folder was created (/sdcard/EFS_Backups) with the ZIP files in there. They did not show up under any app or through PC, only TWRP. So I say, fair enough and move them to the Download folder. They now show up, but no app, cloud storage, or even transferring through Explorer will work. They all come up with Unknown Error, and I have no idea what to do. I have tried the commands listed and they ran fine, but I can't find the files in the sdcard folder, not even through TWRP. Any help please? I really don't want to move on to flashing Sultan without these backed up.
     

  8. daniga74
    Jelly Bean May 19, 2016

    daniga74 , May 19, 2016 :
    Boot in recovery mode and connect opo via usb;
    On pc open a prompt and type "adb shell"
    Then type:
    dd if=/dev/block/mmcblk0p10 of=/sdcard/modemst1.bin bs=512
    dd if=/dev/block/mmcblk0p11 of=/sdcard/modemst2.bin bs=512
    sync && reboot
    In /sdcard you'll find the two files
     

  9. Soccerbob7
    Froyo Jun 4, 2016

    Soccerbob7 , Jun 4, 2016 :
    Hey guys I think I ****** up. my signal is permamnently dead reguardless of what modem I flashed. I have an EFS backup (2 .img files) but i can't seem to get it to restore to them
     

  10. Soccerbob7
    Froyo Jun 4, 2016

    Soccerbob7 , Jun 4, 2016 :
    So its not an IMEI issue.. I checked my IMEI tothe one on the box that the phone came in
     

  11. rhn345
    Gingerbread Jul 10, 2016

    rhn345 , Jul 10, 2016 :
    1. Recovering from no OS installed and no ROM or Backup present on the phone.

    i have this issue.
    can someone help? i dont have access to OTG.. Fastboot is on. can go to recovery, restoring the back up aint working as stuck at OP logo.
    please help.

    thanks in advance.
     

  12. daniga74
    Jelly Bean Jul 14, 2016

    daniga74 , Jul 14, 2016 :
    If you can access in fastboot mode follow the guide "clean_installation" in my signature
     

    TForesto likes this.
  13. mootme1
    Cupcake Jul 16, 2016


  14. GusN
    Cupcake Jul 24, 2016

    GusN , Jul 24, 2016 :
    I rooted and now my phone is stuck at the Cyanogen Mod Ready screen. Anyone know what to do?
     

  15. Ch17r4nshu
    Cupcake Aug 15, 2016

    Ch17r4nshu , Aug 15, 2016 :
    I flash COS13.1-ZNH2KAS254 and also installed custom recovery TWRP-3.0.2.0 and SuperSu v2.67 after that whenever i try to encrypt my phone its stuck at Cyanogen MOD ready screen and nothing happens after 2-3 hrs.
    Any suggestion or help please!!
     

  16. righN
    Cupcake Aug 19, 2016

    righN , Aug 19, 2016 :
    Hi, I can't create a thread because I'm here new so I wanted to ask for help here. My mom bought a OnePlus One a week ago, it had problem with SIM Card reading so we took it to the repair and they fixed it, specalist showed that everything is working with his EE SIM Card. Then mom tried her giffgaff/three networks cards, they both gave same error ''No Service'' we went to the repair again and they tried to do factory reset - no luck. Inserted EE card again - it starts working after few seconds. So we bought EE card, and it worked for us too. But my mom wanted to use SIM card from Three network so we went go home inserted the card and waited about 30 minutes and it started working but not for long. We went shopping and phone just showed No Service, until now it's same. Sometimes it gets signal, but my mom wanted to get signal everytime so I tried to flash CM13 nightlies and no luck. Can you help me? IMEI and baseband are good.
     

  17. Disturber
    Honeycomb Aug 19, 2016

    Disturber , Aug 19, 2016 :
    Guys i have a very simple question.
    Back ago, I installed OxygenOS because it was being promoted via Oneplus FB, instructions were very simple and i was done in matter of minutes. Now, I've been all too tired of the bugs and issues for quite some time now, and want to switch back to official CM whichever it is, having it all stock back again.

    Is there a simply way to go back to CM as when I had switched to Oxygen?
     

  18. righN
    Cupcake Aug 20, 2016

    righN , Aug 20, 2016 :
    I used this tutorial a few times and I didin't had any problems.

    http://forum.xda-developers.com/oneplus-one/general/guide-return-opo-to-100-stock-t2826541
     

  19. crisis-trustee
    Gingerbread Aug 28, 2016


  20. daniga74
    Jelly Bean Sep 1, 2016

    daniga74 , Sep 1, 2016 :
    you have to flash the old firmware (c6-241) and then twrp via fastboot