281
Guide

[Full Guide] Setting drivers up, unlocking bootloader, flashing recovery, roms, kernels & rooting

  1. bjayaram Eclair Sep 20, 2016

    bjayaram, Sep 20, 2016 :
    Hi guys,
    I read through the first page and I wanted to back up some stuff.. an then i read this first sentence "Boot your phone into TWRP " which left me blank.. how do i do it?
     

  2. bjayaram Eclair Sep 20, 2016

    bjayaram, Sep 20, 2016 :
    This is the other statement.. "type fastboot devices to verify that you have a working connection with your phone and then type fastboot oem unlock to unlock your bootloader
    This will delete all the data off your phone and perform a complete factory reset." im scared now... should i do it or not?
     

  3. striker280 Gingerbread Sep 25, 2016

    striker280, Sep 25, 2016 :
    I was running twrp 2.8.6.0 and it flashed everything fine (roms, modems/firmwares). I recently just flashed the ported oxygenos 3.1.1 and for some reason, my old twrp was overwritten by a newer one 3.0.2.0 (not sure why, any ideas?) Anyways, does this newer version 3.0.2 flash modems well and work just as well as the old 2.8.6? Thanks!
     

  4. KforHorizon Jelly Bean Sep 25, 2016

    KforHorizon, Sep 25, 2016 :
    Yes
     

    striker280 likes this.
  5. striker280 Gingerbread Sep 25, 2016


  6. KforHorizon Jelly Bean Sep 25, 2016


    striker280 likes this.
  7. striker280 Gingerbread Sep 25, 2016

    striker280, Sep 25, 2016 :
    I just tried to restore my darkobas backup coming from ported oxygen 3.1.1, but for some reason it said failed, mounted as read only? Any ideas? Thanks!
     

  8. KforHorizon Jelly Bean Sep 25, 2016

    KforHorizon, Sep 25, 2016 :
    Try going into TWRP and then advanced!
    Uncheck read only option if there is any and check system data storage (whatever there is except usb otg) and try again!
     

    striker280 likes this.
  9. striker280 Gingerbread Sep 25, 2016

    striker280, Sep 25, 2016 :
    Thank you. Just restored the darkobas backup, but now it's stuck at the 1+ logo. Is it because of the different firmware? Should i just try reflashing darkobas with the firmware instead?
     

    KforHorizon likes this.
  10. striker280 Gingerbread Sep 25, 2016

    striker280, Sep 25, 2016 :
    Please help! i tried to reflash darkobas from oxygenos, but it doesn't work properly. It says "updater process ended with error: 7, failed to installed zip" I'm not too sure how to fix this, not even sure if it will restore my oxygenos backup properly either?
     

  11. KforHorizon Jelly Bean Sep 26, 2016

    KforHorizon, Sep 26, 2016 :
    Try a clean flash instead! If it still doesn't work! Try manually flashing the TWRP again! And then try and clean flash!
     

  12. kartike4u Ice Cream Sandwich Oct 1, 2016

    kartike4u, Oct 1, 2016 :
    Could anyone suggest me a working toolkit for all this???
    Current is cos13.1.2
     

  13. F_Rafael_Morais_fNVQ Cupcake Nov 23, 2016

    F_Rafael_Morais_fNVQ, Nov 23, 2016 :
    Hello.

    I have a Oneplus One.

    And i think i have a hard brick, i write details:

    When i turn on my smartphone it stay on cyanogen logo forever.
    I cant access recovery mode and i cant access fastboot mode(it goes to cyanogen logo forever).

    But it find ADB interface on device manager

    What i want to know is: Is it a hard or soft brick??

    Can u help me???

    Thanks

    EDIT: ADB interface only appears when my device is on cyanogen logo.

    here is a screen shot!

    [​IMG]
     

  14. jakegf Froyo Dec 1, 2016

    jakegf, Dec 1, 2016 :
    Hi, I am little bit desperate.
    My problem is with the microphone. The people calling me hear me very low. I read that I need to enter some parameters on the phone to fix this. In order to do this, I need first to ROOT my phone.
    I have android 6.01 and Cyaonogen OS 13.1.2.
    I unlocked the bootloader, installed TWRP recovery and my issue is in the last step, flashing SuperSU: When I reboot my oneplus one in recovery mode I do not get any option to install SuperSU. Can you please help me?
    Thanks
     

  15. daniga74 Jelly Bean Dec 2, 2016

    daniga74, Dec 2, 2016 :
    Download this and flash via recovery:
    http://redirect.viglink.com/?format...t=http://download.chainfire.eu/supersu-stable

    Take a backup before.
     

  16. F_Dominick_Holmes_ZPPN Cupcake Dec 18, 2016


  17. Matt Dixon Cupcake Dec 21, 2016

    Matt Dixon, Dec 21, 2016 :
    to fully control the world (I mean your android phone)
     

  18. Anonymous_unknown Froyo Jan 2, 2017

    Anonymous_unknown, Jan 2, 2017 :
    Unable to boot into recovery getting error message - `dtb not found` after installing oxygen OS, i tried reinstalling and booting through fastboot -still error existing
    any help would be appretiated
     

  19. daniga74 Jelly Bean Jan 3, 2017

    daniga74, Jan 3, 2017 :
    try to flash via fastboot this:

    https://www.androidfilehost.com/?fid=24591000424946739

    follow the guide in my signature "clean_intallation"
     

    anjath likes this.
  20. qminou Cupcake Jan 5, 2017

    qminou, Jan 5, 2017 :
    Dear all,

    I have a general question to ask about Root operation for OPO :

    I unfortunately deleted some pictures and movies from my phone. In fact, I deleted "Camera" folder by mistake... my bad.

    I have a pro version of disk digger app, it works very well but to recover my whole lost data, I need to use it in root mode.

    I readed many tutorials about How to root an OPO and I am little bit confused and worried because :

    I want to root my OPO without a full wipe and my OS is 13.1.2-ZNH2KAS3PO-bacon

    I am asking the community, Could you be kind and help me by linking a full process please ?

    In advance, thank you very much.