281
Guide

[Full Guide] Setting drivers up, unlocking bootloader, flashing recovery, roms, kernels & rooting

  1. qminou Cupcake Jan 6, 2017


  2. narglin Cupcake Jan 8, 2017

    narglin, Jan 8, 2017 :
    Hello, I hope someone here can help me.

    I've managed to soft-brick my OPO: there's no OS installed, and in the attempt of updating TWRP, I've managed to mess that up as well, so NO recovery.
    Fastboot mode seems to work, however Windows 7 does not recognise my phone in any way. I've tried installing adb drivers, but nothing seems to change. I've downloaded and installed QPST but I'm not quite sure what I'm supposed to do with it.

    I've also made some attempts via Ubuntu, however adb devices and fastboot devices show nothing at all.

    EDIT: all solved, the problem was the usb cable ¬_¬
     
    Last edited: Jan 9, 2017

  3. daniga74 Jelly Bean Jan 12, 2017

    daniga74, Jan 12, 2017 :
    you have to flash custom recovery (twrp 3.0.2) via fastboot and then flash supersu via twrp recovery.
    you don't loose data.
     

  4. anjath Cupcake Jan 19, 2017

    anjath, Jan 19, 2017 :
    Looks like you are on stock setup. In this case if you have a call volume issue, then it may not be a software issue at all. Try a factory reset. Get the hardware checked. Advice you don't go for unlocking bootloader and root until you fix the problem.
     

  5. anjath Cupcake Jan 19, 2017

    anjath, Jan 19, 2017 :
    Went through your detailed fastboot installation guide in signature. Thank you.

    After "adb reboot bootloader", assuming that the rest of the commands to be executed one after the other and in same sequence. Also, understand that this procedure can be done irrespective of the current software state of the device.
     

    daniga74 likes this.
  6. daniga74 Jelly Bean Jan 19, 2017

    daniga74, Jan 19, 2017 :
    You are right!!! Let me know.
     

    anjath likes this.
  7. Niko231 Cupcake Jan 19, 2017

  8. Lovo Gingerbread Jan 28, 2017

    Lovo, Jan 28, 2017 :
    HELP PELASE!

    I just unlock the bootloader with this Tutorial.
    After that it says ok with some timestamp.
    After that the OPO showed the green Android guy and some chinese word under him.

    What to do?

    If I type "fastboot reboot" it says waiting for device...


    HELP please!
     

  9. KarolN Honeycomb Feb 2, 2017

    KarolN, Feb 2, 2017 :
    Thanks for that brillant Tutorial. I am a complete loser in this and could Update to Lineage os Step By step - the Green, the good one. All went like written.
    Big thanks!
     

  10. impinas Honeycomb Feb 4, 2017

    impinas, Feb 4, 2017 :
    It just happened to me too. The green Android guy had under him: "erasing..."
    If I typed "fastboot reboot", it said "waiting for device"

    Then I long pressed the power buttob and my phone rebooted. Everything was like before. All my files and settings there. I shut it down again, put it in fastboot, and entered the "fastboot oem device-info" command. It says <bootloader> device unlocked: true

    I don't understand. Unlocking the bootlader means that everything is deleted...

    Anyone? :)
     
    Last edited: Feb 4, 2017

  11. Vinayak Pakhare Froyo Feb 8, 2017

    Vinayak Pakhare, Feb 8, 2017 :
    How did you flash nightly after experimental build?
     

  12. KarolN Honeycomb Feb 8, 2017

    KarolN, Feb 8, 2017 :
    I did not flash as after experimental reboot, ota with nightly was shown, so press download install and that's it.
     

  13. bhenne Cupcake Feb 9, 2017

    bhenne, Feb 9, 2017 :
    Hey guys! I'm trying to follow the guide but I cannot even get my device to show up in fastboot. I tried pretty much everything anyone on the internet ever suggested; a thorough list of what I did is here. Does someone know what I'm missing?
     

  14. Vinayak Pakhare Froyo Feb 12, 2017

    Vinayak Pakhare, Feb 12, 2017 :
    Hi
    I just finished flashing experimental build successfully. Then flashed pico version of GApps successfully. Now it shows three nightly updates available. However i am unable to download nightly build. It shows download progress till about 75% then says download failed. I am stuck on experimental build :(
     

  15. KarolN Honeycomb Feb 12, 2017

    KarolN, Feb 12, 2017 :
    That's not good but I don't know why or how to solve. Sorry
     

  16. wilsmits Jelly Bean Feb 19, 2017

    wilsmits, Feb 19, 2017 :
    Ppffff when I read the issue's you guys have with migration cos to lineage. It's scared me to even try it myself :(
     

  17. xxxlux Honeycomb Feb 22, 2017

    xxxlux, Feb 22, 2017 :
    Try with this TOOLBOX it has drivers and works with Win 7, 8 & 10.
     

  18. xxxlux Honeycomb Feb 22, 2017

    Last edited: Feb 22, 2017

  19. flxdg Cupcake Mar 17, 2017


    wilsmits likes this.
  20. wilsmits Jelly Bean Mar 17, 2017

    wilsmits, Mar 17, 2017 :
    That's true m8 :)