4
Ghost Issue in OnePlus One = Low Microphone

?

Low Microphone 1. OnePlus One Hardware 2.CyanogenMod Software or 3. "OK Google" detection API issue

  1. 1. OnePlus One Hardware

    18.6%
  2. 2. CyanogenMod Software

    72.1%
  3. 3. "OK Google" detection API issue

    9.3%
  1. Renyson Robert
    Donut Jun 19, 2016

    Renyson Robert , Jun 19, 2016 :
    Teams
    OnePlus case ID:- 295983

    Need your help to collaborate and resolved this haunting issue, This is effecting CM, Google, OPP Users, we are unable to use OnePlus One because of Low Microphone issue =
    https://jira.cyanogenmod.org/browse/BACON-289 see how many users are struggling with the same issue.

    Looks like a Orphan Oneplus_One between CM & OPO !

    Its absolutely amazing that the ticket is open since 25/Jul/2014, defeating the entire ability of being agile.
    CM Team please declare to OPO that this is a Hardware issue of 3 mic setup with noise cancellation it been haunting all of us and getting carry forwarded to all the version and the saga continues with XNPH22R, XNPH25R, XNPH30O, XNPH33R, XNPH38R, 11.0-XNPH44S,12.0-YNG1TAS17L, 12.0-YNG1TAS2I3, 12.1-YOG4PAS1N0, 12.1.1-YOG7DAS2K1 and the recent update of 13.1-ZNH2KAS1KN @Pat Erley & @PsychoI3oy, You guys do a awesome job, why leave this issue, ITS so bugging !!!

    Why 1.OnePlus , 2.CyanogenMod and 3.Google, needs to team up.

    We are ended up with following confusion:
    1. Is it Hardware 3mic noise cancellation setup issue = case ID:- 295983
    2. Is it Software 3mic noise cancellation setup issue = https://jira.cyanogenmod.org/browse/BACON-289
    3. Is "OK Google" detection software bug interfering, Part of Google Now implementation

    Thanks and Regards
    Reny
     
    Last edited: Jul 11, 2016

    #1
  2. kanagadeepan
    KitKat Jun 19, 2016

    kanagadeepan , Jun 19, 2016 :
    It is the CM sw issue, when using call recorder.. Since almost ALL ROMs are based on them, the issue persists in custom ROMs too.. Its NOT a hardware issue, as there is NO issue in 3G mode or BT calls or through Loud Speaker or after disabling noise-cancelling mics in 2G mode or when call recording disabled..
     

    #2
    Renyson Robert likes this.
  3. Renyson Robert
    Donut Jun 19, 2016

    Renyson Robert , Jun 19, 2016 :
    Question is where you able to get this resolved ?
     

    #3
    ameileesun likes this.
  4. ASHWANI19185
    Gingerbread Jun 19, 2016


    #4
    Renyson Robert likes this.
  5. Renyson Robert
    Donut Jun 20, 2016

    Renyson Robert , Jun 20, 2016 :
    I can understand, that is why have called it Ghost cause no one is able to eliminate the issue (OPO, CM, Google)
     

    #5
  6. env0ke
    Cupcake Jun 20, 2016

    env0ke , Jun 20, 2016 :
    >>
    ASHWANI19185, Yesterday at 7:14 PM :
    M thinking of buying a new phone just because of this. It's so irritating

    I thought about buying OnePlus 3, but now renounce this. I do not want to once again receive the problem with the mic.
     
    Last edited: Jun 20, 2016

    #6
    Renyson Robert and Mithrel like this.
  7. danash
    Cupcake Jun 21, 2016

    danash , Jun 21, 2016 :
    I had to buy a new phone about a year ago, but still keep the OPO in case this issue will resolve, it's an excellent hand computer, not a phone!
     

    #7
    Renyson Robert likes this.
  8. stonerl
    Cupcake Jun 21, 2016

    stonerl , Jun 21, 2016 :
    I stated this in the bugreport, imho disabling the fluence noise-cancellation would solve this for most of the users. From what I read so far and experienced myself, every time a custom rom enabled fluence many people started complaining about their microphones.
     

    #8
    Renyson Robert likes this.
  9. guilhermebar
    Cupcake Jun 21, 2016

    guilhermebar , Jun 21, 2016 :
    It is a truly bugging bug. I love OPO but why buy another another OPO phone or a phone with Cyanogen if you can't use it to call people properly?

    Guys we love you, you've accomplished great things in the past, can you please take care of this issue? It's bugging a lot of us!
     

    #9
    Renyson Robert likes this.
  10. delpinsky
    Ice Cream Sandwich Jun 21, 2016

    delpinsky , Jun 21, 2016 :
    I'm not sure honestly.
    I had some issues here and there but not a stable problem with the mic.
    Recently I made a long few hours call and I didn't receive any complaint from the recipient.

    Unfortunately there's people here who have serious issues using the very basic element of a phone:
    the speaker to call and receive calls.
     

    #10
    Renyson Robert likes this.
  11. vviikkrraamm
    Eclair Jun 21, 2016

    vviikkrraamm , Jun 21, 2016 :
    Thanks Renyson for creating separate thread for this problem , Its absolute failure for OPO & Cyanogenmod to resolve BACON-289 , almost 2 years still no resolution and its a blocker :)

    Certainly OPO is not paying any attention to this problem , its a major problem specially for the users who were 1st to believe in OPO and eager to win OPO invitation , like me many pple waited insanely , even purchased OPO from other countries as it wasn't even launched in their country.

    Every upgrade we have to update those crap system files root the device spend precious time just to make that main mic working ( even after tht result is not satisfactory) , its frustrating , like me many pple would have stopped recommending OPO , which was their plus point actually i.e. mouth to mouth publicity ,

    anyways , frustrated a lot while dealing with this basic functionality problem , OPO , Cyanogenmod are not capable to resolve this problem , that's for sure.
     

    #11
  12. kanagadeepan
    KitKat Jun 21, 2016

    kanagadeepan , Jun 21, 2016 :
    As I told earlier, it is FULL AND FULL CYANOGEN TEAM ISSUE.. Google has nothing to do with this. It happens ONLY in 2G mode, with call recorder ON.

    It does NOT happen in any one of following incidents, even with root based call recorder is ON:-
    [1] While voice call on 3G network.
    [2] While using Loud-speaker even in 2G mode.
    [3] While using BT or headset, even in 2G mode.

    One shitty solution is disabling noise-cancelling mics and ghost effect will be gone, but due to lack of noise cancellation, the call quality will be NOT good again. Other option is NOT using any call recorder sw. This is the reason I sold my OPO in few months for cheap.

    Custom ROM is NOT at all a solution, as every ROM is based on Cyanogen version of sw drivers. Blame the Cyanogen Team for NOT taking care of this very basic feature...
     

    #12
  13. guilhermebar
    Cupcake Jul 7, 2016

    guilhermebar , Jul 7, 2016 :
    Any news on this issue? Is it is a Cyanogen issue then they seek to be behaving in a childish and irresponsible way towards this because we've participated intensively on their bug tracking page and had no response. I'm beginning to think that we should get in touch with a reporter/influential blogger to shed some public light over this issue. Any suggestions guys?
     

    #13
  14. johnniee91
    Cupcake Jul 12, 2016


    #14
    Renyson Robert likes this.
  15. jomo59
    Donut Jul 18, 2016

    jomo59 , Jul 18, 2016 :
    Got the same problem. So with speaker on it works, or skyping. But when just calling they can hear me a little bit from really far away
     

    #15
    Renyson Robert likes this.
  16. Chumalaka
    Eclair Jul 20, 2016


    #16
    Renyson Robert likes this.
  17. yoyo_from_mars
    Cupcake Jul 24, 2016

    yoyo_from_mars , Jul 24, 2016 :
    I had the same problem on CM. I just switched to Oxygen OS 2.1.4 & I Have the same problem.
    Changing some parameters in /System/etc/mixer_paths.xml didn't solved the problem but I noticed some change on sound detection (I can shut the volume captured by a mic totally by changing parameters). It is definitely somewhere in this file that the solution should be !! But can't find how to solve the problem.

    Maybe if someone kin could explain the different parameters we could find which one to change. What is for exemple "RX1 Digital Volume" for ?
     

    #17
    Renyson Robert likes this.
  18. Renyson Robert
    Donut Aug 1, 2016

    Renyson Robert , Aug 1, 2016 :
    No the issue is not resolved have a new post OPO is orphaned
    https://forums.oneplus.net/threads/...-or-oneplus-oxygen-team.457903/#post-15125536
     

    #18
  19. Renyson Robert
    Donut Aug 1, 2016


    #19
  20. vCillusion
    Cupcake Sep 20, 2016

    vCillusion , Sep 20, 2016 :
    RX1 stands for Receiver 1 Digital Volume
    Check out the solution worked for me and I tried all the solution available and sharing below:
    https://vcillusion.wordpress.com/20...n-low-mic-during-call-problem-in-oneplus-one/
     

    #20