Gmail notification doesn't work

  1. tomekr
    Donut Mar 19, 2020

    tomekr , Mar 19, 2020 :
    I have OnePlus 5. After the latest OS update to 9.0.11 Gmail notifications stopped working. I cleared app cache and reinstalled but no luck. Does anyone has solution for this?


  2. Erikmarko
    Eclair Mar 31, 2020

    Erikmarko , Mar 31, 2020 :
    I have the same problem. I would like to ask android geniuses if they know how to fix it.

  3. Deactivated User
    Mar 31, 2020

  4. ruijmeira
    Gingerbread Apr 1, 2020

    ruijmeira , Apr 1, 2020 :
    I faced this issue so many times in so many builds of OOS that I can only assume that it is something related with deep clear being enabled on battery management. In my case, every single time the notifications would come back after some time. For example, curiously, I was not getting any notifications whatsoever from Gmail whilst my 5T was running 9.0.9. After I've updated to 9.0.11 (after skipping 9.0.10 on purpose), I finally started receiving Gmail notifications again. This issue, at least for me, is very erratic. I'm 100% positive that eventually I will again start not receiving Gmail notifications.

  5. Erikmarko
    Eclair Apr 1, 2020

    Erikmarko , Apr 1, 2020 :
    After latest update no notifications from Gmail (locked or unlocked). I tried reboot, clear cache, disable data saving for Gmail nothing helped.

    P1541993735830 likes this.
  6. Erikmarko
    Eclair Apr 1, 2020

    Erikmarko , Apr 1, 2020 :
    OK I found a fix. Uninstall latest Gmail update and just use Gmail without the update.

  7. Waveform Modifier
    Marshmallow Apr 1, 2020

    Waveform Modifier , Apr 1, 2020 :
    Basically it's the App's fault. Like always.

    Deactivated User likes this.
  8. joeblues
    Gingerbread Apr 11, 2020

    joeblues , Apr 11, 2020 :
    How can I do it? It's not secure. The mail is one of the most important apps in a smartphone. I see the unread messages only by clicking and viewing the app. It's a nonsense.

  9. joeblues
    Gingerbread Apr 11, 2020

    joeblues , Apr 11, 2020 :


    This means that the Gmail doesn't work at all in background.

    The app is using the version below


  10. joeblues
    Gingerbread Apr 11, 2020

    joeblues , Apr 11, 2020 :
    I downgrade to the version of November 2019. It's not s good thing but it's working so far...


  11. ruijmeira
    Gingerbread Apr 12, 2020

    ruijmeira , Apr 12, 2020 :
    in this case it's not. I may agree with you on the Google app not opening and thus "hey google" hotword also not working, being a problem with the app, but this isn't. I've experienced this from day one. I know it will eventually start giving me Gmail notifications again, as I'm also sure that it will do the exact opposite sometime in the future. It has to be something related with battery management settings. I have mine set to deep clear, and I understand that if I change it, it might solve it, but in the end it's not that much of a problem for me.

  12. ruijmeira
    Gingerbread Apr 12, 2020

    ruijmeira , Apr 12, 2020 :
    if you watch any reviews whatsoever about OnePlus phones on YouTube, you'll see that many YouTubers (some of them really big channel's) also complain about missing notifications on them.

  13. Fil ツ
    Cupcake Apr 24, 2020

  14. C1593690151290
    Cupcake Jul 2, 2020

    C1593690151290 , Jul 2, 2020 :
    Same here.. what I tried just now is to check/uncheck [ ] Sync Gmail. And for some reason, it's working again. Will see if this is really the solution.

    ssmhon likes this.
  15. ssmhon
    Cupcake Jul 3, 2020

  16. Sanjana_13
    Eclair Sep 10, 2020

  17. gopalsrini76
    Cupcake Sep 10, 2020

    gopalsrini76 , Sep 10, 2020 :
    Go to your Google email settings》select your specific email acct (in case you have more than one) select inbox notifications 》ensure that "notify for every new message" is selected.

    I Found this on Gmail Support. This works for me in Oneplus 7T. I also had the issue for past 2 or 3 months after an Update. But everytime I do an OS Update some messages will be shown, but later it would stop

    Abdallah Hakim HAMADA likes this.
  18. nilleftw
    Cupcake Sep 15, 2020

    nilleftw , Sep 15, 2020 :
    This seems to have worked for me. I'm sure I've already adjusted this setting, but maybe it goes back to default for some reason.

  19. B1600332834159
    Cupcake Sep 17, 2020

  20. Meldon DSouza
    Cupcake Nov 18, 2020

    Meldon DSouza , Nov 18, 2020 :
    1. Open gmail and mke sure it's upto date in terms of update
    2. click on the top left corner on the 3 horizontal lines.
    3. now choose settings.
    4. now on the notification section, choose "inbox notification"
    5. click on "sync messages" and choose "notify for every message".
    This worked for me