3
Gmail notification not showing on OnePlus 7t via OnePlus 6T

  1. Aron_E
    Eclair Oct 21, 2019

    Aron_E , via OnePlus 6T , Oct 21, 2019 :
    My friend just got himself a OnePlus 7t and I met with him today and he was very happy with it but only problem that he didn't get Gmail notifications. I went through his phone trying to find the problem but couldn't find it. Went through his Gmail and notification settings in his phone but couldn't find it.

    Does somebody have a fix for this?
     

    #1
    popers, meetvekaria and TrueBrush like this.
  2. Photoman9988
    KitKat Oct 21, 2019

    Photoman9988 , Oct 21, 2019 :
    It could potentially be battery optimization settings. I had a lot of issues with notifications on my older Huawei p20 Pro, and I found out that it was their overly aggressive battery optimization profile. I had to go to every app that I wanted to receive notifications from and turn off battery optimization.
     

    #2
  3. winsty
    Donut Oct 21, 2019

    winsty , Oct 21, 2019 :
    Do you see the gmail notification in the pull down shade but no icon at the top left?
     

    #3
  4. Aron_E
    Eclair Oct 21, 2019

    Aron_E , via OnePlus 6T , Oct 21, 2019 :
    There is just no notification from Gmail when I send him even after more than an hour
     

    #4
  5. winsty
    Donut Oct 21, 2019

    winsty , Oct 21, 2019 :
    Strange, I had an issue where I wasn't getting notifications (not just Gmail). it would show up in the notifaction shade but not on my lockscreen and no icon. On the notification shade I had to swipe half to the left and click on the cog and change it to important, then they would come through.
     

    #5
    JRock121 likes this.
  6. ngydat
    KitKat Oct 22, 2019

    ngydat , Oct 22, 2019 :
    In my case, I'm not aware of new e-mails unless I open Gmail but there's no sound nor an icon in the notification area (even after I open Gmail).

    Edit : in settings > battery > battery optimisation > press on the 3-dot in the top-right > Advanced optimisation, by default, the adaptive battery toggle and the other one are enabled. Might want to disable them.
     
    Last edited: Oct 22, 2019

    #6
  7. TrueBrush
    Ice Cream Sandwich Oct 23, 2019


    #7
  8. ngydat
    KitKat Oct 23, 2019

    ngydat , Oct 23, 2019 :
    I guess that's the source of the issue but weirdly, on my One Plus 6, I didn't have this issue.

    Edit : I tried what you suggested but either with a 3rd-party launcher or Activity Launcher, the created shortcut doesn't lead to all the apps (I mean it's the same as going in the settings by yourself and check the battery optimization)
     
    Last edited: Oct 23, 2019

    #8
  9. RicardoDimm
    Eclair Oct 23, 2019

    RicardoDimm , via OnePlus 7T Pro , Oct 23, 2019 :
    Yes same here
     

    #9
  10. TrueBrush
    Ice Cream Sandwich Oct 23, 2019

    TrueBrush , Oct 23, 2019 :
    Follow the instruction, it works, I get Gmail notifications now:

    use Activity Launcher to create a shortcut for "settngs$highpowerapplicationsactivity"

    from that shortcut you will see the gmail in the list of apps to not optimise
     

    #10
  11. ngydat
    KitKat Oct 23, 2019

    ngydat , Oct 23, 2019 :
    Even then, I have the issue with other apps and those apps are in the "do not optimise" list.
     

    #11
  12. TrueBrush
    Ice Cream Sandwich Oct 23, 2019

    TrueBrush , Oct 23, 2019 :
    That's true, OnePlus has fundamental issues, amnog the top Android manufacturers: https://dontkillmyapp.com/

    I don't know what's the solution to that, I tried to go the iPhone route and it's worse in different ways, the Gmail app there doesn't even have the label notification option.
     

    #12
  13. RicardoDimm
    Eclair Oct 23, 2019

    RicardoDimm , via OnePlus 7T Pro , Oct 23, 2019 :
    I am sure I follow the instructions correct, but I dont see Gmail and other system apps in the list...
     

    #13
  14. Bala1994
    Cupcake Oct 23, 2019

    Bala1994 , via OnePlus 7T , Oct 23, 2019 :
    I had similar issue with gmail when notification setting inside the gmail app was set to "High Priority Only". Maybe try changing the setting to "All"
     

    #14
  15. LesleySnijder , via OnePlus 7T Pro Haze Blue , Oct 23, 2019 :
    If the icon isn't there in the top screen. Swipe down the notification bar if the notification is there long press on the notification --> press important --> press apply. Solved my missing notification icons in the top notification bar.
     

    #15
    JRock121, Kamarinchev and TrueBrush like this.
  16. TrueBrush
    Ice Cream Sandwich Oct 24, 2019

    TrueBrush , Oct 24, 2019 :
    Thanks, will try as soon as I see the notification.
     

    #16
    LesleySnijder likes this.
  17. ngydat
    KitKat Oct 26, 2019

    ngydat , via OnePlus 7T , Oct 26, 2019 :
    That's the thing though : all my gmail notifications are set as important but still, nothing in the notifications area. For now, I can only check for new mails by opening Gmail which isn't ideal
     

    #17
  18. LesleySnijder , via OnePlus 7T Pro Haze Blue , Oct 26, 2019 :
    I have now the same problem, it could be a bug in the software or from Google's side. I think it is a bug from both sides. Hope the will fix this as soon as possible.
     

    #18
    nofoo likes this.
  19. JRock121
    Donut Oct 26, 2019

    JRock121 , Oct 26, 2019 :
    I had this same exact issue right when I setup the phone so that's the first thing I checked & it solved the issue on Tues.
     

    #19
    LesleySnijder likes this.