49
Google App Crash Hotfix

  1. Reevin
    Cupcake May 21, 2020


    #61
    paritosh9199 likes this.
  2. RobGroen_NL
    Cupcake May 21, 2020

    RobGroen_NL , May 21, 2020 :
    Thanks paritosh9199

    This solved the problem of the Google App crashing as soon as I touched the search baron my OnePlus 5T. I am using the Nova Launcher and I thought that the problem was Nova related. After some investigation I realized that Google App was the problem.

    I send a email to the Google-app support Team with this issue. I hope the add some priority to this issue. (Fingers X)

    Thanks again!
    Now we wait for Google to fix this for real.
     

    #62
    paritosh9199 likes this.
  3. Dikus
    Cupcake May 23, 2020


    #63
    paritosh9199 likes this.
  4. Vér Bence Farkas
    Cupcake May 24, 2020


    #64
  5. Dikus
    Cupcake May 24, 2020


    #65
  6. paritosh9199
    Gingerbread May 24, 2020

    paritosh9199 , via OnePlus 7 , May 24, 2020 :
    @Dickus try this
     

    #66
  7. paritosh9199
    Gingerbread May 24, 2020


    #67
  8. Dikus
    Cupcake May 24, 2020

    Dikus , via OnePlus 5T , May 24, 2020 :
    First of all, thank you for your interest, @paritosh9199. You are very kind to help us.

    I tried your suggestion. If I remove the 999 user, the parallel application is removed too, so I can't open it after removing the user. But the user is gone.

    Then reboot and I install it again through parallel applications. The 999 user is there but OK Google is working now. 🤔
     

    #68
  9. paritosh9199
    Gingerbread May 24, 2020

    paritosh9199 , via OnePlus 7 , May 24, 2020 :
    Hey, just disable all the parallel apps(from settings) and run the commands. it should work then.
     

    #69
  10. jaypabla
    Cupcake May 25, 2020

    jaypabla , May 25, 2020 :
    OnePlus 3t - stock Android 9.0.6

    Google App crashing has been annoying for months, but running the adb command to remove user 999 worked a treat thank you
     

    #70
  11. Maxximuscool
    Jelly Bean May 27, 2020

    Maxximuscool , May 27, 2020 :
    1 week without thetthe problems coming back after this fixed.Google app crashes is nowpnow fixed.
     

    #71
  12. Dikus
    Cupcake May 29, 2020

    Dikus , May 29, 2020 :
    Sorry for the delay to reply and for the long extension of the post. I'm just tried the following steps again:

    1. Show users with adb: There are two users: 0 (with my name) and 999 (parallel aplications)
    2. Go to preferences and untick the paralell application (Tumblr in this case). The paralell application is removed.
    3. Show users with adb: The 999 user is still there.
    4. Remove the 999 user with adb. Success: removed user.
    5. Show users with adb: Only user 0.
    6. Tried Ok Google, but nothing happens. Nevertheless, G icon and microphone works when I touch them and no close suddenly as before.
    7. Reboot phone.
    8. List users with adb: Only user 0.
    9. Ok Google works.
    10. Go to preferences and tick Tumblr again. The paralell aplication is created.
    11. List users with adb: The are two users again: 0 and 999.
    12. Paralell Tumblr works.
    13. Ok Google works.

    14. Second part of the fix: I open paralell tumblr and I close after a few seconds.
    15. Remove the user 999 with adb. Success.
    16. The paralell Tumblr is removed too, I can't open it again.
    17. Go to preferences and paralell applications. Tumblr is ticked.
    18. I untick Tumblr, the application is removed appears in a message.
    19. I tick Tumblr agian, paralell application is created apperas in a message.
    20. I search for the paralell application (it has a little badge) but not open.
    21. Reboot.
    22. I have now two Tumblrs but they are the same (the little badge is dissappeared) , so I go to preferences and repeat untick and tick to create again the paralell tumblr.
    23. Paralell tumbr works...
    24. ... Ok google no works, G no works and microphone no works.

    If I repeat from step 1 to 13, Ok Google and Tumblr work again but there is a moment, I don't know when and why Google stops working.
     
    Last edited: May 29, 2020

    #72
  13. ArmyOfOne
    Cupcake May 30, 2020


    #73
  14. mallorcaben
    Eclair Jun 1, 2020

    mallorcaben , Jun 1, 2020 :
    If I were to factory reset my OP5 and not re install my parallel whatsapp, then would this be ok, would it fix it without editing as above?
     

    #74
  15. paritosh9199
    Gingerbread Jun 1, 2020

    paritosh9199 , via OnePlus 7 , Jun 1, 2020 :
    No it would not fix the problem! You'll have to run those commands again after the reset.
     

    #75
    mallorcaben likes this.
  16. mallorcaben
    Eclair Jun 1, 2020

    mallorcaben , via OnePlus 5 , Jun 1, 2020 :
    ok thanks but my wife has the exact same phone, bought at the same time. she doesn't run parallel apps. she's never had this problem with Google.
     

    #76
  17. paritosh9199
    Gingerbread Jun 1, 2020

    paritosh9199 , via OnePlus 7 , Jun 1, 2020 :
    The problem seems to be with code that manages app permissions. Idk what apps you used but it triggered creation of user 999 (Which in my case was completely automatic). Running those commands fixes the Google app problem and if in future you want to use those parallel apps again you can just turn them in in the setting. (Google app doesn't work when parallel apps are turned on; as user 999 is created again)
     

    #77
    mallorcaben likes this.
  18. mallorcaben
    Eclair Jun 1, 2020

    mallorcaben , via OnePlus 5 , Jun 1, 2020 :
    ok. thanks for the info.
    I just hopes that if I factory reset my phone, it would fix the problem.
    I did this last year and all was fine for a while. I then set up my parallel WhatsApp app and the problem seemed to start again. may just be coincidence.
     

    #78
    paritosh9199 likes this.
  19. paritosh9199
    Gingerbread Jun 1, 2020

    paritosh9199 , via OnePlus 7 , Jun 1, 2020 :
    Sure, if the problem comes back again then you can just run those commands. All the changes made by those commands are completely reversible and would not harm the device in anyway.
     

    #79
  20. Vid80
    Cupcake Jun 7, 2020


    #80