57
Google App Crash Hotfix

  1. mallorcaben
    Eclair Jun 7, 2020


    #81
    ezenna and Dikus like this.
  2. vijayk1989
    Donut Jun 12, 2020

    vijayk1989 , via OnePlus 5 , Jun 12, 2020 :
    Hey thanks paritosh, you've made my day man. I have been struggling with this problem for several days, even months. It worked like anything. Thanks again. [e]1f44c[/e][e]1f44d[/e]
     

    #82
    paritosh9199 likes this.
  3. liv1305
    Cupcake Jun 14, 2020

    liv1305 , Jun 14, 2020 :
    Thanks paritosh. It worked perfectly onto Oneplus 3T. I have tried all others fixes unsuccessfully from last update of Google app.
     

    #83
  4. chupcho
    Cupcake Jun 16, 2020

    chupcho , Jun 16, 2020 :
    This fixes the issue until you re-enable parallel apps :( Isn't parallel apps a feature of oxygenos rather than Android itself?

    edit: the only true fix for this is updating to Android 10. I have done so and this nolonger happens.
     
    Last edited: Jun 19, 2020

    #84
    mallorcaben likes this.
  5. chupcho
    Cupcake Jun 19, 2020

    chupcho , Jun 19, 2020 :
    Thanks!
     

    #85
    mallorcaben likes this.
  6. aaron.sarwal
    Cupcake Jun 28, 2020


    #86
  7. mallorcaben
    Eclair Jun 30, 2020


    #87
  8. mallorcaben
    Eclair Jun 30, 2020

    mallorcaben , Jun 30, 2020 :
    OP5.
    I updated to Android 10 and the problem went away until now, and its much worse.
    Now I cant get Google working at all. App, weather, lens etc. it comes up with "no connection"
    This is only happening on these apps
    How can I reset.
    I wasn't keen before as I run an old Whatsapp dual app but I need Google working again.
    Please advise
     

    #88
  9. mallorcaben
    Eclair Jun 30, 2020

    mallorcaben , Jun 30, 2020 :
    Ive deleted user 999 and disabled parallel apps.
    I cant get the google app news feed to update, Google assistant wont connect nor will google Lens
     

    #89
  10. rabbider
    Gingerbread Jul 13, 2020

    rabbider , Jul 13, 2020 :
    thx, just fixed 3t
    btw on windows 10 if you using PowerShell command should start with ./adb instead adb
     

    #90
    slavekt likes this.
  11. S1595261560529
    Cupcake Jul 20, 2020


    #91
  12. 902msa
    Eclair Aug 3, 2020

    902msa , Aug 3, 2020 :
    wow man. thank you so much so this fix !!!
     

    #92
  13. gravavel
    Froyo Aug 7, 2020


    #93
  14. rahulappala
    Cupcake Aug 21, 2020

    rahulappala , via OnePlus 3 , Aug 21, 2020 :
    Simple solution i tried... It's working... Open google app info.... Clear cache and clear data.... Go to play store.... Uninstall google app.... It shows 'update' option playstore then... Not an install option because google app is inbuilt with OS and playstore only uninstall the update to the app... Now google app works and all it's featured... Important note... Never update google app.... Simple and effective solution
     

    #94
  15. D1587909472845
    Cupcake Aug 27, 2020


    #95
  16. B1595323733240
    Donut Sep 29, 2020

    B1595323733240 , Sep 29, 2020 :
    bro what if I do not run this command but just turn of my parallel app and delete parallel whatsapp and its all data will this help me ?

    Device : OP3T
     

    #96
  17. paritosh9199
    Gingerbread Sep 29, 2020

    paritosh9199 , via OnePlus 7 , Sep 29, 2020 :
    The command needs to run. Parallel apps can't be disabled with running adb command
     

    #97
  18. MostlyVirtual
    Cupcake Oct 30, 2020


    #98
  19. N1616458181146
    Cupcake Mar 23, 2021


    #99
    L1593636646232 likes this.
  20. Oxymarvin
    Cupcake Mar 23, 2021

    Oxymarvin , via OnePlus 8 , Mar 23, 2021 :
    Like the user above me n1616458181146. Also started getting these exact symptoms one OnePlus8 Oxygen 11.0.4.4. IN21BA yesterday. Seems to maybe affect a wider range of Google apps than the 2020 forums and threads suggest. Basically all Google Search Widget and Assistant linked apps. (although chrome is stable when searching)..... Failing whenever "manage my Google account" is evoked in any G app and not even loading the manage Google account from Android settings
    1616478284101.jpg

    1616478115644.jpg
    Reverting affected Google apps to remove previous play updates doesn't seem to work as per this thread. And goes beyond Android 9 so the previous advice to upgrade to 10 no longer applies...

    As before clearing cache, force stop / disconnect / phone reboot and unlinking and relinking Google account either does nothing or can fix the issue briefly/momentarily. For me the issue seems to start again when Gmail decides it wants to spam me with the "meet now" link to Duo at which point Gmail starts falling over on launch.
    1616478813786.jpg

    Also consistently seeing similar launch crash on one non-google app (The Guardian) where clearing storage/cache ore reinstalling that app temporarily briefly fixes. Could be the same thing?

    Trying to avoid a full factory reset so that's the only thing I haven't tried so far.

    New here (first post) so not sure if this warrants an entirely new thread tagged for Android 11 + OP8 onwards? - going to try the ADB suggestion here and see if it is the same variation of parallel ID error as this hotfix first.
     

    Attached Files: