2
Google Assistant default applications via OnePlus 7T

  1. schiv
    Froyo Nov 20, 2019

    schiv , via OnePlus 7T , Nov 20, 2019 :
    Hi guys! I don't usually post here a lot, I do prefer reading but in this case any question like mine hasn't been asked before.
    I would to know now to change default application in Google assistant. That's because I do have two cameras on my phone, Stock cam and Gcam, when I asked Google "Take a picture" it asked me which application I wanted as default and I pressed Gcam accidentally. Of course, as you can understand, I don't want Gcam as default... I looked over the internet but there wasn't any info about it, so here I am.
    Thank you in advance to all of you [e]1f60a[/e]
     

    #1
    scp41 and Z1574084206589 like this.

  2. #2
  3. schiv
    Froyo Nov 20, 2019

    schiv , via OnePlus 7T , Nov 20, 2019 :


    R1571501042766

    try to delete the cache of the application. and restart​


    How do I cancel cache? Because the application of Google assistant is built-in so it doesn't show up anywhere in the app list.
     
    Last edited: Nov 20, 2019

    #3
  4. schiv
    Froyo Nov 20, 2019

    schiv , via OnePlus 7T , Nov 20, 2019 :
    Update: Since cleaning cache directly of the application, I mean, I don't know how to do it, I cleared cache of the entire phone, but it didn't work, so I tried unistalling the application and re-installing it, with the hope Google assistant would have asked me which camera use as default, but it didn't work, it just opened gcam again.
     

    #4
  5. scp41
    KitKat Nov 20, 2019

    Last edited: Nov 20, 2019

    #5
    katiaap and beckham64 like this.
  6. schiv
    Froyo Nov 20, 2019

    schiv , via OnePlus 7T , Nov 20, 2019 :
    I doesn't show anything... At least on community app.

    Edit: on webpage it shows the video. Yeah, i have already tried it but it shows camera is not default app for anything.
     

    #6
    scp41 likes this.
  7. scp41
    KitKat Nov 21, 2019

    scp41 , Nov 21, 2019 :
    You've already managed to solve the camera problem
     

    #7
    katiaap and beckham64 like this.
  8. schiv
    Froyo Nov 21, 2019

    schiv , via OnePlus 7T , Nov 21, 2019 :
    No, unfortunately I haven't found a solution yet. I have contacted the technical support but they neither knew the solution and told me to wait because they would have contacted the advanced technical support or smt like that.
     

    #8
    scp41 likes this.
  9. ngydat
    KitKat Nov 21, 2019

    ngydat , Nov 21, 2019 :
    If I understood you correctly, you just want to set the stock camera app as the default one ? Simple : settings > apps and notifications > default apps > camera, choose the stock cam
     

    #9
  10. schiv
    Froyo Nov 21, 2019

    schiv , via OnePlus 7T , Nov 21, 2019 :
    No, that's not the problem. I want to set the default application on Google assistant. I have already tried that way but even if I chose the stock camera if I call "open camera" it still opens the other.
     

    #10
  11. Z1574084206589
    Cupcake Nov 22, 2019

    Z1574084206589 , Nov 22, 2019 :
    Open Settings, then open Apps & notifications, finally open Default apps, there is Camera app, you can change it. Hope it can help you.
     

    #11
  12. ngydat
    KitKat Nov 22, 2019

    ngydat , Nov 22, 2019 :
    That’s exactly what I suggested. Please check the previous messages before suggesting the same thing
    @schiv did you think of doing this : long press on gcam > app info, in one of the sections (can’t remember which one) you can reset the default behaviour of the app so next time you ask google assistant, you’ll get asked again what camera you want to use
     

    #12
    Z1574084206589 and schiv like this.
  13. schiv
    Froyo Nov 22, 2019

    schiv , via OnePlus 7T , Nov 22, 2019 :


    ngydat

    That’s exactly what I suggested. Please check the previous messages before suggesting the same thing
    @schiv did you think of doing this : long press on gcam > app info, in one of the sections (can’t remember which one) you can reset the default behaviour of the app so next time you ask google assistant, you’ll get asked again what camera you want to use​


    Already tried [e]1f614[/e]

    https://streamable.com/r0ihp

    EDIT: Moreover, now, if I say, as in the video "take a picture" it opens gcam instead if I say "open camera" it opens default camera...
     

    #13
    Z1574084206589 and scp41 like this.
  14. scp41
    KitKat Nov 23, 2019

    scp41 , Nov 23, 2019 :
    Do you already have a solution
     

    #14
    katiaap likes this.
  15. schiv
    Froyo Nov 24, 2019

    schiv , via OnePlus 7T , Nov 24, 2019 :
    Hey! Sorry for the late reply. No, not yet. Actually I think neither the technical support knows about it.
     

    #15
    scp41 likes this.
  16. scp41
    KitKat Nov 24, 2019

    scp41 , Nov 24, 2019 :

    When you have an answer, share it here.
    Thank you
     

    #16
    katiaap likes this.
  17. schiv
    Froyo Nov 24, 2019


    #17