0
Google assistant not working when phone is locked via OnePlus 8T

  1. Devmalya
    Donut Nov 4, 2020

    Devmalya , via OnePlus 8T , Nov 4, 2020 :
    Hi,

    So when the screen is off for more than 5 mins, Google assistant doesn't work. "Ok Google" works, but it doesn't recognise instructions and says "you seem to be offline, check your internet". My wifi is fully functional and connected. It works just fine as soon as the screen is unlocked.
    Is the phone disconnected from wifi when locked?
    Looking for a solution because it's a very important part of my daily workflow, while working from home.

    OnePlus 8T , Oxygen OS 11.0.2.3.KB05DA
     

    #1

  2. #2
    eastbay likes this.
  3. Devmalya
    Donut Nov 5, 2020

    Devmalya , via OnePlus 8T , Nov 5, 2020 :
    1604573362378.jpg
    It's already enabled, no luck. :-/
     

    #3
  4. lybo_spurs
    Cupcake Jan 24, 2021


    #4
  5. Ravsa
    Froyo Jan 24, 2021

    Last edited: Jan 25, 2021

    #5
  6. DarshanMeniya
    OnePlus TV Product Ninja 2021 Jan 24, 2021


    #6
  7. Devmalya
    Donut Jan 24, 2021


    #7
  8. StefanStark
    Ice Cream Sandwich Jan 24, 2021

    StefanStark , via OnePlus 8T Aquamarine Green , Jan 24, 2021 :
    Make sure your data connection is set to always on.

    There are some battery saving settings that cut data when locked but you won't get notification then.

    Make sure Google assistant is allowed to use data in the background. Check for necessary rights granted.
     

    #8
  9. ghanshyam860
    Donut Jan 25, 2021


    #9
  10. Devmalya
    Donut Jan 28, 2021

    Devmalya , via OnePlus 8T , Jan 28, 2021 :
    Everything is set and checked. This is an issue with IPv6 connections ( wifi or mobile data ).
    No one can do anything until and unless Google fixes this with some OS level code change or whatever.
     

    #11
  11. panpaliyah
    Cupcake Apr 22, 2021

    panpaliyah , Apr 22, 2021 :
    Turn off the Battery Optimization for Following apps :
    Google
    Google Assistant

    From Settings-> Battery -> Battery Optimization.
     

    #12
    Devmalya likes this.
  12. PavanSimhadri
    Froyo Apr 23, 2021


    #13
  13. Devmalya
    Donut May 6, 2021

    Devmalya , via OnePlus 8T , May 6, 2021 :
    This worked, this worked guys. :)
     

    #14
    Ssinha2103 likes this.
  14. Ssinha2103
    Cupcake Jun 15, 2021

    Ssinha2103 , Jun 15, 2021 :
    Turn off the Battery Optimization for Following apps :
    Google
    Google Assistant

    From Settings-> Battery -> Battery Optimization.

    This worked in my Oneplus Nord . Thanks.
     

    #15
    Devmalya likes this.
  15. O. Priya
    Ice Cream Sandwich Jun 15, 2021

    O. Priya , Jun 15, 2021 :
    You cannot disable it like that. If your voice commands are registered even then you cannot as Google voice support for off-screen is not supported in many devices. Only selected phone like Pixel, Samsung have that.
     

    #16