1
Google Assistant not working with latest versions via OnePlus 8 Pro

  1. curiousiguana
    Cupcake May 23, 2021

    curiousiguana , via OnePlus 8 Pro , May 23, 2021 :
    Anyone else having trouble with Assistant? When I activate it, it says to set Google as the default voice assistant.

    It is set as the default voice assistant.

    I have to roll back all updates to the Google app to get it to work again.
     

    #1
    I1594492095627 likes this.
  2. rashimkavel7
    Cupcake May 23, 2021

    Last edited: May 24, 2021

    #2
  3. juttuka.pavan
    Honeycomb May 24, 2021

    juttuka.pavan , May 24, 2021 :
    Clear the cache & clear data of google app and retrain your voice in Google assistant feature that is in Google settings.
     

    #3
  4. curiousiguana
    Cupcake May 25, 2021

    curiousiguana , via OnePlus 8 Pro , May 25, 2021 :
    I've tried clearing cache and data. Goes back to being broken after working for a short while.

    It's not the voice model, works on my home devices and it's the button which fails.
     

    #4
  5. I1594492095627
    Eclair Jun 1, 2021

    I1594492095627 , Jun 1, 2021 :
    Same here. I don't want to activate it by voice, I always used to activate it with button, it worked perfectly, but now it's broken.
    Data and cash wipe fix it until reboot, but it's a bad workaround, cause I need reboot my phone every day. And now we probably need to wait for fix for 2 months at least :(
     

    #5
  6. Tee_Eee_Bee
    Ice Cream Sandwich Jun 1, 2021

    Tee_Eee_Bee , Jun 1, 2021 :
    You can activate the assistant by swiping up from the bottom corner to the center of the screen.
     

    #6
  7. I1594492095627 , via OnePlus 8 Pro , Jun 1, 2021 :
    No matter how you activate it, it says that Assistant isn't set by default, but it is actually set.
     

    #7
  8. Tee_Eee_Bee
    Ice Cream Sandwich Jun 1, 2021

    Tee_Eee_Bee , Jun 1, 2021 :
    As far as I know, there are a couple of settings that need to be checked (if you haven't already checked them):
    Settings > Apps & Notifications > Default Apps:

    Screenshot_20210602-082557.jpg

    Screenshot_20210602-082436__01.jpg


    Search for "default digital" in Settings - then go to Default digital assistant app:

    Screenshot_20210602-082427__01.jpg
     
    Last edited: Jun 1, 2021

    #8
  9. I1594492095627
    Eclair Jun 2, 2021

    I1594492095627 , Jun 2, 2021 :
    Thanks for trying to help, but these settings of course are checked. As I said, the Assistant is set by default, settings were not changed since 11.0.5.5., but in 11.0.6.6 it's just broken. When I activate Assistant, it says that it need to be set by default first, but it is set by default already for sure. The only thing that helps is to clear data of the Assistant app, but the problem returns after reboot, so you need to clear app after every damn reboot, it's very inconvinient. I suppose it's oxygen update has caused this problem, maybe some bug in firmware or during update.
    As far as I understand, you don't have this problem on 11.0.6.6, right?
     

    #9
  10. Tee_Eee_Bee
    Ice Cream Sandwich Jun 2, 2021

    Tee_Eee_Bee , via OnePlus 8 Pro , Jun 2, 2021 :
    I'm on Open Beta 10 and I don't have this problem
     

    #10
  11. Dimi Dimitrov
    Gingerbread Jun 11, 2021

    Dimi Dimitrov , Jun 11, 2021 :
    I have same problem after 11.0.6.6
    I don't have data in assistant app, and I'm total stuck.
     

    #11
  12. I1594492095627
    Eclair Jun 11, 2021

    I1594492095627 , via OnePlus 8 Pro , Jun 11, 2021 :
    Even if you clear data, il works until reboot. After reboot you have to clear data again
     

    #12
  13. I1594492095627
    Eclair Jun 11, 2021


    #13
  14. Dimi Dimitrov
    Gingerbread Jun 11, 2021

    Dimi Dimitrov , Jun 11, 2021 :
    I read in internet,that other brand have same problem.
    Maybe is Google issues.Hard reset have chance to solve problem,but now I don't want reset my phone.
    Edit:Can you send me screenshot what data you wipe to make work again.
    Thanks.
     

    #14
  15. I1594492095627
    Eclair Jun 12, 2021

    I1594492095627 , via OnePlus 8 Pro , Jun 12, 2021 :
    I don't think it's google, cause on oos 11.0.5.5 and below it worked without issues.
    Sure, there are some screenshots:

    1623483337670.jpg

    1623483337695.jpg

    1623483337715.jpg
     

    #15
    Dimi Dimitrov likes this.
  16. Dimi Dimitrov
    Gingerbread Jun 14, 2021 at 1:42 AM

    Dimi Dimitrov , Jun 14, 2021 at 1:42 AM :
    I think find solutions.
    Go to search button write assistant, will find two options digital default app,and default digital assistant app.
    Choice Google in both,like screenshot.
    Then go to and setup assistant.
    And will work.
     

    Attached Files:

    Last edited: Jun 14, 2021 at 2:02 AM

    #16
    I1594492095627 likes this.
  17. I1594492095627
    Eclair Jun 14, 2021 at 4:06 PM

    I1594492095627 , via OnePlus 8 Pro , Jun 14, 2021 at 4:06 PM :
    I've already rolled back to 11.0.5.5))
    So you can confirm it works even after reboot?
     

    #17
  18. Dimi Dimitrov
    Gingerbread Jun 14, 2021 at 8:12 PM

    Dimi Dimitrov , Jun 14, 2021 at 8:12 PM :
    For me it worked after restart. I'm on 11.0.6.6
     

    #18
    I1594492095627 likes this.
  19. harleyquinn07
    Cupcake Jun 17, 2021 at 10:21 AM

    harleyquinn07 , Jun 17, 2021 at 10:21 AM :
    it's because of the latest update even i'm facing the same issue.
     

    #19