0
Google ate my battery juice till death

  1. Maxby23
    Froyo Jun 11, 2017

    Maxby23 , Jun 11, 2017 :
    On recently updated OOS Open Beta 17 (directly updated from stable to beta without formatting or dirty flash you can say) and it has been seen many times that my battery drained till auto switch off without even using my device! do anyone faced the same ?

    1497171396603.jpg

    1497171396752.jpg
     

    #1
  2. adpro
    KitKat Jun 11, 2017

    adpro , Jun 11, 2017 :
    Clear app data of Google app once and see.

    Disable it if issue still persists.
     

    #2
  3. meatandy
    Oreo Jun 11, 2017


    #3
  4. F_Junaid_Khan_kKSE
    Honeycomb Jun 11, 2017

    F_Junaid_Khan_kKSE , Jun 11, 2017 :
    you r mental u went from stable to beta that means ur saying urself wht u did wrong and now complaining .. who are u ?


    do a clean install
     

    #4
    darius1988 and JoshuvaAntony like this.
  5. G_JZ_Chan_OfOd
    Eclair Jun 11, 2017


    #5
  6. F_Yasiru_Wickramarathna_
    Gingerbread Jun 11, 2017


    #6
  7. darius1988
    KitKat Jun 11, 2017

    darius1988 , Jun 11, 2017 :
    From beta to stable always clean instal, I repeat you ALWAYS clean instal, wipe data and cache!
     

    #7
  8. gencho81
    Donut Jun 11, 2017

    gencho81 , Jun 11, 2017 :
    nothing to do with coming from stable to beta.complete wipe needed only from beta to stable.
    This happened to me also after goggle app update before.check goggle settings specially ok goggle settings. after update it was on even if I have it off before that.
    check it.if it's in turn it off and chosen cache in recovery.
    then you should be fine.
     

    #8
  9. peaky blinders
    Jelly Bean Jun 11, 2017


    #9
    G_Tran_Anh_Tuan_ChNK likes this.
  10. G_Tran_Anh_Tuan_ChNK
    Cupcake Jun 11, 2017

    G_Tran_Anh_Tuan_ChNK , Jun 11, 2017 :
    I have a similar problem. Disabling Google App solved it. You can also disable Feed (Google Now) and everything in Google Activity Controls in Google App Settings. These settings are intentionally hard to find.
     

    #10
    peaky blinders likes this.
  11. Maxby23
    Froyo Jun 11, 2017

    Maxby23 , Jun 11, 2017 :
    Chill out dude! I knew what i did. Did i mentioned any complain about it i just randomly asked peeps out there that did anyone faced the same or my case is special one you fool! I wonder why such people exists #peace_out
     

    #11
  12. Maxby23
    Froyo Jun 11, 2017

    Maxby23 , Jun 11, 2017 :
    Exactly! Its not a big deal to always clean flash while stable to beta. The main thing is to do this when coming back to stable from beta.
     

    #12
  13. SatriaPr
    Ice Cream Sandwich Jun 11, 2017

    SatriaPr , Jun 11, 2017 :
    Actually it should have been fine I don't know what caused so, clear system cache from recovery, disable Google and re enable it, see if problem persist.
    If so the best option is to clear system setting (all apks will be uninstalled without deleting its data and your internal) when you install that certain apk again it'll be just like when you left it out
     

    #13
  14. G_Tran_Anh_Tuan_ChNK
    Cupcake Jun 12, 2017

    G_Tran_Anh_Tuan_ChNK , Jun 12, 2017 :
    You can install BetterBatteryStats, give it permissions via adb and track down the problem from there. For me, Google set up a lot of alarms to wake up the phone, it's like 10 to 20 times per minute. It doesn't make much sense for me because Google Feed doesn't update frequently. There must be a bug of some kind with the Google App.
     

    #14