0
Google Camera Pie Beta Fix

  1. MarcoTerzulli
    Froyo Dec 12, 2018

    MarcoTerzulli , Dec 12, 2018 :
    Hi everyone,
    I have a problem with the GCam port after Pie update. The front camera doesn't work properly with HDR enabled, it only captures a fuchsia crap.

    One of my friends, who has installed the beta too, is facing the same issue. I tryed the chinese hydrogen beta, a few weeks ago, and i thought it was a bug of that beta.

    Does anyone have found a fix for this? I tried a lot of portings from different developers and options, but no one works for now. I also tried some magisk modules (the fix for Oreo doesn't make the camera work totally).

    So, if you're interested in GCam, NOT UPDATE to Pie beta for now since it seems like there's no solution for now.
    1544623105841.jpg
     

    #1
  2. K1525658097128
    Froyo Dec 13, 2018


    #2
  3. Adidz
    Gingerbread Dec 14, 2018


    #3
  4. Rahul Patki
    Donut Dec 15, 2018

    Rahul Patki , Dec 15, 2018 :
    Problem:
    It is caused by one plus 5t's default camera libraries and requires camera2Api...


    I fixed it as follows (works on both Oreo stable 8.1 and open beta 20(pie))
    Official site for 5t camera port:

    https://www.celsoazevedo.com/files/android/google-camera/

    Solution:

    ***requires root-systemless(magisk)***

    ***Pre requisites: TWRP, unlocked bootloader, magisk:
    follow this awesome guide for pre requisites:

    https://forums.oneplus.com/threads/oneplus-5t-unlock-bootloader-flash-twrp-root-nandroid-efs.685403/

    ***

    ***
    solution starts here:
    step 1)Download the latest pixel 3 camera port from:

    https://drive.google.com/file/d/1SssPCvt5s4TKlbXHtf7wmFn_FRDiTUIP/view?usp=drivesdk

    step 2)
    flash latest twrp& take a backup of current system

    step 3)
    >Flash magisk 15.3
    [download from source repo GitHub(I prefer using PC, fastboot,adb as in the guide link--prerequisites)]

    >Update magisk within the manager to 18 or latest version *instead of flashing latest magisk directly*


    final step):
    in the magisk manager go-to:
    downloads>search"5t">

    install-- one plus 5t camera libraries fix(v2.5-OB17)>
    done

    ***
     
    Last edited: Dec 15, 2018

    #4
  5. X1517396854503
    Honeycomb Jan 2, 2019

    X1517396854503 , Jan 2, 2019 :
    Brother any fixes or a modded apk for the non rooted users?
     

    #5
    slowmachine likes this.
  6. MANYA_1999
    Honeycomb Jan 2, 2019

    MANYA_1999 , Jan 2, 2019 :
    There is magisk module for pie,uninstall dotfix 2.5 and install dotfix 3.0
     

    #6
    mojoyoyo77 likes this.