0
Google Messages No Notifications via OnePlus 3

  1. TheGrayWolf81
    Froyo Jan 10, 2020

    TheGrayWolf81 , via OnePlus 3 , Jan 10, 2020 :
    Hello.

    I have been experiencing issues in regards to notifications from the default Android Messages app from Google. Often I will receive an SMS message but I won't receive a notification or notification sound, leaving me unaware that I received a message. Recently, I have been receiving notification sounds but no notification is present anywhere.

    I have disabled battery optimization for the app but it yields no change.

    Has anyone else been experiencing this issue? I would like a fix because I am constantly missing people's texts, sometimes not seeing them until days later.
     

    #1
  2. Paschfire
    KitKat Jan 11, 2020

    Paschfire , via OnePlus 3T , Jan 11, 2020 :
    And do you have GM set as the default Message App?

    Within;

    System Settings > Apps & Notifications > Default Apps > SMS App{choose default App from overflow menu}

    Google Messages is also not the default messaging app, OnePlus includes their own Messaging App within stock OOS.
     

    #2
  3. C1571440528997
    Cupcake Jan 29, 2020

    C1571440528997 , Jan 29, 2020 :
    I am having this same problem. I suddenly stopped receiving any notifications of SMS, both audio and notice at top of screen. I've checked everything I could find and am even started using OnePlus stock messaging app to see if that would fix it and no change. I'm also no longer receiving most notifications for apps: calendar, social media, Ring, Alexa, Disneyland, timer.... I don't know what to do. I've tried everything I could find on the internet to fix it.
     

    #3
  4. Sidharth_9282
    Gingerbread Jan 29, 2020

    Sidharth_9282 , Jan 29, 2020 :
    just go to settings > apps and notifications > notifications there will be a option allow notification dots on it.... and then go back to apps and notifications, click see all apps... in top right corner there will be 3 dots click reset app preference...
    I think this will solve your problem
     

    #4
  5. meeksmen
    Cupcake Oct 2, 2020

    meeksmen , Oct 2, 2020 :
    my own solution was to go into Parameters/Apps & Notifications/Messages/Notifications/
    Then on this page, there is one first parameter "Display Notifications" that has a switch, and the second one is "Incoming Message" and has a box to tick; you must select the text, not the box, and then another page opens, here it is !
     

    #5