1
Google Play Services draining my battery

  1. Mr Fiddle
    Eclair Jan 14, 2019

    Mr Fiddle , Jan 14, 2019 :
    Hi! I've made a post before about this but I deleted it, so that's why I'm making a new one.
    Google Play Services (and Facebook too) have been draining my battery these last days, since I got back to school I get 50% with only one hour and half of screen on time. My phone is new, I have less than a month with it, I got it since Christmas, and it's kind of weird what is happening, a week ago I used to get like seven hours of screen on time with 20% remaining.
    I've tried wiping cache twice and didn't help, another solution to this? One thing I've been noticing is that that my device notify me sometimes about GPS using Play Services.
    1547507586921.jpg

    1547507586945.jpg

    1547507586967.jpg
     

    #1
    adi1001 likes this.
  2. Aman bajaj
    Eclair Jan 15, 2019

    Aman bajaj , Jan 15, 2019 :
    Nobody is going to help because no one know the reason
    and i think every 6t user is facing this issue
    May be its a bug .
     

    #2
  3. Aashish.007
    Ice Cream Sandwich Jan 15, 2019

    Aashish.007 , Jan 15, 2019 :
    try uninstalling and reinstalling it after disabling device administrator.
    you can also try out the beta of play services if you wish from the play store.
     

    #3
  4. Mr Fiddle
    Eclair Jan 18, 2019

    Mr Fiddle , Jan 18, 2019 :
    I've tried play services beta, updating Facebook and also tried OxygenOS beta and it still with the same problem :( I think I'm gonna wipe my phone completely, I was actually thinking about rooting it, so
     

    #4
  5. JelleZon
    KitKat Jan 18, 2019

    JelleZon , Jan 18, 2019 :
    same problem here
    but the play services are only active when the device is used.
    that is strange

    1547811240915.jpg
     

    Attached Files:


    #5
  6. Mr Fiddle
    Eclair Jan 19, 2019

    Mr Fiddle , Jan 19, 2019 :
    I think I've solved the problem, in my case, seems like it's not play services at all, it's Facebook, I restricted it on battery settings and seems like it's not draining it any more, but I'm not sure at all, I have to fully charge my battery and use it as a normal day and see if it's solved.
    1547935197263.jpg
     

    #6
  7. LennartG
    Eclair Aug 20, 2019

    LennartG , Aug 20, 2019 :
    1566323027232.jpg
    Did you manage to fix it? I seem to have the same problem (see the attached screenshot).
     

    #7
  8. Matteo8719
    Gingerbread Aug 21, 2019


    #8
    LennartG likes this.
  9. Panos1988
    Froyo Aug 21, 2019

  10. LennartG
    Eclair Aug 21, 2019

    LennartG , Aug 21, 2019 :
    Thx
    Yes, it worked! Wiped the cache and turned off GPS for one day. Now it's back to normal :)
     

    #10
  11. kondapakasharathchandra
    Gingerbread Aug 23, 2019


    #11