1
Google Play Store not downloading

  1. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    Hello, guys,

    I have a big problem with Play Store. It is not downloading my apps. It just says it's pending or downloads like small amount of an app and stops. I tried everything I could find on Google like clearing caches, restarting, clearing data even factory reset. It works fine on Beta release, but I want to have stable. Any suggestions?
     

    #1
    marcozwetsloot likes this.
  2. Kytharsis
    Marshmallow Aug 15, 2019

    Kytharsis , Aug 15, 2019 :
    Do you have automatic app updates enabled?
     

    #2
  3. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    Yes. My apps are updated. It doesn't download new apps.
     

    #3
  4. Kytharsis
    Marshmallow Aug 15, 2019

    Kytharsis , Aug 15, 2019 :
    No, no. Automatic updates. Meaning updating your apps in the background automatically which will prevent any parallel updates till it finishes. You can turn this off in the Play Store settings.
     

    #4
  5. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    I disabled it, restared the phone and it's downloading for now. Thank you!
     

    #5
    Kytharsis likes this.
  6. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    It downloaded a few apps and stopped again. And it's like this everytime.
     

    #6
  7. marcozwetsloot
    Donut Aug 15, 2019

    marcozwetsloot , Aug 15, 2019 :
    I have same issue as from yesterday evening when I switched back to stable release from open beta.
    Switching off automatic downloads doesn't do anything.
     

    #7
  8. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    I switched back to stable too. I had stable in the past with same problem and decided to try beta. On beta everything works fine, but i want to be on stable, because beta seems a little bit laggy and battery drains fast.
     

    #8
  9. anupritaisno1
    KitKat Aug 15, 2019

    anupritaisno1 , Aug 15, 2019 :
    This is a very old bug in the play store that hasn't been fixed to this date

    Basically the play store sometimes thinks a download is in progress when there is no download actually going on and refuses to download apps

    The only solution seems to be waiting until it fixes itself
     

    #9
    limas, the_o2 and Kytharsis like this.
  10. the_o2
    Marshmallow Aug 15, 2019

    the_o2 , Aug 15, 2019 :
    It is well known play store issue, it get fixed automatically within day or two...
     

    #10
    limas likes this.
  11. limas
    Donut Aug 15, 2019


    #11
  12. marcozwetsloot
    Donut Aug 15, 2019


    #12
  13. the_o2
    Marshmallow Aug 15, 2019

    the_o2 , Aug 15, 2019 :
    Yep,
    Or just force stop the play store app
    Press and hold the Play store app --> Click on app info --> Force stop

    And then again open the app and try to update or download
    See if this fixes your problem.
     

    #13
    Captkirkusa and Kytharsis like this.
  14. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    I tried these things, but it fixes it temporarily for a few minutes.
     

    #14
  15. the_o2
    Marshmallow Aug 15, 2019

    the_o2 , Aug 15, 2019 :
    Btw what is your play store version?
     

    #15
  16. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    1565878607108.jpg
    This one.
     

    #16
    the_o2 likes this.
  17. the_o2
    Marshmallow Aug 15, 2019


    #17
  18. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    Okey, thanks [e]1f44d[/e]
     

    #18
  19. HaroldNL
    Froyo Aug 15, 2019

    HaroldNL , Aug 15, 2019 :
    I had that problem too when switching from Beta to Stable, my solution was a clean install of the Rom again. (maybe waiting a few days could have worked, but I couldn't wait that long :) )
     

    #19
  20. limas
    Donut Aug 15, 2019

    limas , Aug 15, 2019 :
    How did you install clean rom?

    I installed rollback package then updated via OTA, but it still didn't worked then i did a factory reset and still didn't worked properly.
     

    #20