0
Google Voice Calls Do Not Ring on OnePlus 7t

  1. markeattnet
    Froyo Feb 29, 2020

    markeattnet , Feb 29, 2020 :
    I'm kind of at my wit's end here, hopefully, someone on the forum can help. I can't get Google Voice calls to ring on my new OP 7t phone. I've tried what I think are all the solutions from the various Google forums, connect to Hangouts, uninstall Hangouts, delete your forwarding number, re-enter your forwarding number, everything I could find. Calls to my device's number are just fine. Calls to the GV number show up on screen but do not ring on the phone and eventually just go to voice mail if I don't answer them. I'm sure I'm missing something easy, but I'm lost and could use any ideas to get those calls to ring as they have on every other device I've ever had. Thanks in advance for any assistance you can provide.
     

    #1
  2. GeekOnTheHill
    Honeycomb Feb 29, 2020

    GeekOnTheHill , Feb 29, 2020 :
    I had so many problems with GV that I gave up and ported the number out to AT&T. When a free app is so bad that you move it to a paid service, that says something about the app.

    From what I was able to gather, Google Voice vomits on dual-SIM phones (which is kind of ironic considering that Google makes dual-SIM phones). If I completely removed the second SIM, I had no problem. But if it was installed, even if turned off, it caused GV to barf in all manner of ways.

    I suggest disabling battery optimization for Google Voice. I also had Digital Wellbeing and Zen Mode disabled, but I don't know whether they had anything to do with anything. (It wouldn't surprise me if it did. Digital Wellbeing breaks all kinds of things.) With that configuration, I was able to receive calls, even with two SIMs installed; but it wasn't able to place calls unless the second SIM was completely removed.

    Richard
     

    #2
    markeattnet likes this.
  3. markeattnet
    Froyo Feb 29, 2020

    markeattnet , via OnePlus 7T , Feb 29, 2020 :
    thank you for the tip. I hadn't even thought about the battery optimization. I will give it a try and see what happens.
     

    #3
  4. gperez22
    Cupcake Feb 14, 2021

    gperez22 , Feb 14, 2021 :
    Make sure that you also have the following permissions ENABLED, under Apps->Voice->Permissions:
    - Microphone
    - Phone
    - Contacts (yes, without this you don't get incoming calls notifications, so you can't pick up)
     

    #4