1
GPS issue

  1. egyeagle
    Eclair Apr 8, 2015

    egyeagle , Apr 8, 2015 :

    Thank you
     

    #61
  2. kcai
    Cupcake Apr 14, 2015


    #62
  3. paulx290
    Cupcake May 19, 2015

    paulx290 , May 19, 2015 :
    I'm not sure if the problems reported with OPO gps are the same or have the same fix as none of the ones on here have worked for me. I was constantly having to reboot my phone to get a gps fix no matter what setting or permission settings I used. However I noticed on occasions GPS worked fine but after noting settings each time this happened and compared them to when it fails I found one setting which appeared to effect the GPS function and that was the Bluetooth ..... If Bluetooth was on GPS failed, Off worked fine so I have tried this out for a few days now and I feel sure now there is an issue with Bluetooth and GPS ...atleast in my case but some of you could try it and see if its a problem for you too
     

    #63
  4. paulx290
    Cupcake May 21, 2015

    paulx290 , May 21, 2015 :

    OK scratch that now working fine even with Bluetooth ... no idea why I haven't changed anything or installed anything new and no doubt when I need it to work it will play up again
     

    #64
  5. Ronpeleg
    Cupcake Jun 30, 2015

    Ronpeleg , Jun 30, 2015 :
    Surprisingly this worked for me. Thanks so much! Strange how that would change GPS capabilities!
     

    #65
  6. Yateesh Kumar
    Cupcake Jul 1, 2015


    #66
  7. Ronpeleg
    Cupcake Jul 3, 2015

    Ronpeleg , Jul 3, 2015 :
    Hi everyone. I sent a note to oneplus support and within 24 hours they responded with a method that worked for me. Here it is:
     

    #67
  8. Ronpeleg
    Cupcake Jul 3, 2015

    Ronpeleg , Jul 3, 2015 :
    Hi everyone. I sent a note to oneplus support and within 24 hours they responded. This actually worked for me (I'm on AT&T in the US). Here's exactly what he suggested:
    Settings>> Privacy>> Privacy gaurd>> click the 3 vertical dots on the top right of the screen>> enable show system apps>> grant location access to Android System, Location Services, Maps, and Street Views.

    Hope this helps others fix the problem because I love the OPO and wanted it to work for everyone. Good luck!
     

    #68
  9. ACORE
    Donut Jul 5, 2015

    ACORE , Jul 5, 2015 :
    Okay I'm really really out of ideas right now. My GPS worked fine for a half year I had the phone but then the GPS just stopped working.

    Here is what's happening:
    - I get my current location wherever I am with Google Maps
    - Sports Tracker gets the location too
    - My Compass is working fine (on maps the arrow turns and with gps status it shows that it is fine)

    While these things are happening the apps dont follow my tracks, they dont locate my current location if I move around or go biking/walking

    What've I've tried already:
    - Used many GPS fix apps there is, non of them works (clearing AGPS and getting the data)
    - Gone through the Privacy settings and checked that everything has been allowed to use location
    - I've factory reseted my phone
    - I rooted my phone and
    - Switched gps.conf files from the /system/etc folder
    - Downloaded FasterGPS and get the newest conf -file.

    What I've not tried yet:
    - Install another rom (like downgrade to kitkat)

    I'm really frustrated and don't know what to do anymore. What the hell is going on even, why do I get the current location but it won't track my movement? It's like the GPS is working for a second and then losts all the satellites. I've tested with one program that if I get the satellites to connect and it doesn't get them at all. It finds like 20 of them but any of them works.

    If ANYONE has any other suggestions I'd be glad to take them. I just would like it to work because GPS is one of the features I'd really like to use on my phone..

    EDIT:

    Okay. Now I downloaded GPS Status software (again) and went out for a walk and test it out. I got the satellites on my phone by resetting and getting the AGPS files. I tested out the sports tracker and I got it to track me (wow). But here is the funny thing. If I shut down the sports tracker and restarted it (or started a new workout) I had to get the track files through the GPS Status app again to it to work. That's f***ing bs. Unbeliveable if you ask me. But anywhoo I don't know what my actions worked it out but atleast I got it to somewhat working. I REALLY hope oneplus crew is going to fix these kind of unfunctionalities to the Oneplus 2.
     
    Last edited: Jul 5, 2015

    #69
  10. dressanderc
    Donut Aug 3, 2015

    dressanderc , Aug 3, 2015 :
    I've attempted a number of things I've found across the internet the last two days to try and remedy this issue. I've finally came across a replacement gps.conf file, that for whatever reason, is giving me odd results. I'm not entirely sure what is going on. It pulls a latitude/longitude, that when google searched, puts me exactly where I am, yet the GPS status app cannot get any "lock" on a satellite when 20+ are visible.
     

    #70
  11. jrap1707
    Cupcake Aug 4, 2015

    jrap1707 , Aug 4, 2015 :
    Going to settings - apps - Google Maps
    And clicking on "uninstall updates" solved it for me.
     

    #71
  12. Ukali
    Jelly Bean Aug 7, 2015

    Ukali , Aug 7, 2015 :
    Same problem still :eek:..
     

    #72
  13. diegonator
    Cupcake Aug 7, 2015

    diegonator , Aug 7, 2015 :
    Same problem, I have a new opo (3 days) and is totally imposible to lock a satélite, when 34 are visible. However, my wife's opo 6 months old works fine.
     

    #73
  14. noelbah
    Cupcake Aug 15, 2015

    noelbah , Aug 15, 2015 :
    Did you notice what apps or games that causing your gps not work?!
     

    #74
  15. tanja3981
    Froyo Aug 15, 2015

    tanja3981 , Aug 15, 2015 :
    Well, for me is wasn't defnitely not any app I had.
    Factory reset worked and the problem is gone since then.
     

    #75
  16. 724428
    Donut Sep 14, 2015

    724428 , Sep 14, 2015 :
    My GPS was working perfectly in last 2 weeks, I switched Cyanogen OS 12.1, and now my gps isn't showing my current location. I think it's ROM problem.
     

    #76