21
[GUIDE FOR MAC] How to Unlock Bootloader, Install Custom Recovery & Root (Macbook Pro)

  1. quintes_
    Cupcake Nov 15, 2015


    #61
  2. Funk Wizard
    Lollipop Moderator Nov 15, 2015

    Funk Wizard , Nov 15, 2015 :
    Refer to both the threads this one and the X threads, basic commands are the same you just have to incorporate them on mac
     

    #62
  3. quintes_
    Cupcake Nov 15, 2015

    quintes_ , Nov 15, 2015 :
    I'll give it a try, one more thing. Which app/program do you advice to backup my device in terms of the whole os.
     

    #63
  4. Funk Wizard
    Lollipop Moderator Nov 15, 2015

    Funk Wizard , Nov 15, 2015 :
    With Root Nandroid / Titanium Backup, without root Helium
     

    #64
  5. Josh Lo
    Cupcake Dec 9, 2015

    Josh Lo , Dec 9, 2015 :
    i went up to the installing the custon recovery, now im stuck what do I do. And I can't find the root directory.
     

    #65
  6. Funk Wizard
    Lollipop Moderator Dec 9, 2015

    Funk Wizard , Dec 9, 2015 :
    Root directory?
    You just have to flash via fastboot, check videos on YouTube for your reference
     

    #66
  7. mihirb85
    Cupcake Dec 28, 2015

    mihirb85 , Dec 28, 2015 :
    I unlocked the bootloader, but the recovery does not install. It says it has installed but the same cyanogen stock recovery keeps appearing. As a result no root. Can someone help. I am on macbook pro.
     

    #67
  8. Funk Wizard
    Lollipop Moderator Dec 28, 2015

    Funk Wizard , Dec 28, 2015 :
    After the twrp flash u have to force the first boot
    Long press power plus Vol down, when the device reboots and u see the Oneplus logo release the power button but still keeping the Vol down pressed. Then you would see twrp welcome screen, release the Vol down and enjoy rooting
     

    #68
    mihirb85 likes this.
  9. jaysmoke
    Gingerbread Mar 16, 2016

    jaysmoke , Mar 16, 2016 :
    Hi, am also trying to figure this out. What videos are you refering to. Can't find any link.
     

    #69
  10. kanagadeepan
    KitKat Mar 17, 2016


    #70
  11. kamil
    Donut Apr 25, 2016

    kamil , Apr 25, 2016 :
    Hello, I can't unlock my bootloader. I did all the steps but when I Type ./fastboot oem unlock, it's very rapid but nothing changed when I restart my phone. Data isn't deleted. All the same like before ./fastboot oem unlock. Can you help me. Thanks you in advance. Sorry for my english.
     

    #71
  12. OPFanBoyTillEnd
    Honeycomb May 1, 2016

    OPFanBoyTillEnd , May 1, 2016 :
    Any chances anyone found where to get the Mac bundle with adb and fast boot in it? Everything I can get from Google seems to not have those in it.
     

    #72
  13. Arach
    Donut May 18, 2016

    Arach , May 18, 2016 :
    Hey - I'm having issues, I don't have anything bundled with the ADB, and as such can't get past the first step. Help?

    OnePlus 2, OOS 3.0 Beta, El Capitan.
     

    #73
  14. mazhit
    Cupcake May 19, 2016

    mazhit , May 19, 2016 :
    Same here!
     

    #74
  15. elliotsl
    Cupcake May 19, 2016


    #75
  16. syp1996
    Cupcake May 21, 2016

    syp1996 , May 21, 2016 :
    @Kishore830 go into tools folder you will find android then open it in terminal and then you will get an option to download the sdk platform tools there you go !! if u dont get it again text me
     

    #76
  17. Funk Wizard
    Lollipop Moderator May 24, 2016


    #77
  18. screamroad
    Cupcake Jul 1, 2016

    screamroad , Jul 1, 2016 :
    Hey, mate! Thanks for the ultimate guide! I'm from Google here, as a user of Xiaomi phone. How do you think, Is it possible to unlock bootloader on my phone, using Mac by this guide?
     

    #78
  19. neerajaggarwal
    Cupcake Jul 1, 2016

    neerajaggarwal , Jul 1, 2016 :
    Can i install XIAOMI'S MIUI8 on my OnePlus 3, if yes can someone share a video for that. and also how can i reinstall OnePlus 3 stock oxygen os back on my device..
     

    #79
  20. rishi pahwa1
    Cupcake Sep 18, 2016

    rishi pahwa1 , Sep 18, 2016 :
    i am having the same problem, were you able to find any solution? , it boots into custom recovery everytime (tried Vol down + power and then holding Vol down after logo appears it still boots into custom recovery), i guess after the command './fast reboot' oneplus 2 updates itselfs to custom recovery because unlike oneplus one i dont think oneplus 2 developer option contains 'Disable CM Revovery' option (does it?).

    Also, at the very first time i tried the steps after ./fastbook oem unlock, there was a message on my OPT to erase data , i don't know what did it erase because i seem to have every folder (it only deleted apps)?.

    i am on Oxygen OS 3.1.0, if that helps. Can somebody please help?
     

    #80