150
[GUIDE] [General] How to make LTE faster and fixes all your problems!

  1. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    This POST IS MEANT FOR AT&T/T- Mobile USA OR INTERNATIONAL USERS WHO ARE HAVING PROBLEMS GETTING LTE ON THEIR DEVICE!!

    Do not use APN's down below if you are on SUBSIDIARY of ATT/T-mobile (ie. StraightTalk, Net 10, MetroPCS, Cricket Wireless)!!
    (PM me and I will give them to you or use this link http://www.unlockit.co.nz/mobilesettings/ to find them yourselves) Find the correct apn for your carrier and the location your are in, THEN USE THIS TUTORIAL!! You can try it on other carriers but I am not responsible if you loose connectivity issues or have no internet.

    If you need APN settings for other carriers, PM ME!!

    Steps for OnePlus 2, OnePlus One, and potentially international phones:
    1. The OnePlus One and 2 IMEI is supported by AT&T so give them a call and tell them to enter the IMEI.
    2. Insert your Sim Card into the phone, wait for it to connect to your provider.
    3. Input the APN Settings into Setting/More/Cellular Networks/Access Point Names
    4. Once you see your carrier in the notification bar, follow these steps:
    Go to the phone dial, type in *#*#4636#*#* and a tab should pop up. Click phone information and scroll down. Click and change the preferred network to LTE/GSM auto (PRL) then click home.
    5. Go back to Settings/More/Cellular Networks/and click on Preferred network type and select LTE.
    YOUR status bar should say LTE on the notification bar now and your SPEEDS should be twice as fast.
    Pictures included!! Screenshot_2014-08-03-20-18-21.png Screenshot_2014-08-03-20-18-34.png Screenshot_2014-08-03-20-18-21.png Screenshot_2014-08-03-20-18-34.png

    Note: In my pictures, I have the setting as LTE/GSM/CDMA, this is an error please use the correct setting above. (It should be LTE/GSM auto (PRL))

    For AT&T users: Both the OnePlus One and OnePlus 2 detects APN of your carrier once you put the sim into the phone. If it doesn't you have to input it and the settings you need to input are below. If you have a bunch of APN settings in Access Point Names then I recommend to select ATT Phone as it is the fastest in my testing!! If the APN 'ATT Phone' was an option already present when opening the menu in 'Access Point Names', then you DO Not need to enter the below setting.

    APN Name: ATT Phone
    APN: phone
    Proxy: Not set
    Port: Not set
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mmsc.mobile.att.net
    MMS proxy: proxy.mobile.att.net
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: default,supl,mms,hipri
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: Unspecified
    MVNO type: None
    Thanks to @laanrobe

    If you encounter MMS issues, more information about fixing the issue is below.
    https://forums.oneplus.net/threads/fix-at-t-mms-downloading-error.209871/

    PS: OnePlus One and OnePlus 2 imei is now approved by att. They will give you LTE speeds!! (I heard OnePlus imei isnt in T-mobile database) Correct me if I'm wrong!!

    Note: Coming from a non LTE branded phone, IE. iPhone 4/4S, Nexus 4, international phone. Go to AT&T Store and request them to update your plan and sim to an LTE one. Depending on your phone, it will either need to be a micro-sim or a nano-sim. (OnePlus One = Micro-sim, OnePlus 2 = Nano-sim)

    HOW TO SAVE THE PREFERRED NETWORK SETTING YOU CHOSE!! On the phone information click in the right upper hand corner on the three dots.Then click on select radio band and choose your country's band either European or American. (In the OnePlus 2 case, its USA Band) (Sometimes selecting automatic can save your preferred setting even after a reboot!) Also make sure your WiFi is off and that you are on LTE! If it doesnt stick keep trying until it does!! Thanks to @Derfus

    FOR T-MOBILE USA USERS
    YOUR APN IS DIFFERENT, THIS IS THE ONE YOU NEED TO BE USING!!!
    Name: T-Mobile US LTE
    APN: fast.t-mobile.com
    Proxy: Not set
    Port: Not set
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC:http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMS proxy: Not set
    MMS port: Not set
    MCC: 310
    MNC: 260
    Authentication type: Not set
    APN type: default,supl,mms,hipri,dun
    APN protocol: IPv4/IPv6
    APN roaming protocol: IPv4
    APN enable/disable: APN enabled
    Bearer: Unspecified
    MVNO type: None
    MVNO value: Not set

    Note: Coming from a non LTE branded phone, IE. iPhone 4/4S, Nexus 4, international phone.

    Visit the link down below to get more info on how to connect, transfer your existing device sim to a OnePlus phone, and for more information.


    https://forums.oneplus.net/threads/tutorial-how-to-use-the-opo-on-t-mobile-usa.64071/


    PS: LOOK AT THIS WEBSITE FOR APNS http://www.unlockit.co.nz/mobilesettings/ OR PM ME!!

    EDIT: FASTEST LTE Speed I HAVE SEEN ON AT&T IN LA!!
    Screenshot_2014-12-24-17-49-58~2.jpg

    Edit: Many people have been requesting to put the StraightTalk APN Settings and I have decided to put them in this thread.

    So you will need to find out what SIM card you activated Straight Talk with (T-Mobile or AT&T)
    Personal Preference: I would choose AT&T as it covers more coverage nationwide.
    Go to this link scroll to 1:20 and watch the the very few seconds.
    Once you figured out what sim you activated or going to activate the OnePlus phone.
    Put in these APNs!!

    Straight Talk AT&T APN
    APN Name: Straight Talk
    APN: tfdata
    Proxy: Not set
    Port: 80
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC: http://mms-tf.net
    MMS proxy: mms3.tracfone.com
    MMS port: 80
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: Not set
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: Unspecified
    MVNO type: None

    Straight Talk T-Mobile APN
    APN Name: Straight Talk
    APN: wap.tracfone
    Proxy: Not set
    Port: 8080
    Username: Not set
    Password: Not set
    Server: Not set
    MMSC:
    http://mms.tracfone.com
    MMS proxy: Not set
    MMS port: Not set
    MCC: 310
    MNC: 410
    Authentication type: Not set
    APN type: Not set
    APN protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: Unspecified
    MVNO type: None


    EDIT: Cricket Wireless APN Settings
    APN Name: Internet
    APN: ndo
    Proxy: Not Set
    Port: Not Set
    Username: Not Set
    Password: Not Set
    Server: Not Set
    MMSC: http://mmsc.aiowireless.net
    MMS Proxy: proxy.aiowireless.net
    MMS Port: 80
    MCC: 310
    MNC: 150
    Authentication type: Not Set
    APN type:default,mms,fota,hipri,supl

    Note: on the above APN type be sure to enter it exactly as it is listed and don't include any spaces!

    If anybody has questions feel free to PM me. Also anything you would like me to add or fix in this thread, just leave a comment down. Also state if this guide worked for you. Thanks
     
    Last edited: May 4, 2016

    #1
  2. jshjx
    Jelly Bean Aug 4, 2014


    #2
    slipin3 likes this.
  3. bestlands
    KitKat Aug 4, 2014


    #3
    Ivanpoocky13 and jshjx like this.
  4. bestlands
    KitKat Aug 4, 2014


    #4
    Joyyy likes this.
  5. Greenarcher707
    Gingerbread Aug 4, 2014


    #5
  6. woody
    Eclair Aug 4, 2014

    woody , Aug 4, 2014 :
    I used this and I now don't have any data service.....:(

    EDIT: now I do have data service back. looks like it took a while before the settings took. But I have no reference on whether this had improved my LTE speed or not, unfortunately.
     
    Last edited: Aug 5, 2014

    #6
    whytefyre, malidan, Raptor619 and 2 others like this.
  7. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    Try rebotting your phone
     

    #7
    luiguy501 likes this.
  8. chrism1548
    Ice Cream Sandwich Aug 4, 2014


    #8
  9. TheRad1
    Honeycomb Aug 4, 2014

    TheRad1 , Aug 4, 2014 :
    You know, I thought I had already done this when I first got my OpO, but seeing your thread reminded me to check it and nope, it wasn't set right. Thanks for the reminder. Here's shots of the difference. It's late in the evening here too so the towers have less traffic but still a substantial gain! Screenshot_2014-08-04-00-01-47.png

    After checking my results I see when I changed it the first time in the regular settings menu under mobile networks. It jumped from 7 to 21. But in the hidden menu the change was much more significant. And additional note is DO NOT CHANGE ANYTHING ELSE IN THAT HIDDEN MENU OR YOU'LL LOSE SERVICE!
     
    Last edited: Aug 4, 2014

    #9
    reghunath.ek, sarin.j, Joyyy and 8 others like this.
  10. Anessa
    Honeycomb Aug 4, 2014

    Anessa , Aug 4, 2014 :
    Whats the science behind this?
     

    #10
  11. woody
    Eclair Aug 4, 2014

    woody , Aug 4, 2014 :
    I did reboot, and shutdown as well. still no avail. I used one of the other tutorials when I was not getting data from switching on iphone nano sim to OPO.
     

    #11
  12. carl_gadget
    Gingerbread Aug 4, 2014

    carl_gadget , Aug 4, 2014 :
    Cough. This is what it is on now and my options. It seems to me to be the best setting already? Screenshot_2014-08-03-20-52-58.png
     

    #12
    Sabbu likes this.
  13. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    Your welcome please continue to spread the word with the link
     

    #13
    Sabbu and dmicohen like this.
  14. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    I had that I had my signal dropping so the one I changed to now is for me the best one
     

    #14
  15. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    Try calling att and giving them your OnePlus imei
     

    #15
    rayandreas likes this.
  16. carl_gadget
    Gingerbread Aug 4, 2014

    carl_gadget , Aug 4, 2014 :
    The option you said is not showing.
     

    #16
    jhoang900 and uchi like this.
  17. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    Scroll up and down in that popup you'll find it
     

    #17
    jdf likes this.
  18. gmo8492
    Lollipop Aug 4, 2014

    gmo8492 , Aug 4, 2014 :
    So this is for At&t...Well my speeds are pretty fast enough on T-mobile and the One should already be provisioned to run on the best networks on At&t.
     

    #18
    rayandreas likes this.
  19. bestlands
    KitKat Aug 4, 2014

    bestlands , Aug 4, 2014 :
    Yes but I've your not getting fast speeds you can try this
     

    #19
  20. gmo8492
    Lollipop Aug 4, 2014

    gmo8492 , Aug 4, 2014 :
    Cool, anything helps.
     

    #20
    blikie, reghunath.ek and rayandreas like this.